1. ThatsAnotherJ13

    Newcomer

    Joined:
    Sep 13, 2020
    Messages:
    1
    Country:
    United States
    Hey. I keep getting this error. How do I fix it?
     

    Attached Files:

    adamsky_ likes this.
  2. Mamothstard

    Mamothstard Advanced Member
    Newcomer

    Joined:
    Oct 25, 2015
    Messages:
    76
    Country:
    France
    I think your black screen issue may be tied to a specific game you're trying to launch.

    There are ways to troubleshoot that issue. look it up here.

    I would really appreciate an answer to that question too.

    OMG thanks so much for that info. That makes total sense now.
     
    Last edited by Mamothstard, Sep 17, 2020
  3. adamsky_

    adamsky_ Newbie
    Newcomer

    Joined:
    Sep 9, 2020
    Messages:
    7
    Country:
    Ireland
    I've the same problem. I've tried a plenty potential solutions, nothing works :(
    „C:\Users\adamo\AppData\Local\Temp\WiiVCInjector\SOURCETEMP\ISOEXTRACT”
     
    Last edited by adamsky_, Sep 17, 2020
  4. Mamothstard

    Mamothstard Advanced Member
    Newcomer

    Joined:
    Oct 25, 2015
    Messages:
    76
    Country:
    France
    Are you guys sure you have at least .NET Framework v4.6.1 like specified by the author?
     
  5. adamsky_

    adamsky_ Newbie
    Newcomer

    Joined:
    Sep 9, 2020
    Messages:
    7
    Country:
    Ireland
    I've installed the newest one today: .NET Framework 4.8 Developer Pack Offline Installer. It didn't help.
     
  6. Mamothstard

    Mamothstard Advanced Member
    Newcomer

    Joined:
    Oct 25, 2015
    Messages:
    76
    Country:
    France
    Tried running as admin? Maybe the program lacks rw priviledges
     
  7. adamsky_

    adamsky_ Newbie
    Newcomer

    Joined:
    Sep 9, 2020
    Messages:
    7
    Country:
    Ireland
    I've tried run as admin. I was changing the folders names, their location. I used CCleaner before new attempts.
    However it seems like the new process, even with the new wbfs file (new game) starts from approx. 60% (the green progress bar). Where is stored the partially finished file? I think it's not fully removed after the failed trial.
     
  8. Mamothstard

    Mamothstard Advanced Member
    Newcomer

    Joined:
    Oct 25, 2015
    Messages:
    76
    Country:
    France
    Maybe cleaning that temp folder could be a good idea.

    I'm sorry. I can't really help you.
    I've only done injection of GC games.
    What are you trying to inject?
     
  9. adamsky_

    adamsky_ Newbie
    Newcomer

    Joined:
    Sep 9, 2020
    Messages:
    7
    Country:
    Ireland
    That temp folder is actually deleted automatically once I'll choose "close" on the error message.

    I've tried 2 games so far, Just Dance 2020 and Wii Sports Wii Sports Resort.
     
  10. Mamothstard

    Mamothstard Advanced Member
    Newcomer

    Joined:
    Oct 25, 2015
    Messages:
    76
    Country:
    France
    haven't tried any wii games. I'll try that tonight if to see if that works.
     
  11. adamsky_

    adamsky_ Newbie
    Newcomer

    Joined:
    Sep 9, 2020
    Messages:
    7
    Country:
    Ireland
    This time I've used the modified version - TeconMoon's WiiVC Injector 3.0.1 mod 12 but still getting the same error:

    Code:
    (9/11)Processing game for NFS Conversion...
    !! wit: ERROR #74 [CAN'T OPEN FILE] in SetupReadSF() @ src/lib-sf.c#447
    !!      Can't open file:
    !!      /cygdrive/d/wii/3/WiiVCInjector/SOURCETEMP/wbfsconvert.iso
    wit: Command 'EXTRACT' returns with status #74 [CAN'T OPEN FILE]
    !! wit: ERROR #74 [CAN'T OPEN FILE] in SetupReadSF() @ src/lib-sf.c#447
    !!      Can't open file: /cygdrive/d/wii/3/WiiVCInjector/SOURCETEMP/ISOEXTRACT
    wit: Command 'COPY' returns with status #74 [CAN'T OPEN FILE]
    Processing game for NFS Conversion terminated unexpectedly: Nie można odnaleźć części ścieżki „D:\wii\3\WiiVCInjector\SOURCETEMP\ISOEXTRACT”.

    EDIT:
    Solved, everything works. For some reason wbfs file needs to be converted to the iso file first and then it could be processed with no errors. I've used Wii Backup Manager for the wbfs to iso conversion.
     
    Last edited by adamsky_, Sep 18, 2020
    Mamothstard likes this.
  12. gurnben

    gurnben Newbie
    Newcomer

    Joined:
    Sep 20, 2020
    Messages:
    7
    Country:
    United States
    Hello all!

    TLDR: Black Screen Issues running injected gamecube games using TeconMoon's injector, games work via directly running nintendont and even a nintendont forwarder. Wii injects also working - checking in for any new suggestions/developments and here to help debug if I can!

    I'm incredibly new to the Wii U Homebrew/Softmodding community and I've recently run into some issues with the dreaded black screens when attempting to run WiiVC injected gamecube games (injected using TeconMoon's wonderful injector program). I'll provide as much detail below as I can having collected some of the concerns from various other threads from this forum, reddit, and elsewhere.

    System:
    32GB Wii U Deluxe (from the Mario & Luigi pack - to date the system)
    Running 5.5.3
    (further details on request)

    Modding timeline/configuration:
    1. Received switch, followed wiiu-dot-hacks-dot-guide (new user, woo!) to install CFW, Homebrew Channel, etc. Also follow the vWii modding guide completely.
    2. Installed homebrew on the vWii via the vWii homebrew channel.
    3. Installed a prebuilt Nintendont forwarder for Wii U (I've misplaced the forum thread where I picked it up). Forwarder works flawlessly.
    4. Verified multiple GameCube titles via Nintendont via forwarder - ISOs from Vimm's Lair, but can experiment with direct backing up disks if that would provide any valuable alternatives
    5. Built a WiiVC application for Super Paper Mario using an ISO from Vimm's Lair which worked beautifully
    6. Built WiiVC applicatoins for numerous GameCube titles, installed on Wii U via Homebrew Channel, all attempts black screened. I had to unplug the console to reboot.
    7. Note: all above steps were loaded to a Samsung 64GB Evo SD card. All software and games were loaded from the SD card. Note 2: All attempts to install Wii and GC WiiVC games were installed to NAND.

    Solutions I've Tried Unsuccessfully:
    1. Deleting nincfg.bin and re-creating by generating it in nintendont direclty
    2. Deleting nincfg.bin and using a nincfg found online
    3. Deleting nincfg.bin and generating via TeconMoon's injector
    4. Disabling autoboot (successfully booted into nintendont, but didn't achieve the goal of booting direct to the game, achieves the same goal as a forwarder).
    5. Using a custom forwarder (pointed to my forwarder, same result as #4 unsurprisingly!)
    6. Enabling or disabling gamepad
    7. Reinstalling Nintendont on vWii using the SD manager in TeconMoon's injector

    Conclusion (see: Cry for Help)
    Any further suggestions on how I could get GameCube WiiVC games running on my WIi U using TeconMoon's injector or other manual injection methods (specificaly, should I attempt the steps documented by piratesephiroth- can't link, too new to the forum)? At the moment I can play GameCube games without issue but I would love to get WiiVC up and running because it makes for a much more elegant experience! Any ways I can assist in debugging or contribute?
     
    Last edited by gurnben, Sep 20, 2020
  13. 64bitmodels

    64bitmodels GBAtemp Advanced Fan
    Member

    Joined:
    Aug 1, 2019
    Messages:
    741
    Country:
    United States
    I've got the injector working now- it makes a wup file to install but now i've got problems concerning wup installer GX
    Each time i try to install the rom the thing give me a 0xFFFCFFE9 error, at least on USB
    when i try it on NAND however the thing just stays on 0 percent. this has not happened with any other wup file i have tested, from the injector or from wii u usb helper
     
  14. Sonofabel

    Sonofabel Newbie
    Newcomer

    Joined:
    Sep 21, 2020
    Messages:
    1
    Country:
    United Kingdom
    Where are the actual instructions?
     
  15. Mamothstard

    Mamothstard Advanced Member
    Newcomer

    Joined:
    Oct 25, 2015
    Messages:
    76
    Country:
    France
    Somewhere on a GBATemp post that dates back from 2017 are the info for vWii injection with this tool. I started here.

    @gurnben have you checked if your game is in the compatibility list?
    https://wiki.gbatemp.net/wiki/WiiU_VC_Wii_inject_compatibility_list

    There is also another tutorial linked here. Frankly, I find that the info for vWii injection is few and far between.

    So far I've had luck with only modding my Wii U and injecting only NTSC Wii and GC games in progressive scan (even though I have a PAL console). I have not modded my vWii in any way for now.
    Also I've only used games that either I dumped myself with cleanrip or 1:1 images from Vimm's (that I also own but can't rip cuz my wii drives are dead and gone by now).

    It's really hit & miss I believe.

    @64bitmodels what did you try to install? Where did the game come from?
     
    Last edited by Mamothstard, Sep 21, 2020
  16. 64bitmodels

    64bitmodels GBAtemp Advanced Fan
    Member

    Joined:
    Aug 1, 2019
    Messages:
    741
    Country:
    United States
    Smash bros brawl, and vimms lair
     
  17. Mamothstard

    Mamothstard Advanced Member
    Newcomer

    Joined:
    Oct 25, 2015
    Messages:
    76
    Country:
    France
    Images from vimm's lair should work.
    Did you create it as a retail injection?
    upload_2020-9-22_0-36-5.png

    Never tried to install on nand nor SD so I can't help you on that side.
    Should work though.
     
  18. gurnben

    gurnben Newbie
    Newcomer

    Joined:
    Sep 20, 2020
    Messages:
    7
    Country:
    United States
    @Mamothstard Thanks for the reply! I'm only having issues with GameCube injection (namely DoubleDash, Paper Mario, Mario Party 4-7, Animal Crossing), all Wii injeciton has worked flawlessly! I have a sinking suspicion that the issue lies in the handoff from the injection and my installed nintendont on the vWii!

    Do you happen to know if GameCube injections collide if you have nintendont preinstalled on the vWii?
     
    Last edited by gurnben, Sep 22, 2020
  19. gurnben

    gurnben Newbie
    Newcomer

    Joined:
    Sep 20, 2020
    Messages:
    7
    Country:
    United States
    Update: I've found an (inconvenient) way to make my GameCube injects work - I have to:
    1. run Haxchi
    2. load into the soft-modded vWii
    3. load HBC in vWii
    4. load nintendont
    5. return to the Wii menu
    6. return to the Wii U menu
    7. run Haxchi again

    and finally the GameCube injects will work.

    Needless to say, I would love to hear if there are any alternative fixes to this. I've seen numerous users in this thread and others reporting that this procedure also worked for them and would love to help get to the bottom of it!
     
  20. SpicyMcHagis

    SpicyMcHagis Member
    Newcomer

    Joined:
    Jan 12, 2016
    Messages:
    12
    Country:
    Canada
    My injects all work great but as soon as I try my GameCube controller adapter I get a black screen and it won't boot the game.

    I have the black plug in the back port. The grey plug is plugged into the wall. Did I set up something incorrectly when creating the inject?
     
    gurnben likes this.
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - [RELEASE], Injector, Homebrew