[RELEASE] WiiVC Injector Script (GC/Wii/Homebrew Support)

Discussion in 'Wii U - Hacking & Backup Loaders' started by TeconMoon, Sep 9, 2017.

  1. EmulateLife

    EmulateLife GBAtemp Addict

    Member
    4
    May 30, 2016
    United States
    You could try converting the ISO to wbfs and retrying http://www.wiibackupmanager.co.uk/

    If that doesn't work, I would try another ISO.

    Another thing make sure the ISO doesn't have any special characters in the name, or the folder that has the ISO (If there is one) same thing. It conflicts with the injector. If there is a special character just rename it without it and you might not even have to convert to wbfs, ISO should work.
     
    Last edited by EmulateLife, Jul 8, 2019
  2. pdog128

    pdog128 Newbie

    Newcomer
    1
    Jul 8, 2019
    United States
    It's already a wbfs (the iso is another game), and there are no special characters. :( I suppose I'll keep looking. Thanks, though.
     
  3. hemi426

    hemi426 GBAtemp Regular

    Member
    4
    Mar 16, 2018
    Belgium
    do you have enough space on your computer ,needs space available to make and swap the file
     
  4. MartyDreamy

    MartyDreamy "Need a ride, handsome?"

    Member
    7
    Jul 1, 2015
    Italy
    Raccoon City
    I have the same issue. Windows 10, Latest version of the program (3.0.1) . I have all the versions of net framework installed on my pc. I can't convert any wii or gamecube game. I tried to rename the iso with a sinple name (ex. game.iso) but it doesn't work. I tried to use both iso and wbfs file but it gives me this error
    "Could not find a part of the path C:\Users\Martina\AppData\Local\Temp\WiiVCInjector\SOURCETEMP\ISOEXTRACT."
     
  5. hemi426

    hemi426 GBAtemp Regular

    Member
    4
    Mar 16, 2018
    Belgium
    just a few thoughts
    maybe you can try to install(and run) wiivc as administrator and put everything on the same drive.?
    anti-virus?
    try to run it in compatibility mode (for win 7,8.1)(right click .exe file)
     
  6. MartyDreamy

    MartyDreamy "Need a ride, handsome?"

    Member
    7
    Jul 1, 2015
    Italy
    Raccoon City
    It's all in the same drive, yes, i have enough space avaiable (around 150gb free), yes i tried to open in as admin and i tried to run it in compatibility mode (i tried 7,8.1) and i also disabled windows defender since i don't have an antivirus
     
  7. EmulateLife

    EmulateLife GBAtemp Addict

    Member
    4
    May 30, 2016
    United States
    People with that problem in the past had to solve it by using another computer and we found no solution that I know of. Do you have another computer you can try it on?

    If not you can try making another account on the same computer and try it.

    — Posts automatically merged - Please don't double post! —

    You could also try this

    [​IMG]
     
  8. YukidaruPunch

    YukidaruPunch Advanced Member

    Newcomer
    1
    Oct 24, 2017
    Brazil
    I've a question. Is there any, any way I can play Donkey Kong Country Returns without the motion controls using this?

    I know there's a gecko code for it, but - as far as I know - there's no way of patching it directly into the .iso, is there? I don't think I could use these codes on my Wii U, considering this. Is there literally any way for it to be achieved?
     
  9. EmulateLife

    EmulateLife GBAtemp Addict

    Member
    4
    May 30, 2016
    United States
    There's a post in this thread somewhere that tells you how to patch the ISO to use the gamepad but I can't find it.
     
  10. hemi426

    hemi426 GBAtemp Regular

    Member
    4
    Mar 16, 2018
    Belgium
    i was looking for the the previous version but i can find it anymore so i have no idee what the problem is the only think i found that still gives you an error is this
    • At least .NET Framework v4.6.1 (Windows 8 & 10 also need the .NET Framework 3.5 feature enabled)
     
  11. MartyDreamy

    MartyDreamy "Need a ride, handsome?"

    Member
    7
    Jul 1, 2015
    Italy
    Raccoon City
     
  12. hemi426

    hemi426 GBAtemp Regular

    Member
    4
    Mar 16, 2018
    Belgium
    Then i have no idee what's the problem.maybe if you find the original release you can try that.it's more work and you have to manualy rename the games but it's basically the same
    Some Guy also said he was able to fix it by putting it on the c and not in Anny folder.and you need Java 8 aswel
    Hope you can make it work.
     
    Last edited by hemi426, Jul 10, 2019
  13. hemi426

    hemi426 GBAtemp Regular

    Member
    4
    Mar 16, 2018
    Belgium
    update1: may won to try this :Go to C:\Users\YOURPCUSERNAMEHERE\AppData\Local\Temp\ and delete the WiiVCInjector folder. some guys fixed a similar problem whit that
     
  14. VatoLoco

    VatoLoco Don't crush that dwarf, hand me the pliers.

    Member
    7
    Jan 29, 2008
    United States
    Ya Cant Get There From Here
    https://gbatemp.net/attachments/dkrc-cc-patch-rar.104407/
     
  15. pdog128

    pdog128 Newbie

    Newcomer
    1
    Jul 8, 2019
    United States
    I got mine to work. I used WiiBackupManager to convert it from a wbfs to a wbfs. I'm new to this and have no idea what I'm doing, but it worked. Afterwards, it recognized it no problem.
     
  16. AtomicSpatula

    AtomicSpatula Newbie

    Newcomer
    1
    Jul 11, 2019
    Bahamas, The
    Hi everyone I'm having a problem getting this to work fully. I have a nintendont forwarder made with this tool using the wii homebrew injection which works fine. But if I make a forwarder with the GC retail option and open it I get a black screen, however if I open the nintendont forwarder first and reach the sd/usb menu, then return to the wiiu homepage and open up the game injection again it loads up fine. Any ideas how to fix this so I don't have to open nintendont first? Thanks
     
  17. EmulateLife

    EmulateLife GBAtemp Addict

    Member
    4
    May 30, 2016
    United States
    Do you have nincfg.bin on your sd card?

    Also could be because you need to run CFW before you run your inject.
     
    Last edited by EmulateLife, Jul 12, 2019
  18. AtomicSpatula

    AtomicSpatula Newbie

    Newcomer
    1
    Jul 11, 2019
    Bahamas, The
    I have nincfg on the root, I'm assuming that's where it needs to be? And I use coldboot so cfw launches when I boot it but I'll try running homebrew channel and then the forwarders and see if that works.

    Also might be worth mentioning when I get the forwarders working by launching nintendont if I just power the wiiu off and then back on again they still work but if I remove the sd card or power supply then I have to do the process again.
     
    Last edited by AtomicSpatula, Jul 12, 2019
  19. EmulateLife

    EmulateLife GBAtemp Addict

    Member
    4
    May 30, 2016
    United States
    Not necessary if you're running CBHC you only need to run one CFW.

    — Posts automatically merged - Please don't double post! —

    If you have the space or if you can create the space install a GC game to your internal and see if it works without going the nintendont first.

    Try unplugging your external and install to nand.

    — Posts automatically merged - Please don't double post! —

    Just want to make people aware who are having problems that this is not a perfect tool and the guy who created it himself called it 'horrible" and long ago abandoned it. So the only people are helping you are people who use it like you. It even mentions the above users Gamecube black screen problems.

     
    Last edited by EmulateLife, Jul 12, 2019
  20. AtomicSpatula

    AtomicSpatula Newbie

    Newcomer
    1
    Jul 11, 2019
    Bahamas, The
    Well yeah but I figured it was worth a shot. But like you said, wouldn't work, didn't work.


    Sorry but what do you mean install to internal? If you mean install to nand when using wupinstaller I always install to nand rather than usb, I'd prefer to keep everything to an sd card but I'll try with the usb to see that fixes things.

    If I launch one of my injections without an sd card an error pops up saying "boot.dol not found" and then restarts the console. Despite this i'm still not entirely sure whether the problem is going from the wiiu menu to nintendont or from nintendont to the game. I'm just wondering what processes occur when starting nintendont that would cause the injections to work after I've launched it and backed out that don't happen when I just use my injections, something with ios58 maybe?

    No of course 100% agree, wasn't trying to be a jerk or anything just noticed this wierd thing which I don't see any others mentioning and thought it was worth a mention.
     
Loading...