1. BBking83

    BBking83 GBAtemp Advanced Fan
    Member

    Joined:
    Oct 23, 2008
    Messages:
    676
    Country:
    Well, it depends what you want.

    The idea behind this, is that the cIOSes are untouched so you can use most HB apps, such as Dop-IOS, after the update (given you have cIOS installed before the update) to do as you wish.

    Trucha signig will fix the SD menu.
     
  2. Jacobeian

    Jacobeian GBAtemp Advanced Maniac
    Member

    Joined:
    May 15, 2008
    Messages:
    1,889
    Country:
    Cuba
    what happen if a patched IOS70 is already installed (before updating the system menu) ? Did it get overriden by your update or does the fact version number are the sames ensure it won't be re-updated ?
    Since it's probably overwritten, it could be a good idea to first check if IOS70 is already installed before downloading it again ? This can be done in a few lines of code... I think it's always safer to first DOP IOS70 if you want it, before updating the system menu...

    I think Waninkoko 4.2 updater only installs & patches the newest IOS61 (used by Shop Channel v17) and IOS70 (used by System Menu 4.2), then install those two channels. Therefore, any previously installed IOS (patched or not) will remain untouched.

    Anyway, this installer is still way better than Waninkokos because:
    1/ you know exactly what it does
    2/ its exactly like the official Nintendo update minus the anti-piracy (cIOS) and risky (boot2) things (maybe you should also include the new MIOS to be more a "purist")

    This IS the way guide/stuff should be done, so that anyone has perfect control and understanding about what he is doing...
     
  3. G0dLiKe

    G0dLiKe who needs a title ;)
    Member

    Joined:
    Aug 2, 2009
    Messages:
    1,674
    Country:
    United States
    As I´ve read here this will be used for dragging VC to SD and play from there... are VC games affected which resides on the Nand? I am playing them from Nand actually.
     
  4. BBking83

    BBking83 GBAtemp Advanced Fan
    Member

    Joined:
    Oct 23, 2008
    Messages:
    676
    Country:
    If by this you mean:
    1. Install WAD via Wadmanager
    2. Move channel to SD via Wii data management
    3. Play VC/WiiWare from SD

    Then yes. You won't get that "Failed to Launch" message. The only way VC/WiiWare will be affected is if you put it through ww_packer before you install it. [​IMG]
     
  5. wolffangalchemist

    wolffangalchemist This is bat country!
    Member

    Joined:
    Nov 23, 2008
    Messages:
    1,451
    Country:
    United States
    thanks to the nand emulation there really is no need for a patched ios 70 as long as you got a good sized fat32 partition on a usb drive
    unless you can't get a certain wiiware game to work with it and really want to use it from the sd card.
     
  6. G0dLiKe

    G0dLiKe who needs a title ;)
    Member

    Joined:
    Aug 2, 2009
    Messages:
    1,674
    Country:
    United States
    Exact. Thanks BBking.
     
  7. Dr. Clipper

    Dr. Clipper GBAtemp Addict
    Member

    Joined:
    Aug 28, 2007
    Messages:
    2,485
    Country:
    It will get overwritten, and to be safer, it always updates everything (in case you're an idiot and previously installed a stubbed IOS in one of the positions or something).

    The idea here is to only apply Nintendo updates without any patches whatsoever. If you want to use patches, you are able to add them yourself afterwards. The app is designed for everybody to use, and those of us that hate piracy do not want any trucha patches in our system except those in the custom IOSes.
     
  8. Golfje

    Golfje GBAtemp Regular
    Member

    Joined:
    Oct 14, 2008
    Messages:
    177
    Country:
    Netherlands
    In the past i have downgraded the system menu 3.3E to 3.2E. Is it save to use this to upgrade to 4.2... Will this upgrade affect Bootmii installed as boot2 ???
     
  9. G0dLiKe

    G0dLiKe who needs a title ;)
    Member

    Joined:
    Aug 2, 2009
    Messages:
    1,674
    Country:
    United States
    This update here wont touch Boot2. I am not sure about your 3.3 to 3.2 to 4.2....
     
  10. nl255

    nl255 GBAtemp Addict
    Member

    Joined:
    Apr 9, 2004
    Messages:
    2,934
    Country:
    Which IOSes does this update? Does it just get the latest (non-stubbed) 60 as well as 61 and 70 or does it mess with others like 35, 38, and 38?
     
  11. mooncraterx

    mooncraterx Member
    Newcomer

    Joined:
    Mar 15, 2009
    Messages:
    19
    Country:
    United States
    So did this and tried dop-ios to patch ios70. it freezes after download 15/15 doesn't patch it. Using dop-ios v8.

    Help?
     
  12. Dr. Clipper

    Dr. Clipper GBAtemp Addict
    Member

    Joined:
    Aug 28, 2007
    Messages:
    2,485
    Country:
    Check zektor's guide. It follows it exactly apart from installing an unpatched IOS70. It does not install anything in the IOS60 position.
     
  13. BBking83

    BBking83 GBAtemp Advanced Fan
    Member

    Joined:
    Oct 23, 2008
    Messages:
    676
    Country:
    Sounds like you didn't have cIOS installed. Try installing it again.
     
  14. Gangsterz14

    Gangsterz14 Newbie
    Newcomer

    Joined:
    Dec 30, 2008
    Messages:
    7
    Country:
    Belgium
    My Wii is on 3.4e.
    I want update to 4.2 with this tool.
    Will my preloader and bootmii still work or do I have to update it to? (Preloader and bootmii where installed about 3 months ago)
     
  15. laurozza

    laurozza GBAtemp Fan
    Member

    Joined:
    Sep 17, 2008
    Messages:
    348
    Country:
    Italy
    You have only to reinstall preloader.

    zektor and dr. clipper thanks for this.
     
  16. Optimusprime

    Optimusprime Newbie
    Newcomer

    Joined:
    Oct 7, 2009
    Messages:
    5
    Country:
    Gambia, The
    How can I only Update the Wii Shop Channel from FW 4.1E (with Preloader V0.29, HBC 1.0.5, BootMii on NAND, USB LOader GX)?
     
  17. ante80

    ante80 Member
    Newcomer

    Joined:
    Oct 7, 2009
    Messages:
    19
    Country:
    This has been answered before.
    But to keep it simple, just install the latest IOS61 [v5405] and shopping channel [v17] wad's, and you should be ok.
     
  18. Optimusprime

    Optimusprime Newbie
    Newcomer

    Joined:
    Oct 7, 2009
    Messages:
    5
    Country:
    Gambia, The
    I say it short: THX
     
  19. wiiman123

    wiiman123 GBAtemp Advanced Fan
    Member

    Joined:
    Apr 5, 2009
    Messages:
    938
    Country:
    New Zealand
  20. Screemer

    Screemer GBAtemp Maniac
    Member

    Joined:
    Sep 21, 2008
    Messages:
    1,248
    Country:
    Gambia, The
    could a check for free space on nand be implemented before performing the update?
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - Firmware, RELEASE, Updater