Official [Release] Saviine - WiiU savedata tool

Discussion in 'Wii U - Homebrew' started by Maschell, Oct 16, 2015.

  1. peteruk

    peteruk GBAtemp Advanced Maniac

    Jun 26, 2015
    Using the latest release, was wondering why the icon won't show for me in HBL ?

    All other homebrew the icons show apart from this one

    The .png is in the folder

    Any idea ?

    EDIT: sorted now, in the release pack it was labelled saviine.png - I renamed it to and working
    Last edited by peteruk, Oct 22, 2016
  2. carlitos92jose

    carlitos92jose Advanced Member

    May 11, 2010
    United States
    does anyone tested injecting pal saves to ntsc? I dont want to lose my progress on pokken
  3. Skanob

    Skanob Advanced Member

    Jan 26, 2009
    I have successfully transferred my save game for Wind Waker HD USA (loadiine, 800000x and common folder) to my PAL WiiU for Wind Waker PAL (USB install). Works with 5 mins testing. Don't have the time to finish the game or fully test the save file.

    @Maschell just want to let you know about this, could be helpful.. Also, I can't seem to transfer my Hyrule Warrior save (800000x only), error is that "not enough space" or "too big" (not looking at the WiiU as of the moment).

    Is there any solution for this or anyone experiencing the same?
    Last edited by Skanob, Oct 23, 2016
  4. halloworld

    halloworld Member

    Jan 7, 2016
    Gambia, The
    i have save game save.dat
    howro can transfer this?

  5. tomazzzi

    tomazzzi GBAtemp Regular

    Jul 13, 2007

    I m trying to transfer my PAL Zelda WW loadiine save.

    Inside the "The Legend of Zelda - The Wind Waker HD [BCZE01]" save folder i only have a C and E folder.

    I don't have a common or 80000X folder.

    How to proceed ?

    Thx !!
  6. Maschell

    Maschell GBAtemp Advanced Fan

    Jun 14, 2008
    Gambia, The
    Using loadiine saves from the shared savemode

    C = Common
    U = Unique aka 8000000X
  7. tomazzzi

    tomazzzi GBAtemp Regular

    Jul 13, 2007
    So i must rename to 8000000X or 80000001 2 - 3 or anything else ?

    Sorry for misunderstanding but that's not clear;

    Thx !

    edit ok someone explained it to me so i m editing cause it can be usefull for someone else...

    You need to rename the folder to 800000X where X is the account number on your Wiiu.

    If you have only one user on the console it should be 1 but to be sure make a SAVE dump and you ll know.
    Last edited by tomazzzi, Oct 26, 2016
  8. Jessica1987

    Jessica1987 Member

    Nov 3, 2016
    So I thought I followed the instructions to the letter, but when I try to dump my Hyrule Warriors save file my computer doesn't go past the "Listening on 7332" stage. I am using my IPv4 number, and I can use Gecko dNet just fine to edit my save file (so the kernel exploit works fine, and my computer and Wii U are on the same network).
    MattKimura likes this.
  9. buhdiego

    buhdiego Advanced Member

    Nov 1, 2016
    Hey guys... I have a doubt.... I have two users on my wii u and both have saves on mario kart 8.... i need to reinject the saves... do i have to inject both common and user data to both each time? i may have noticed (maybe not) that, even when i change the users to inject the saves, they ovewrite the other user's common save... and i'm pretty sure that there was 2 folders for common save on wii u data manager before i tried to reinject the saves (need to reinject because i was playing after on loadiine and now i'm using USB brazilian method) thaanks
  10. mbruno

    mbruno Gamer For Life

    Aug 6, 2008
    United States
    Vienna, West Virginia
    Ok, I just went to use Saviine, I've changed nothing since I last used and it worked fine, but now I can't get it to work. I've even tried restarting my computer, since that helped the last time I couldn't get Saviine to work, but no dice.
  11. mbruno

    mbruno Gamer For Life

    Aug 6, 2008
    United States
    Vienna, West Virginia
    Got it to work on my old Windows 7 laptop(my current laptop is Windows 10). Perhaps Windows 10 doesn't like to cooperate with Saviine for some reason.
  12. Kekskrümel

    Kekskrümel Member

    Mar 3, 2014
    Gambia, The
    Can someone give me a hint, how to set a default IP in the source code of saviine ?

    Edit SetServerIp(ip.full); to SetServerIp("");

    doesnt work.

  13. TehCupcakes

    TehCupcakes GBAtemp Regular

    Apr 5, 2013
    United States
    Has anybody tried injecting with Paper Mario: Color Splash? I dumped my save just fine, (unique data only, game has no common)... Then I tried copying the save folder inside "dump" to "inject", and running the inject bat. Once I started up the game, it would appear that I was able to inject without problems, but when I actually press A to start the game, I get the intro cutscene meaning my savefile has been rendered unusable...

    Pretty bummed about this. I've spent several hours on this game and just wanted to make a small tweak to the save, but now I have nothing. And yes, I did save the clean (unmodified) save file and I am trying to inject that. No luck so far.

    EDIT: Nevermind, turns out it wasn't an issue with Saviine, I just must have modified the save file without realizing it. The reason the game was not loading the save after injecting is because the data00.bin file has a Crc32 at the end of the file that verifies the integrity of the save. I just recalculated a Crc for my save and modified this value, then re-injected. Worked like a charm. :)
    Last edited by TehCupcakes, Nov 10, 2016
    Maschell likes this.
  14. Rexxtan

    Rexxtan Newbie

    Nov 11, 2016
    I was trying to dump or inject mass effect 3 save as I was playing on loadiine before I bought the oringinal disc and followed the instructions carefully but there was no popup dialog for both dump and inject. Using Windows 10. Tried on 2 machines and not working. Anyone had any luck?
  15. Cachuchin1

    Cachuchin1 Advanced Member

    Mar 16, 2016
    United States
    Can someone help me with some saves injection? just got SSB4 and MMaker but I'm just too lazy to wait for everything. Does someone has the save files that can share with me ? but also kind of explain me how to inject them ? thanks !!!
  16. mediavieja

    mediavieja Advanced Member

    Oct 28, 2010
    So with this will i be able to transfer my save game from one wii u to the other? cause now i have 2 wii u and i wanna transfer that save to the new one with a diferent NNID
  17. neim81094

    neim81094 GBAtemp Regular

    Jun 15, 2013
    United States
    Hey guys, does anyone know how o run a saviine server with Mac OSX? Is that possible?
  18. animex2k9

    animex2k9 GBAtemp Regular

    Sep 13, 2009
    United States
    I've successfully transferred my loadiine save of Project Zero V to the USB method version of Project Zero V on my Wii U (US) (region-free hack enabled). This is a great tool and very easy to use.
  19. MattKimura

    MattKimura 3DS & WiiU Enthusiast

    Jun 30, 2014
    United States
    Is it possible to run saviine dump or inject with Linux terminal?
    Does not do anything, just says listening. Works on my windows 10 desktop though.

    It's not working on my friend's windows 10 computer though
    Last edited by MattKimura, Nov 24, 2016
  20. digitalforums

    digitalforums GBAtemp Regular

    Nov 20, 2004
    Cheshire, England
    has anyone managed to transfer their mario kart 8 saves from loadiine to nand/usb loader.

    Ive tried a few times today but mario kart wont laod after doing it, i have to delete the saves from the wiiu to get it to load. i can get them to trasnfer and everything, just not work

    Mario kart loadiine no update or dlc to mario kart, latest update and dlc, could that be the problem?

    UPDATE: incase anyone comes across this problem, i deleted the common folder and only uploaded my 8000000X folder and it worked.
    Last edited by digitalforums, Dec 2, 2016 - Reason: updated