[RELEASE] 3DiScord: A Discord client for the 3DS

Discussion in '3DS - Homebrew Development and Emulators' started by cheuble, Jun 19, 2017.

  1. Prillexed

    Prillexed Member

    Newcomer
    15
    1
    Jun 29, 2017
    United Kingdom
    Hope it comes quick mate :) glad i ain't the only one with issues have you updated to 8.1 bugfixes and more stuff in luma menu (L+select+down)
     
  2. Swampat

    Swampat The swamp monster that pats the ground

    Member
    197
    37
    May 25, 2017
    United States
    Yeah
     
  3. Prillexed

    Prillexed Member

    Newcomer
    15
    1
    Jun 29, 2017
    United Kingdom
    fair enough mate :) looking through config files i think i can redirect my boot.firm which launches luma 7.1.. so the errors go, at least until they patch these darn arm 11 probems.. especially using ntr cfw. that annoys me a lot :D trying to get a workaround..
     
  4. Swampat

    Swampat The swamp monster that pats the ground

    Member
    197
    37
    May 25, 2017
    United States
    I wish you luck my friend!
     
  5. Prillexed

    Prillexed Member

    Newcomer
    15
    1
    Jun 29, 2017
    United Kingdom
    Try this one out fo yourself haven't had enough time to test, rename your original boot.firm to Original.firm and leave it where it is and put these two files onto the root of the SD, maybe you'll error but it's something to start with! :D https://filetrip.net/upload?ibeGPvSCy9
     
  6. Swampat

    Swampat The swamp monster that pats the ground

    Member
    197
    37
    May 25, 2017
    United States
    Um wheres the file
     
  7. Prillexed

    Prillexed Member

    Newcomer
    15
    1
    Jun 29, 2017
    United Kingdom
  8. Swampat

    Swampat The swamp monster that pats the ground

    Member
    197
    37
    May 25, 2017
    United States
    no caused the luma to say the boot wasnt supported
     
    Prillexed likes this.
  9. Prillexed

    Prillexed Member

    Newcomer
    15
    1
    Jun 29, 2017
    United Kingdom
    Hmm i think maybe because b9s is coded for 8.0 and up i have to find a workaround.. maybe ctr9 could be useful just need to change the files a bit, thanks though mate :)
     
  10. Swampat

    Swampat The swamp monster that pats the ground

    Member
    197
    37
    May 25, 2017
    United States
    give it try :D
     
  11. LukeHasAWii

    LukeHasAWii If specified, this replaces title above your posts

    Member
    837
    634
    Apr 24, 2016
    United States
    Iowa
    This looks cool. I would love to see this is a dsi homebrew too (no voice chat ofcourse)
     
  12. sks316

    sks316 #YearOfLuigi2018

    Member
    2,033
    1,364
    Nov 28, 2013
    United States
    Cerulean Cave
    So would I. Just imagine sending this over via HaxxStation.
     
  13. LukeHasAWii

    LukeHasAWii If specified, this replaces title above your posts

    Member
    837
    634
    Apr 24, 2016
    United States
    Iowa
    :P i meant dsi, not original ds. The OG ds needs a low-security wifi to work online and doesn't have a lot of ram'n'stuff. I hear there's BuzzHax or something along the lines of that coming soon™
    Edit: but that would be awesome
     
    sks316 likes this.
  14. HRudy94

    HRudy94 GBAtemp Regular

    Member
    138
    22
    Dec 29, 2016
    France
    I would love to see voice chat coming (oh and can you add the emojis button)
     
  15. cheuble
    OP

    cheuble Marieism™

    Member
    737
    1,399
    Feb 6, 2016
    France
    Calamari Region
    Ok, I think I found the issue. Try to start a DM conversation with someone on Discord from your PC/phone. Then start 3DiScord again, and it should fix the issue. I'll have to fix this for the next update :unsure:
     
  16. Prillexed

    Prillexed Member

    Newcomer
    15
    1
    Jun 29, 2017
    United Kingdom
    This could never really work on dsi ill look into it for you mate :)

    — Posts automatically merged - Please don't double post! —

    Any workaround on the arm11 crash? only works on luma 7.1, 8.0 and 8.1 are broken with this,tested on n3ds and o3ds and won't go past login page? do you think extra files are needed for this?
     
  17. Prillexed

    Prillexed Member

    Newcomer
    15
    1
    Jun 29, 2017
    United Kingdom
    could someone recode the luma 7.1 payload( the firm file) to run with b9s 1.2? i feel as if we can grab some code from the 8.1/8.0 luma payload and import it into the 7.1 file we could boot onto that payload and most arm 11 crashes will be fixed, at least until luma 8.2 is released or something else to fix these crashes, it's not only me i know that many 3ds luma users are experiencing this rubbish and at east i'm trying to help all of you,.. by the way from running luma 8.1 by sticking the 8.0 payload onto the boot chainloader you can switch between firms to boot from, this is useful if you guys wanna switch up firms at any point for any random reason, even though they both are crash machines of death for the 3ds right now.. just someone help me out here and you'll get a lot of credit for this :) thanks!
     
  18. nitroBW

    nitroBW warum nicht?

    Member
    754
    683
    Nov 1, 2016
    Germany
    donut piss wasteland
    There already is an official 7.1 B9S1.2 hourly, here, I don't think any of us could recode it.
    You can also just grab the latest 8.0 hourly here, you can disable the exception handlers in the more recent hourlies.
     
    Xiphiidae likes this.
  19. Prillexed

    Prillexed Member

    Newcomer
    15
    1
    Jun 29, 2017
    United Kingdom
    thanks nitro i'll check it out, if that doesn't help it's gotta be something in boot9strap.. i did read that it is buggy and stuff as of this moment..
     
  20. Zero72463

    Zero72463 GBAtemp Maniac

    Member
    1,383
    727
    Jun 27, 2016
    United States
    Screenshots?
     
Loading...