Region Mismatch problem according to AnyTitle Deleter. Help?

Discussion in 'Wii - Hacking' started by phreak97, Aug 29, 2013.

  1. phreak97
    OP

    phreak97 Member

    Newcomer
    2
    May 2, 2009
    Australia
    Adelaide
    I dont mind downgrading it if it will be easier for me to sort out this issue, but I dont think it will make a difference at this stage, I just dont see a point.

    It's AnyTitle Deleter which shows the warning, ARC is perfectly happy.
    The mod is only to show the title names instead of the IDs I believe.
    Not sure where I got it to be honest.
     
  2. JoostinOnline

    JoostinOnline Certified Crash Test Dummy

    Member
    14
    Apr 2, 2011
    United States
    The Twilight Zone
    Oh, I misread. Well I found the problem. The error message isn't quite accurate, which is what threw me off. The region info is in setting.txt, not SYSCONF.

    What does it say right before the warning line?
     
  3. phreak97
    OP

    phreak97 Member

    Newcomer
    2
    May 2, 2009
    Australia
    Adelaide
    [​IMG]

    Not being Sysconf explains something at least..
     
  4. JoostinOnline

    JoostinOnline Certified Crash Test Dummy

    Member
    14
    Apr 2, 2011
    United States
    The Twilight Zone
    Unfortunately, ATD Mod is closed source, so I can only guess at the reports without reverse engineering, which I suck at. I made this for another purpose a long time ago, but it should tell me everything we need to know:
    http://filebin.ca/uHkpv18VWZM/CheckSettings.dol
     
  5. phreak97
    OP

    phreak97 Member

    Newcomer
    2
    May 2, 2009
    Australia
    Adelaide
    ah damn..


    Code:
    Region is Korea
    Area is Korea
    Video is NTSC
     
    Press any key to exit
     
  6. Aractus

    Aractus GBAtemp Regular

    Member
    1
    Aug 4, 2013
    Canberra
    maybe atd mod reports that error as a false-positive every time it sees a korean wii?
     
  7. phreak97
    OP

    phreak97 Member

    Newcomer
    2
    May 2, 2009
    Australia
    Adelaide
    Aractus, that's pretty much what I'm trying to confirm.
     
  8. mauifrog

    mauifrog DA KINE WiiHacker

    Member
    3
    Jan 21, 2010
    United States
    Perhaps it is reading this from sysconf
    Code:
    IPL.SADR BIGARRAY 0x1007 lots "Simple Address" Contains some region info
    
    Possibly some minor region setting was placed in the sysconf when the region select channel was run while the wii was region changed. Possibly formating the wii from the system settings to trigger the wii setup again would fix the issue. Like when it asks you what county you live in during initial startup.
     
  9. JoostinOnline

    JoostinOnline Certified Crash Test Dummy

    Member
    14
    Apr 2, 2011
    United States
    The Twilight Zone
    It's a false positive then. There must be a bug in the ATD Mod code. The original ATD doesn't even support Korean Wii's, so you'd get an error there.
     
  10. phreak97
    OP

    phreak97 Member

    Newcomer
    2
    May 2, 2009
    Australia
    Adelaide
    Mauifrog, that makes perfect sense, installing the us system menu would mean setting that option, the korean system menu does not ask you what country you are from because youre always from south korea, it's factory set.
    Is it possible to edit that information and set it to region 6?
     
  11. JoostinOnline

    JoostinOnline Certified Crash Test Dummy

    Member
    14
    Apr 2, 2011
    United States
    The Twilight Zone
    Your country code in IPL.SADR is set to 136, which is South Korea.
     
  12. phreak97
    OP

    phreak97 Member

    Newcomer
    2
    May 2, 2009
    Australia
    Adelaide
    Ah so probably korean wiis will all have this warning?
     
  13. JoostinOnline

    JoostinOnline Certified Crash Test Dummy

    Member
    14
    Apr 2, 2011
    United States
    The Twilight Zone
    Might be. Because the source is closed, I can't know what exactly it's checking. I wouldn't worry about it.
     
  14. phreak97
    OP

    phreak97 Member

    Newcomer
    2
    May 2, 2009
    Australia
    Adelaide
    I dont think I will, unless it causes me problems.

    Now, ignoring the fact that I'm probably insane for doing it, any suggestions for how to return this wii to factory? that guide is old and recommends deleting every ios above 60 then installing the system menu wad before doing a factory reset.

    now I'm guessing that system menu 3.4 didnt need any of those ios's, but 4.3 does from what I can tell, I'm thinking doing that on 4.3 might brick it again.. should I downgrade to 3.4 then follow the guide before updating again? or is there a better way?
     
  15. JoostinOnline

    JoostinOnline Certified Crash Test Dummy

    Member
    14
    Apr 2, 2011
    United States
    The Twilight Zone
    Okay, know that what you are doing is dangerous, because if it fails (which it probably won't, but I need to warn you) you will get a full brick. You need to use Ohneschwanzenegger (I hate that name, I always have to look up the spelling) to create a clean NAND, and use BootMii as IOS to restore that NAND.
     
  16. JoostinOnline

    JoostinOnline Certified Crash Test Dummy

    Member
    14
    Apr 2, 2011
    United States
    The Twilight Zone
  17. phreak97
    OP

    phreak97 Member

    Newcomer
    2
    May 2, 2009
    Australia
    Adelaide
    awesome I'll give that a go and post back:)
     
  18. Lumstar

    Lumstar Princess

    Member
    4
    Mar 6, 2006
    United States
    Darling
    It's a software issue. I don't know anything technical.
     
  19. JoostinOnline

    JoostinOnline Certified Crash Test Dummy

    Member
    14
    Apr 2, 2011
    United States
    The Twilight Zone
    I don't think it would be of use to you. It wouldn't tell you anything region-relevant that you haven't found by running several tools.
     
Loading...