Regarding Wii firmware 3.0e and 3.10e -PLEASE HELP

Discussion in 'Wii - Hacking' started by TheOne1, Nov 23, 2007.

  1. TheOne1
    OP

    Newcomer TheOne1 Member

    Joined:
    Nov 23, 2007
    Messages:
    13
    Country:
    Sweden
    Hi!
    I have a PAL Wii with firmware 3.0e the latest update is 3.10e(?)(ive heard).

    1- Should i update? If yes- Why?

    2- If you have WiiKey with 1.9g BETA HOTFIX and update could something go wrong - perhaps Brick the Wii?

    3- Are there games that require a specific Wii firmware?

    4- If so shouldnt "WiiBrickBlocker" take care of that?

    Please help!

    Thanks guys!
     
  2. manias

    Member manias GBAtemp Maniac

    Joined:
    Aug 7, 2007
    Messages:
    1,258
    Country:
    Netherlands
    latest thru the internet is always fine to do. And yes many games need at least a certain firmware, mario needs the absolute latest for example and that's always fine, but always try to update thru the internet or if you must thru a game of your OWN region. If you update from another region you could brick. And for the rest, do a search.
     
  3. TheOne1
    OP

    Newcomer TheOne1 Member

    Joined:
    Nov 23, 2007
    Messages:
    13
    Country:
    Sweden

    So they wont find out that you are perhaps using the WiiKey chip and brick the system?

    So basically i wait for a new game and shold the game recuire a newer version of Wii firmware than i have it simply updates the system by it self? - as long as i upgrade from my ogn region eg. NTSC PAL and so on...?????
     
  4. manias

    Member manias GBAtemp Maniac

    Joined:
    Aug 7, 2007
    Messages:
    1,258
    Country:
    Netherlands
    no they won't detect anything. But to be safe, when a new firmware comes out, read this forum about what it does before updating. When they say it's safe here, update thru the internet.
     

Share This Page