RajNX - currently the BEST and most USER-FRIENDLY free starter pack for Nintendo Switch

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by rajkosto, Aug 4, 2018.

  1. rajkosto
    OP

    rajkosto GBAtemp Advanced Fan

    Member
    10
    Apr 6, 2017
    You need to use exFAT firmware version if your microsd is formatted as exFAT. use guiformat to format your microSD as fat32 and then you can use ChoiDujourNX to install 3.0.1 (exFAT) firmware if you want to reformat it and use it as exFAT after that.
     
  2. crazy_p

    crazy_p GBAtemp Regular

    Member
    2
    Sep 3, 2016
    Switzerland
    You can use ChoiDujourNX to update your Switch to 5.1.0 or add the exFat Update for 3.0.1. I recommend Updating to 5.1.0

    Edit: :ninja:
     
    Last edited by crazy_p, Aug 10, 2018
  3. gap30

    gap30 Member

    Newcomer
    1
    Feb 22, 2018
    United Kingdom
    Liverpool
    Now i cannot get into recovery settings if i try to inject the rajnx payload it just goes back to my original problem

    — Posts automatically merged - Please don't double post! —

    sorry how do i do this
     
  4. rajkosto
    OP

    rajkosto GBAtemp Advanced Fan

    Member
    10
    Apr 6, 2017
    There's no reason why you would have to (restore your nand). You are just misconfiguring the bootloader or something, since your console boots normally without it. Maybe try something else.
     
    Last edited by rajkosto, Aug 10, 2018
  5. gap30

    gap30 Member

    Newcomer
    1
    Feb 22, 2018
    United Kingdom
    Liverpool
    So format my sd card to fat32 then what start again?

    If i try to inject the rajnx payload it just goes crazy again

    Bear with me here please

    I have formatted the card using guiformat to fat32

    Ok now i can enter homebrew menu via album and can see tinfoil

    How do install the firmware you recommended
     
    Last edited by gap30, Aug 10, 2018
  6. rajkosto
    OP

    rajkosto GBAtemp Advanced Fan

    Member
    10
    Apr 6, 2017
    Please extract the zip to your microsd again, overwriting everything, to reset it to its normal state. Then use the launch firmware menu option, and choose CFW. This should work and let you run homebrew from album.
     
    Last edited by rajkosto, Aug 10, 2018
  7. palantine

    palantine GBAtemp Regular

    Member
    3
    Oct 5, 2014
    Italy
    I heard you were interested in firmware 4.0.0?
     
  8. gap30

    gap30 Member

    Newcomer
    1
    Feb 22, 2018
    United Kingdom
    Liverpool
    Currently looking at the ChoiDujourNX where do i locate the files to update my firmware

    Also when you advised me to use Briccme earlier I think it said i had burnt 4 fuses i take it i will get banned now?
     
  9. mrmouse781

    mrmouse781 Newbie

    Newcomer
    1
    Aug 10, 2018
    United States
    Nevermind figured it out, I'm an idiot haha. Was using exfat on 3.0.0, changed to fat32 and worked great.
     
    Last edited by mrmouse781, Aug 11, 2018
  10. Slimmmmmm

    Slimmmmmm GBAtemp MoNkEeE

    Member
    4
    Nov 1, 2007
    the land of lol
    @rajkosto, Are you just ignoring my question(s)?
     
    AlexMCS likes this.
  11. Ashura66

    Ashura66 GBAtemp Fan

    Member
    2
    Feb 1, 2016
    Portugal
    Under my bed
    Do keep in mind though that some games aren't going to fit in a fat32 SDcard. Unless you plan on only playing homebrew
     
  12. mrmouse781

    mrmouse781 Newbie

    Newcomer
    1
    Aug 10, 2018
    United States
    Oh yes absolutely. I meant did Fat32 just for initial to do ChoiDuJourNX to upgrade to 5.1 with exfat then reformated as exfat and everything worked great. I just used the original exfat on 3.0.0 to do the nand backup. Thanks
     
  13. DeathGrind

    DeathGrind Member

    Newcomer
    3
    Sep 3, 2008
    United States
    Great work here by the dev! I used rajkosto method of updating my 1.00 fw switch to 5.1.0, with exfat support, and it was straight forward and easy. Using the option in this to deny gamecart update also. Great work. Feels good to be able to use my switch again.



    Sent from my Nexus 6P using Tapatalk
     
  14. vastrolorde

    vastrolorde Advanced Member

    Newcomer
    2
    Mar 22, 2015
    United States
    kudos for this cfw! btw does this thing support exfat? my current firmware is 5.1.0 but asking for a system update.? or its also the same using memloader and hacdiskmount with a a game update xci file just to make exfat work?
     
  15. soaresden

    soaresden GBAtemp Regular

    Member
    3
    Dec 16, 2013
    France
    Using RajNx and trying to make sys-ftp work, make me a infinite loading nintendo black screen on boot ?
    Any workaround ?
    Thanks !
     
  16. Bemmeltje

    Bemmeltje Newbie

    Newcomer
    1
    Jun 1, 2018
    Netherlands
    When i put my backup .xci file on the sd card in the root/backup map it doesnt show uo on the switch ?
     
  17. mezz0

    mezz0 Member

    Newcomer
    1
    Mar 10, 2009
    Belgium
    ::1
    What gave you the idea it would ? What mechanism would load the XCI ? Because as far as I know XCI is only directly loaded by SX oS.
     
    Don Jon and XaneTenshi like this.
  18. jakibaki

    jakibaki GBAtemp Regular

    Member
    5
    Mar 3, 2017
    Germany
    the newest version of sys-ftpd will only work in combination with layeredfs if you also install the pm.kip.

    You can use the pm.kip from the sdfiles or just use an older version of sys-ftpd (which has the drawback of being a lot slower due to low ram-limits.
     
  19. WiiHomebrew+Snes

    WiiHomebrew+Snes GBAtemp Regular

    Member
    2
    May 4, 2016
    United States
    You overestimate people's deletion skills. I say each has it's merits, and it wouldn't really matter one over the other.
     
    Darth Meteos likes this.
  20. rajkosto
    OP

    rajkosto GBAtemp Advanced Fan

    Member
    10
    Apr 6, 2017
    Isn't it a problem if you run ftpd as a sysmodule and then try to write to microsd from any homebrew ? Leading to filesystem corruption and errors, which is why I wouldn't recommend anyone use it yet.