Hacking R4i-SDHC card not working anymore. Says "An Error Has Occured". How to fix this?

sp957

Well-Known Member
OP
Newcomer
Joined
Nov 5, 2013
Messages
85
Trophies
0
XP
275
Country
United States
My R4i-SDHC is not working (I attached a picture of the cart I have).

When I try to boot into the R4i Card. I get this message: "An error has occurred. Press and hold the Power Button to turn the system off. Please use the Nintendo DSi Operations Manual for help troubleshooting." (See Attachment).

My DSi is on 1.4.5U

Here is what I tried so far:

(1) Updating using the files from R4i-SDHC.com (I just delete the old folders/files from the SD Card and copy the files). The one on the site was v1.85b
(2) Downloading the files from https://www.linfoxdomain.com/nintendo/ds/ and copying them to the SD card. The one on this was v1.24b.
(3) Trying a different SD Card with a different size and cluster size
(4) Moving the year back on the DS to 2007

The DS hasn't been updated in a long time (1.4.5U is from 2012). And my R4i card is only about 3-4 years old.

I am not sure what to do.

Anyway to fix this?

Is there a special way I have to update the kernel and/or firmware? Would using the YSmenu version do any good?

Also, even after the different updates, the R4i Card is always recognized as "Touch! Bomberman Land Nintendo". I'm not sure if that means anything or not.
 

Attachments

  • 2.jpg
    2.jpg
    2.4 MB · Views: 97
  • 1.jpg
    1.jpg
    862.9 KB · Views: 96
Last edited by sp957,

Nikokaro

An aphorism a day to improve...my profile
Member
Joined
Feb 3, 2020
Messages
901
Trophies
1
Location
Nautilus (under) Lake Como, Italy 🇮🇹
XP
1,517
Country
Italy
Unfortunately, the late console firmware 1.4.5u blocks some flashcarts from being used. :O
The two available solutions are:

a) Install a cfw in the console (https://dsi.cfw.guide/installing-unlaunch), but this procedure has a certain risk :unsure:;

b) Buy a newer r4 (e.g. chinese r4i gold pro is very cheap and works great). ;)

Greetings
 
  • Like
Reactions: Alexander1970

eyeliner

Has an itch needing to be scratched.
Member
Joined
Feb 17, 2006
Messages
1,974
Trophies
1
Age
41
XP
3,447
Country
Portugal
Unfortunately, the late console firmware 1.4.5u blocks some flashcarts from being used. :O
The two available solutions are:

a) Install a cfw in the console (https://dsi.cfw.guide/installing-unlaunch), but this procedure has a certain risk :unsure:;

b) Buy a newer r4 (e.g. chinese r4i gold pro is very cheap and works great). ;)

Greetings
Correct about the CFW. It's blocked. No need to spend more money on another card.

I have one along the same lines and works perfectly. Just update the kernel/firmware and you'll be set.
 

sp957

Well-Known Member
OP
Newcomer
Joined
Nov 5, 2013
Messages
85
Trophies
0
XP
275
Country
United States
Unfortunately, the late console firmware 1.4.5u blocks some flashcarts from being used. :O
The two available solutions are:

a) Install a cfw in the console (https://dsi.cfw.guide/installing-unlaunch), but this procedure has a certain risk :unsure:;

b) Buy a newer r4 (e.g. chinese r4i gold pro is very cheap and works great). ;)

Greetings
I can't find the gold pro anywhere. It's out of inventory everywhere I checked.

Also, is there a flash cart that will play on my DSi 1.4.5U as well as a n3DS 11.13.0-45U (note, I'm not trying to play 3DS games on the 3DS via a flash cart. I just want to play DS games on my 3DS via a flash cart).
 

eyeliner

Has an itch needing to be scratched.
Member
Joined
Feb 17, 2006
Messages
1,974
Trophies
1
Age
41
XP
3,447
Country
Portugal
I can't find the gold pro anywhere. It's out of inventory everywhere I checked.

Also, is there a flash cart that will play on my DSi 1.4.5U as well as a n3DS 11.13.0-45U (note, I'm not trying to play 3DS games on the 3DS via a flash cart. I just want to play DS games on my 3DS via a flash cart).
Are your consoles hacked? Firmware updates block cards.
 

Nikokaro

An aphorism a day to improve...my profile
Member
Joined
Feb 3, 2020
Messages
901
Trophies
1
Location
Nautilus (under) Lake Como, Italy 🇮🇹
XP
1,517
Country
Italy
I remind you that you can play DS games (.nds) and old emulated 8/16 bit games (.nes, .gb/gbc, .gba, .pce) on DSi also from camera-slot, by easily installing in the SD root Memory Pit and Twilightmenu++, procedure that does not involve any risk (while installing Unlaunch/Hiyacfw, which is not essential, involves a minimum risk):
https://dsi.cfw.guide/launching-the-exploit

I honestly don't know if all DS games work; the ones I've tried don't give any problems.
Anyway, It is a temporary solution while waiting to buy a new r4.:)

P.S. The flashcart I was saying is exactly that.
It is evidently not readily available in your country while, on the contrary, it is in Europe.
 
Last edited by Nikokaro,

RAD047

Member
Newcomer
Joined
Jul 16, 2021
Messages
8
Trophies
0
Age
38
XP
24
Country
United Kingdom
Hi,

I have a similar problem to the OP.

I have the same card as pictured. Found it in a drawer after many years. Still works in my old DS lite if I set the consoles date back.

I bought a DSi though, and the card won't work with it. I get the same error as pictured above. Setting the date back doesn't do anything. My DSi firmware version is 1.4.1E

I don't actually understand the solutions above (I'm a noob when it comes to this stuff) so if any solution could be explained as simply as possible I would really appreciate that. Thanks!
 
General chit-chat
Help Users
    gudenau @ gudenau: This source file is now valid C, C++, Java and Scala.