R4i Gold works with DSi but not 3DS

Discussion in 'R4 DS' started by DrkrZen, May 24, 2013.

  1. DrkrZen
    OP

    DrkrZen Member

    Newcomer
    32
    3
    May 24, 2013
    United States
    A few months ago, my girlfriend accidentally updated my 3DS, so I couldn't use my flashcart. I didn't go and buy a DSi/Lite to patch the flashcart, since she was using the 3DS for 3DS games more than anything.

    Recently I bought a DSi, though, and I got the DSi to update the flashcart to v1.59, but whenever I start it on the 3DS with 4.5.0-10U, it says an error has occurred and I have to shutdown the system. It works on the DSi with 1.4.4U, however, and runs all three of my backed up DS games, even loading old saves I had. Also, its revision C.

    I'm not sure if I've used the correct patch, but the ones I used were: R4iGold_3DS45_NDSi145_Patcha_NDSi.nds and R4iGold3DS_V144_Patch_NDSi.nds. And, when I check the status it says, "3DS 3.0 and DSi 1.44".

    Any ideas?

    Thanks again, in advance.
     
  2. Jayro

    Jayro MediCat DVD and Mini Windows 10 Developer

    Member
    GBAtemp Patron
    Jayro is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    4,725
    2,481
    Jul 23, 2012
    United States
    Octo Canyon
    I have the same problem... 1.4.5 patch on my rev C brought my card to a new Dorasu icon, but I never could get ANY of the Deep Labyrinth patches to work. Looks like my card is a loss, and I bought it last July...
     
  3. DrkrZen
    OP

    DrkrZen Member

    Newcomer
    32
    3
    May 24, 2013
    United States
    Yeah, that's the icon I had, too. Now, I have the Prince Caspian icon for the flashcart.
     
  4. jrk190

    jrk190 GBAtemp Advanced Fan

    Member
    724
    110
    Jul 5, 2009
    United States
    North Carolina
    I've got the SAME issue. I'm really hoping for a fix, I had a ton of my games backed up on it, and most of those games are useless unless I use them on my broken DS lite.
     
  5. tranfeer

    tranfeer GBAtemp Advanced Fan

    Member
    772
    40
    May 23, 2010
    Australia
    Which file you have used?
    You should make use of The new patch for 3DS V4.5.0-10 & DSi V1.45 is releasing! (for R4i gold 3DS card only)(Jan.06th,2013)
     
  6. DrkrZen
    OP

    DrkrZen Member

    Newcomer
    32
    3
    May 24, 2013
    United States
    When I try that patch in the DSi, it immediately gives me a "Fail" for the Card Check. But when I use:


    The new patch for DSi/XL V1.45 is released now! (for DSi/XL V1.45 only)(Jan.23,2013)


    The update works as it normally should and changes the icon to DORASU. Then the R4i works just fine on the DSi but my 3DS gives the "An error occurred. Press and hold the POWER Button to turn off the system" message.

    I've even tried from scratch. I formatted the SD card, put the 1.59 firmware on, then the patch... ran the patch listed above and same result - works on the DSi, not on the 3DS.

    Maybe I should return this DSi for a Lite. Last time I did this, I borrowed a friend's DS Lite and it worked perfectly after patching.
     
  7. LurkerA

    LurkerA ㊣New3DS

    Member
    291
    68
    Apr 8, 2010
    United States
    Have you ever tried the 3DS V4.5.0-10 patch for your card as tranfeer recommended?
     
  8. DrkrZen
    OP

    DrkrZen Member

    Newcomer
    32
    3
    May 24, 2013
    United States
    Yeah, LurkerA. That's what the first sentence referred to in my previous post. I guess I was a little vague... sorry about that.

    When I try that patch, it says Card Check Fail and doesn't let me update. =/

    The patch I posted, however, works and updates my flashcart to DORASU icon.
     
  9. LurkerA

    LurkerA ㊣New3DS

    Member
    291
    68
    Apr 8, 2010
    United States
    You might need to wait for their new patch then, some revision C - old Dorasu icon cards were reported that 4.5.0-10 patch did not work properly anyway.
     
  10. DrkrZen
    OP

    DrkrZen Member

    Newcomer
    32
    3
    May 24, 2013
    United States
    Ah, gotcha. I was thinking that, considering I got my flashcart quite a while back... probably early last year, or so. Thanks for the info, though.

    When that patch comes out, I guess I'll either send in my flashcart or borrow a DS Lite again.