R4i Gold RTS won't play DS roms.

Discussion in '3DS - Flashcards & Custom Firmwares' started by Joshua Martin, Jun 12, 2013.

  1. Joshua Martin
    OP

    Joshua Martin Member

    Newcomer
    21
    1
    Jun 12, 2013
    United States
    I recently purchased an R4i Gold RTS from this site:
    https://www.ndsgamer.com/shop/artic...AvFQjJl4ZrY0dqDMsHmTS&shop_param=cid=1&aid=5&

    This site is a re seller from r4ids.cn.
    Got it home and loaded Wood 1.59, moved over some DS games, and loaded it.

    The first time I launched it (Konami Digital Entertainment icon) it appeared to load fine. Once I tried to launch a DS game it freezes on the "LOADING" screen. Then I manually have to turn it off. When I try and go back into it, it launched but is missing the top screen and there is not font and no way to select anything. It only shows the picture of an SD card and folder. If i plug the Micro SD back into my computer it seems to be corrupted (the file names on the root of my SD has extra symbols added like %$^') and I have to re format the card and start from scratch. I have tried multiple SD cards.

    My 3DSXL runs 5.1.0-11

    Listed here is the info in "Help" on my R4:

    wood akmenu 1.59 support:www.r4ids.cn.
    HW:R4i Gold 3DSb
    Sys:NDSi 1.45&3DS5.1.0-11

    Any help would be appreciated, I've spent about 10 hours trying to get this new card to work. Thanks

    Also, It does play emulated games fine, such as SNES and NES. It only seem to crash when I try and load NDS games. I've also tried multiple .nds sources.
     
  2. Rydian

    Rydian Resident Furvertâ„¢

    Member
    27,883
    8,107
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters
    Where did you get the MicroSD cards from?
     
  3. Joshua Martin
    OP

    Joshua Martin Member

    Newcomer
    21
    1
    Jun 12, 2013
    United States
    Not sure exactly, one is a 2GB PNY and the other is a 8GB Kingston. They are from different places I'm sure, but I don't exactly know where.
    I'm very confident it isn't the MicroSDs, I used the 2GB for my old R4 card for NDS a while back and it never gave me problems.
     
  4. Pong20302000

    Pong20302000 making notes on everything

    Member
    8,076
    1,931
    Sep 8, 2009
    One's inner self
    how did you get the Help info without it booting?

    wait so when your booting roms the Micro SD is corrupting?

    sounds like bad MicroSD cards

    make sure your not using patched roms also

    also switch back to 1.58
    ftp://soft.r4ids.cn/Wood_R4iGold_V1.58.rar
    1.59 was a beta thing for a new file system method to increase speeds but if you have a dodgy micro SD it might not like it
     
  5. Joshua Martin
    OP

    Joshua Martin Member

    Newcomer
    21
    1
    Jun 12, 2013
    United States
    Once I re format the MicroSD and move eveything back over (Kernal) it works fine, until I try and load a DS rom. But once I load a DS rom and it freezes on the "LOADING" screen, I have to turn it off manually and at that point it seems to corrupt.
    As long as I don not launch a DS game though everything works fine. It seems to just be a DS problem. Also, I'm curious as to the "Konami Digital Entertainment" logo. Is that what it's supposed to be? I'm not sure what the different one mean. Thanks for the help guys!

    Again, I don't think it's the MicroSDs. The odds are bad that both of them are bad and having the same problem and it also only happens when loading the .nds roms. If you guys really think it's the problem I can get another one.

    Could some one list the steps they take from formatting the MicroSD - Playing a DS game. I'm sure I'm doing it correctly but You can never be to sure.

    Just an update. Got a 4GB SanDisk and it is doing the exact same thing.
     
  6. Pong20302000

    Pong20302000 making notes on everything

    Member
    8,076
    1,931
    Sep 8, 2009
    One's inner self
  7. Joshua Martin
    OP

    Joshua Martin Member

    Newcomer
    21
    1
    Jun 12, 2013
    United States
    Need a UN and Pass for the link...

    Sorry, I'll start editing instead of posting new posts.

    Edit: couldn't donwload from the link, said I need a username and password. Downloaded it froma different source and it didn't work. Here are my steps:

    Format with SDFormatter
    Copy over Wood 1.5x
    Copy of game back up (Mariokart ds)
    Turn on and click Konami Digital Entertainment
    Same thing happens.

    The 1.58 I downloaded from a different site didn't work. It just loaded to a black screen. May have just been the site I got it from though.

    Edit 2: anything?

    Is there another site I can download different firmware version? Also what icon am I supposed have on my home screen? The Konami one?

    Edit: Anyone have a clean ROM site I can download from to make sure I'm getting clean ROMs?
     
  8. Langin

    Langin GBAtemp's kpop addict

    Member
    4,651
    778
    Jul 29, 2008
    Netherlands
    The Hague

    As Pong stated USE THE EDIT BUTTON

    I can only answer you second question: if the card boots it is good. So yes your supposed to have the Konami logo ;D

    Also: http://filetrip.com might help
     
  9. Joshua Martin
    This message by Joshua Martin has been removed from public view by Depravo, Oct 6, 2013, Reason: No bumping allowed..
    Jun 13, 2013
  10. air2004

    air2004 Air

    Member
    1,601
    436
    Oct 24, 2008
    United States
    Anytown
    The SD card is a fake , I had that same issue with some SD cards I bought on ebay , they were supposed to be 32gb , I would transfer shit to them fine , but when I would pop the card in my phone only some music would play , and other files would say they were corrupt , when I would load the card in my computer I would see weird chinesse symbols and shit . One of the things I noticed with the knock off cards was , during transfer the speed would be about 2mbs during the first 2 mins of transfer , then all the sudden it would jump to 8mbs it was a class 10 card , and the computer would say everything loaded fine , pop the card back in the phone and again the same issue. When I bought the same card from a legit site , I never had any of these issues with trnsfer speed and the card worked great.
     
  11. Joshua Martin
    OP

    Joshua Martin Member

    Newcomer
    21
    1
    Jun 12, 2013
    United States



    Thanks for the reply. I'm sure the MicroSD cards are fine. I bought one from Wal Mart today and they are ALL name brand SDs. Never bought one off eBay or any other site. I have tried 3 separate SD cards. PNY 2GB, Sandisk 4 GB, and a 8GB Kingston.
    They also work with anything else i try them in (ie. Phone, camera, camcorder). Thanks.

    Edit 1: I have tried multiple different kernals and they ALL run fun until I load a DS game then it freezes on "Loading". Once it does that, I have to reformat with SD Formatter.

    Any ideas?
     
  12. GoldenSun3DS

    GoldenSun3DS GBAtemp Regular

    Member
    264
    34
    Apr 27, 2013
    United States
    Patched roms work perfectly fine in the R4i Gold RTS.

    I know this from personal experience because I daily use anti-piracy patched Pokemon Black 2 and White 2 roms in my R4i Gold 3DS RTS (this one: http://nds-card.com/ProShow.asp?ProID=149 ) and I've had absolutely NO problems using it. I've also used an english patched Fire Emblem 12 rom in my card, and again, it runs fine, just like it would on a legit DS cartridge (except for the fact it's in English).

    EDIT:
    Maybe it's your rom? (you said you backed it up yourself)

    And if you want, you can try a copy of the firmware from my R4i:
    http://efshare.com/?s=R3SFHN (this was uploaded by me and is an exact copy of the contents of the SD I use in my R4i, minus the roms and homebrew)

    The password to the archive is "123" without the quotation marks. You'll need an archive extractor (like the free 7z or the free winrar) to extract it.
     
  13. luckyu

    luckyu Newbie

    Newcomer
    1
    0
    Oct 6, 2013
    I have tried multiple different kernals and they ALL run fun until I load a DS game then it freezes on (processing don't power off) just like joshua martin I have the same r4 as him am on dsi xl 1.45e could you plese be so kindly to re upload your firmware from your r4 as the link gone plus just wondering if Joshua martin fixed his r4 if so please share thank you