R4DS + EZ Flash 3-in-1 can't load GBA games

Discussion in 'R4 DS' started by chc, Dec 29, 2009.

Dec 29, 2009
  1. chc
    OP

    Newcomer chc Newbie

    Joined:
    Dec 21, 2009
    Messages:
    2
    Country:
    United States
    I have been using R4DS for a while, recently I updated the firmware to YSMenu made from YSMenu0903270000 and Unofficial DSTT Kernel V1.17a12, I could play "Mario & Luigi: Bowsers Inside Story" without any problem.

    One nice feature of YSmenu is to play GBA games, following recommendations from this forum I bought an EZ Flash 3-in-1 from dealextreme, link is http://www.dealextreme.com/details.dx/sku.2967

    I put Pokemon Emerald, Leaf Greed and Fire Red GBA roms on R4DS, then tried to load them with EZ Flash 3-in-1 card inserted. I got the following problems

    1. Pokemon Emerald, stuck at white screen after Game Boy banner.
    2. Pokemon Leaf Greed and Fire Red, games can be loaded, then got a warning of "1M sub-circuit board is not installed". When I tried to save games, I got "SAVE Error"

    Could you please suggest what I did is wrong? Do I need any other software to initialize EZ Flash 3-in-1? Thank you very much.
     
  2. hundshamer

    Member hundshamer GBAtemp Advanced Maniac

    Joined:
    May 22, 2009
    Messages:
    1,810
    Location:
    United States
    Country:
    United States
    Have you tried GBAExploader? Check this thread.
     
  3. chc
    OP

    Newcomer chc Newbie

    Joined:
    Dec 21, 2009
    Messages:
    2
    Country:
    United States
    Thanks a lot. I was able to use GBA ExpLoader 0.58b to run GBA Pokemon games.

    When I ran Pokemon Emerald, I got the message "The internal battery has run dry. The game can be played. However, clock-based events will no longer occur." Is that normal? I just want to make sure that I didn't get a defective EZ Flash 3-in-1.

    Just wondering if anybody has been able to use YSMenu for R4DS to load GBA Pokemon games directly. I thought YSmenu can do that, but I got no luck.
     
  4. Chaos Knight Mat

    Newcomer Chaos Knight Mat Newbie

    Joined:
    Jan 4, 2010
    Messages:
    2
    Country:
    United States
    I've been having similar battery problems as well although with mine it's primarily these conditions...

    1. When EZ Flash V 3-in-1 is inserted and activated, the system asked if it could use this for slot 2. It's only supposed to ask this once. It does this every time I restart my system.

    2. When I try to run Zelda - A Link to the Past it starts as a new game, regardless of the save file that I believe I loaded from my R4DS. If I try to register a name it tries to save, but says 'The File cannot be created' and takes me back to the main Zelda menu.

    3. Any game I've tried running on my EZV it wasn't able to save anything. Like with Super Mario Advanced 2: Super Mario World. First time I play it it says save file is corrupt, but I can still save while it's on. If I shut it off though it erases.

    I've been searching and researching on this subject for a while. Some say it was a faulty battery, but if it's tested it still has a charge (I lack the equipment to test it myself)

    If anyone knows what this issue is all about or how to get it working again, any advice is welcome. Although I do wonder if this error is evident in all EZ V Flash 3-in-1 carts...

    (If it's a touch screen solution, I won't be able to try it anytime soon until I get a new system, my touch screen was broken when I tried to switch housing cases on mine)
     
  5. Chaos Knight Mat

    Newcomer Chaos Knight Mat Newbie

    Joined:
    Jan 4, 2010
    Messages:
    2
    Country:
    United States
    Sorry for the double post, couldn't figure out how to delete my last post >.
     

Share This Page