R4 flashcart soft reset attempt messed up my SD card?

Discussion in '3DS - Flashcards & Custom Firmwares' started by TServo2059, Dec 28, 2016.

  1. TServo2059
    OP

    TServo2059 Member

    Newcomer
    17
    3
    Dec 23, 2016
    United States
    Hello,

    I have an issue I'd really like help on, because I'm not sure what I did, or how to fix it.

    I have a modded N3DSXL with A9LH+Luma, latest version, I use sysNAND with the latest system update. I have had no problems with anything until yesterday.

    I have an R4i 3DS *RTS* Revolution for DS (R4i Gold?) flashcart, running R4 Wood kernel. I wanted to soft reset out of a DS game to the R4i menu, but I think I hit the wrong combination of buttons. My screen went black, and I had to turn off the 3DS.

    When I came back on, not only could I not launch my flashcart from its system menu icon (black screen, the "spinning" noise persisted for a while, then stopped, and I had to shut off my system again), but I also couldn't successfully open any of the games or utilities installed on the SD in my 3DS. They're all on the menu, but launching any of them shows the error screen "The SD card was removed." I can get into System Settings (though it seems slower to load?), and in Data Management it cannot detect my microSD.

    What did I do? Did I mess up something with my flashcart, my SD card, or possibly even my CFW? I don't understand how making a mistake with a flashcart soft reset could screw up the SD in my actual 3DS, or worse. I'm kind of scared, I don't know what to do here, and I really hope this somehow didn't blow up my entire mod (though I still can load into Luma emuNAND by holding the L button, I just get the same CTRNAND error I've always gotten before any of this, that seems like a good sign that nothing has changed with the CFW?)

    Can anyone help me out with this? I'd love to get back to playing.
     
    Last edited by TServo2059, Dec 28, 2016
  2. TherealDarknes

    TherealDarknes GBAtemp Fan

    Member
    350
    29
    Jun 16, 2016
    United States
    ok i know this is stupid but did you try taking the sd cards out of both things that was all it took to fix my dstwos saving issue
     
  3. TServo2059
    OP

    TServo2059 Member

    Newcomer
    17
    3
    Dec 23, 2016
    United States
    No, I was traveling when this happened so I haven't tried to remove the 3DS SD yet.

    Do do I take out the SD cards of both, then what? Start the 3DS with the flashcart in? With the flashcart out?
     
    Last edited by TServo2059, Dec 28, 2016
  4. TherealDarknes

    TherealDarknes GBAtemp Fan

    Member
    350
    29
    Jun 16, 2016
    United States
    try taking the card out of your 3ds turn it on and then turn it off and put it back in? im not sure if that would mess with the whole modding thing you have with yours
     
  5. TServo2059
    OP

    TServo2059 Member

    Newcomer
    17
    3
    Dec 23, 2016
    United States
    That worked, I was able to get music on the game titled again, I opened one game, it worked, but then another had the same problem. I think it may actually be that the Micro Center 128 GB SD that came with the modded system is going bad...

    Also, when it stopped working again, for some reason starting the system with the SD card in it, then removing before the system menu actually booted up, then reinserting, when the game icons appeared they seemed to work.

    Stuff appears to work again, I turned the system off and on a couple times and it all seems to still work, my flashcart works again too, but this gives me pause all the same. Is my 3DS' SD card going bad? Is my reader going bad? I sincerely hope it's the former.
     
    Last edited by TServo2059, Dec 28, 2016
  6. TherealDarknes

    TherealDarknes GBAtemp Fan

    Member
    350
    29
    Jun 16, 2016
    United States
    128 gigs is a little big for the 3ds that might be a problem in it of itself make sure the sd card is in fat 32 cards larger than 32 gigs aren't supposed to be able to be fat 32 so they need to be specially set its noting complicated just another stupid windows restriction but that maybe the cause of all of this and i would put the thing in your computer and have it scan it for bugs also where did you buy a modded 3ds and how much was it
     
  7. TServo2059
    OP

    TServo2059 Member

    Newcomer
    17
    3
    Dec 23, 2016
    United States
    I got it from someone on eBay. It was working perfectly for the past few months. I paid for the system and for labor, it was $400. It was worth it to me so I didn't have to buy the SD myself or go through all the trouble of modding and screwing up. (The only mod I've done myself is the Wii U Haxchi + sig patches softmod, I have chosen to pay experienced modders for everything else.)

    I am not having problems anymore, though I notice the red waves animation is a little slower to load than it was before this incident. I could have sworn the waves used to start as soon as the 3DS logo appeared, and before the title selection sound finished, now the logo appears just as the sound is ending, and then the waves come in. Does that mean it's taking longer to load from the SD?

    I have the SD card over half full right now, so I definitely am making use of the 128GB.

    I do think if it's anything wrong, it'd likely be the SD and not the mod. I can buy another SD if things start going wrong again, and I will definitely scan my current one for errors when I get home from my vacation.
     
    Last edited by TServo2059, Dec 29, 2016