R4 Firmware

Discussion in 'R4 DS' started by Kyuzumaki, Dec 30, 2006.

  1. Kyuzumaki
    OP

    Kyuzumaki GBAtemp Regular

    Member
    251
    2
    Dec 24, 2006
  2. H8TR

    H8TR GBAtemp Advanced Fan

    Member
    796
    0
    Oct 22, 2006
    Canada
    t-Dot
    It should work. R4 dosen't have protection against different language firmware, it only has protection that stops people from putting M3 DS Simply firmware on it and running it.
     
  3. Kyuzumaki
    OP

    Kyuzumaki GBAtemp Regular

    Member
    251
    2
    Dec 24, 2006
    i just answered my own question by putting it on. It says hardware not compatable. Must be the Kanji fonts that it's missing.

    Only realising that i've been looking at an old mirror of the site and that theres english v1.04 available.
     
  4. pristinemog

    pristinemog GBAtemp Fan

    Member
    381
    1
    Dec 22, 2006
    United States
    Tampa, FL
    That's kinda disappointing. I hope they release the English DIY version of the firmware before I get my R4 on Tuesday.
     
  5. Kyuzumaki
    OP

    Kyuzumaki GBAtemp Regular

    Member
    251
    2
    Dec 24, 2006
    Yeah it is [​IMG]

    It's probably possible to hack the 1.04eng and 1.05chin firmwares together. I was looking at the *.dat file but can't get it to decompile. Not that thats important I doubt it'll take them long to release 1.05 in english given the speed updates have been thrown out so far.

    They do have the R4DS IO interface source but i can't make head nor tail of it. Seems to include disc_io.h and nds/card.h which they didn't supply..

    Need someone better at coding in c to look at it. I'm not very experienced
     
  6. mavis

    mavis Advanced Member

    Newcomer
    76
    0
    Feb 23, 2006
    That sucks. i just ordered an R4 from a Japanese retailer thinking that since the I/O files were available online I could easily change the language. You mean to tell me I'm stuck with Japanese?!
     
  7. Kyuzumaki
    OP

    Kyuzumaki GBAtemp Regular

    Member
    251
    2
    Dec 24, 2006
    no the problem is not the cart it's the firmware on the ds.
    You will be able to put any R4firmware on the cart you like.
    So bottom line fo you is it will work fine [​IMG]

    The prob with running R4firmware 1.05 is that Chinese DS's have a much larger firmware that allows them to display the 40,000 odd Kanji characters. So when you run the chinese R4firmware the thing crashes cuz it can't find the fonts it wants for the menus.

    EDIT: All the firmwares were confusing so i stuck R4 prefix onto the ones reffering to the R4
     
  8. kennyboy

    kennyboy GBAtemp Regular

    Member
    157
    0
    Apr 14, 2006
    Senegal
    i highly doubt this. DS/dslite are multi-region sets...they contain all the same languages. unless you're talking about the ique ds, but that shouldn't be any different.

    i think the cart itself has some kind of region lock like those for the m3 series of carts.
     
  9. Kyuzumaki
    OP

    Kyuzumaki GBAtemp Regular

    Member
    251
    2
    Dec 24, 2006
    The ique DS is the one with larger chinese firmware.

    It would suprise me if they manufactured a different R4 for english and chinese markets. It would be much cheaper to use exactly the same hardware for both given the DS's are the same except for the extra character sets
     
  10. lexus-8

    lexus-8 GBAtemp Regular

    Member
    197
    0
    Aug 20, 2006
    LONDON
    where do you get the firmware update v1.04 ?
     
  11. Monkey01

    Monkey01 GBAtemp Advanced Fan

    Member
    586
    0
    Aug 27, 2006
    Netherlands
    The Netherlands
    I think it's the other way around, that the m3simply firmware is protected to run on r4, as the error message was said in m3skin...
     
  12. Kyuzumaki
    OP

    Kyuzumaki GBAtemp Regular

    Member
    251
    2
    Dec 24, 2006
    lexus-8:

    Go HERE and you can get the other v1.04 skins HERE
     
  13. Kyuzumaki
    OP

    Kyuzumaki GBAtemp Regular

    Member
    251
    2
    Dec 24, 2006
    TBH i don't know all I can say is the chinese firmware on an english cart in a normal DS doesn't work.

    The rest is just speculation. Only way to test is if someone has an iQue