R4+3 in 1 pack problem

Discussion in 'EZ-Flash' started by bsxyu, Jun 13, 2008.

Jun 13, 2008

R4+3 in 1 pack problem by bsxyu at 12:08 AM (932 Views / 0 Likes) 4 replies

  1. bsxyu
    OP

    Newcomer bsxyu Newbie

    Joined:
    Jun 12, 2008
    Messages:
    4
    Country:
    United States
    Hi!

    I have a DS Lite, a R4DS with 1.18 English Firmware, an EZ-Flash 3 in 1 expansion pack (GBA version AKA "Phat", so that it would also fit my GBA SP and Gameboy Player).

    I'm using Rudolph's GBA ExpLoader version 0.57 and I've succesfully copied one rom to the NOR memory (Mother 3 (J)).
    It works fine and all but the problem is that now, every rom I try to copy to the NOR memory won't load.

    It erases the NOR fine, Analyzes the ROM ok but hangs at 0% of "Copying to memory".
    PSRAM does not work either. It copies all the way to 100% and then hangs there.

    What is puzzling me is that I can erase and copy over the original ROM (Mother 3) as much as I want but any other ROM simply won't do.

    I formatted my R4DS's memory card and reinstalled firmware and ExpLoader without luck.

    Any ideas?
     
  2. Spaceman016

    Newcomer Spaceman016 Advanced Member

    Joined:
    Jun 4, 2008
    Messages:
    70
    Country:
    United States
    Hello Bsxyu

    I dont use an R4 with the 3-in-1 so i cannot comment

    1. I am unsure if you need to patch the GBA_Exploader with DLDI, R4 should be auto patching

    Is your GBA_Exploader.nds and GBA_Exploader.ini in your root folder? (read some things about it playing up if its not in the root folder)
    Have you created a GBASAVE and GBASIGN folders in your root directory? and do they match your .ini file (edit with notepad)
    Try removing the # symbol before No_MultiSave line and save the file (stops exploader always asking for saves + backups)

    After these are checked give us an update
     
  3. bsxyu
    OP

    Newcomer bsxyu Newbie

    Joined:
    Jun 12, 2008
    Messages:
    4
    Country:
    United States
    Thanks for the reply!

    I was setup correctly, all the folders are created and match the .ini.

    I don't need to patch GBA Exploader's .nds as the R4 does it automaticaly.

    Also, it worked fine the first time I tried it (with Mother 3) and now I can't do anything with it.

    As soon as I try to either load a game in NOR or in PSRAM, it freezes. Same thing happens if I ever try to backup the SRAM to SAV folder.

    It's as if my cartridge was write protected or something.

    I tried Rudolph's older 3 in 1 tool which, surprisingly, worked and let me copy a new game to NOR.
    It is far from an ideal solution though, as I much prefer the ExpLoader interface.

    Anyone with an idea what could make ExpLoader unusable even though 3in1 tools work fine?
     
  4. Spaceman016

    Newcomer Spaceman016 Advanced Member

    Joined:
    Jun 4, 2008
    Messages:
    70
    Country:
    United States
    Yes heaps of variables, updates open betas bugs errors compatability :-)

    I prob wouldnt worry about an idea about why it wouldnt work for I cant tell you, as long as it works im happy.

    But for the fun of it,
    The GBA exploader supports the new 3-in-1 chipset whereas the 3-in-1 tool is the older chipset
    Maybe your 3-in-1 has the older chipset and works fine with the 3-in-1 tool, and not with the exploader.
    That would be my guess but the exploader should work with the olderchipset also so....., Theres prob a
    compatability problem otherwise.
     
  5. bsxyu
    OP

    Newcomer bsxyu Newbie

    Joined:
    Jun 12, 2008
    Messages:
    4
    Country:
    United States
    That may be it, as I bought the "phat" version (meaning the GBA cart-sized one).
     

Share This Page