Questions Regarding Acekard 2i Updates and DSi Firmware (and Pokemon)

Discussion in 'Acekard' started by kidcryptid, Jul 18, 2013.

  1. kidcryptid
    OP

    kidcryptid Newbie

    Newcomer
    2
    0
    Jul 18, 2013
    United States
    So I haven't booted up my DSi in a long time, but my friend is wanting to play Pokemon Black & White 2. Right now my DSi is on 1.4U. So I have a couple questions:

    1) On the download page of the Acekard site, it mentions it has a firmware update for the DSi 1.4.4. How do I update my system from 1.4 to 1.4.4 if the latest out there is 1.4.5? Like, how do I choose for my DSi only to update to 1.4.4?

    2) Does that firmware work on the DSi 1.4.5?

    3) It looks like AKAIO 1.9.0 is the latest. I'm assuming this plays Pokemon B&W 2 fine?

    4) Do I need to even do any updating to play B&W or should it work on my 1.4U DSi?

    Any assistance would be great. Thanks.
     
  2. Lacius

    Lacius GBAtemp Guru

    Member
    5,634
    2,122
    May 11, 2008
    United States
    You can't. You only have two options: The firmware you're on or the latest firmware.

    No, it only works on 1.4.4 and anything below that. Since 1.4.0 and 1.4.5 are your only options, you need to stay on 1.4.0 in order for your Acekard to continue working.

    AKAIO 1.9.0 plays Pokemon BW2 just fine with the latest loaders.

    It will work fine on 1.4. Don't update your DSi.
     
    bjelsmore and kidcryptid like this.
  3. kidcryptid
    OP

    kidcryptid Newbie

    Newcomer
    2
    0
    Jul 18, 2013
    United States
    Thanks so much bud, I'll just throw on AKAIO 1.9.0 and boot it up. Thanks!
     
  4. Lacius

    Lacius GBAtemp Guru

    Member
    5,634
    2,122
    May 11, 2008
    United States
    Remember to update the loaders so BW2 works.
     
  5. bjelsmore

    bjelsmore Newbie

    Newcomer
    1
    0
    Jun 10, 2009
    United States


    Thank you Lacius! This is EXACTLY what I was looking for. My sons DSi is at 1.4.3U and I could not for the life of me figure out why I could not get the 1.4.4 firmware update to work! But all he wanted was to play the new Pokemons so AKAIO 1.9.0 and the latest loaders did the trick!