Questions about WiiWare on firmware 3.1U

Discussion in 'Wii - Hacking' started by HopOnRocks, Jul 14, 2008.

Jul 14, 2008
  1. HopOnRocks
    OP

    Newcomer HopOnRocks Advanced Member

    Joined:
    May 19, 2006
    Messages:
    96
    Country:
    Canada
    I'm recently getting back into the Wii scene and I'm finally ready to install a bunch of homebrew that people have created.
    I'm currently using firmware 3.1U on my system and I don't have the update for WiiWare. I never got it in time before 3.2 came out and everyone was saying how no one should update to 3.2
    Anyways, I want to install the homebrew channel later tonight and then proceed to installing some wads, but I'm not sure if I should try a WiiWare one or not because I don't think my system will be able to reconize it. VC games I don't think will be a problem though.

    So is it right for me to install the homebrew channel, and some apps and some VC games on 3.1 and then update my console to 3.3 to install WiiWare titles? I heard that even at 3.3 the homebrew channel still works is that correct? Also the Twilight Hack works, but Truca Signed discs dont? Those Truca discs didn't matter to me because I never messed around with any of my games.
    Also I have a Wiikey installed with the latest firmware.

    Thanks.
     
  2. deba94

    Member deba94 GBAtemp Fan

    Joined:
    Aug 23, 2007
    Messages:
    317
    Location:
    Toronto, Canada
    Country:
    Canada
     
  3. paul1991

    Banned paul1991 Banned

    Joined:
    May 5, 2007
    Messages:
    680
    Country:
    United States
    Yeah. I have 3.1U(I updated with mariokart, but it stayed at 3.1. Go figure.) Anywho, every WiiWare game works. I have tried them all and the worked.
     
  4. HopOnRocks
    OP

    Newcomer HopOnRocks Advanced Member

    Joined:
    May 19, 2006
    Messages:
    96
    Country:
    Canada
    So, I am able to install WiiWare games via the Wad Manager? That program seems really good for the VC games, and I can't seem to find much info about the program someone posted above.
    I guess there is no real reason to update to 3.3 unless you want the Nintendo Channel, and the Mii stuff. But I guess I'm gunna have to do that eventually so I can play the newer games. Is the Twilight Hack any less reliable at 3.3?
     
  5. HopOnRocks
    OP

    Newcomer HopOnRocks Advanced Member

    Joined:
    May 19, 2006
    Messages:
    96
    Country:
    Canada
    Alright, just gunna bump this again because I have 1 more question that I can't seem to get a straight answer to.
    Some people are claiming that the Homebrew channel doesn't load anymore on 3.3, is that correct? Now others are saying it does. I've also been hearing that some people are having trouble installing the channel at 3.3 with the new Twilight Beta hack.
    I currently have it installed, and am very tempted to update my wii so I can get the latest features and actually use my Wii Shop Channel again. But I don't wanna lose homebrew either if in fact 3.3 breaks it.
    So.. can anyone tell me if their channel still works at 3.3? There doesn't seem to be any downside to updating to be honest then.
     

Share This Page