Questions about DSi and R4 gold pro 2016

Discussion in 'NDS - Console and Game Discussions' started by dryden, Jun 9, 2017.

  1. dryden
    OP

    dryden Newbie

    Newcomer
    2
    0
    Jun 9, 2017
    So I bough a DSi in an outlet mall for a few bucks, then I bought this card and its working ok, however I can't connect to the internet because I only have wep type encryption. Ive seen a few videos that show DSi is WPA compatible, so the problem is probabily in the firmware version. If necessary I can connect it to a wep router or to an open internet connection to update it's firmware, but I'm concerned that the R4 might not be supported in earlier versions of the firmware.

    So, should I update it or not? Ty
     
  2. migles

    migles Mei the sexiest bae

    Member
    GBAtemp Patron
    migles is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    6,806
    4,567
    Sep 19, 2013
    Saint Kitts and Nevis
    my dad works for nintendo.
    WPA is only supported in DSI or DSI hybrid game titles.
    a flashcart will run in DS mode no matter what..

    anyway, DS servers shutted down IIRC last year.
     
  3. dryden
    OP

    dryden Newbie

    Newcomer
    2
    0
    Jun 9, 2017

    That really doesn't answer my question. I'm not a native English speaker so I may haven't been clear. The question is should I update the firmware or not? In other words: if I update the firmware will my card still work?
    I'm not asking because of online playing, but because it seems that it lacks some basic functionalities (like connecting to WPA for example), and it might be better with the lastest update.

    thx in advance
     
  4. migles

    migles Mei the sexiest bae

    Member
    GBAtemp Patron
    migles is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    6,806
    4,567
    Sep 19, 2013
    Saint Kitts and Nevis
    my dad works for nintendo.
    i am pretty sure dsi suppports wpa since it's release.. what happens when you go into system settings (without a cart) and try to configure a new connection, doesn't offer you the wpa option?
    like i said earlier, wpa is only supported in dsi titles and it's installed software..
    if you launch your flashcart, it will run in DS mode, which only supports wep..

    i would say to leave the console with that "old" firmware, there is no reason to update it..
    the only way to play online is to use custom servers and for thoose you will have to create a wep\open hotspot either way

    http://en-americas-support.nintendo...l/a_id/4514/~/system-menu-and-feature-updates
    http://www.dsibrew.org/wiki/System_Menu
     
    Last edited by migles, Jun 10, 2017