(Question) Restore browser vulnerabilities on a 5.5.2 console that already has haxchi?

Discussion in 'Wii U - Homebrew' started by DonnieV, Jul 21, 2017.

  1. DonnieV
    OP

    DonnieV Member

    Newcomer
    25
    10
    May 2, 2017
    United States
    This is the scenario:
    A 5.5.2 user who already has haxchi from when they were on 5.5.1
    They install a previous copy of the browser somehow, wupinstaller maybe.
    Would this restore vulnerability?
    Would it have high brick risk?
    Forgive me, I know nothing of how this stuff works.
     
    CatmanFan likes this.


  2. Maschell

    Maschell GBAtemp Advanced Fan

    Member
    885
    1,282
    Jun 14, 2008
    Gambia, The
    Why would you want this? Compared to haxchi the browserhack is soooooo unstable. There is NO reason to prefer browserhack
     
  3. The Real Jdbye

    The Real Jdbye Always Remember 30/07/08

    Member
    GBAtemp Patron
    The Real Jdbye is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    11,429
    4,751
    Mar 17, 2010
    Norway
    Alola
    I don't know if the firmware will let you downgrade titles. With iosuhax it should be possible, but wupinstaller doesn't make use of that currently.
    Brick risk should be 0 since you're not replacing an important title.
     
    Ryccardo and DonnieV like this.
  4. DonnieV
    OP

    DonnieV Member

    Newcomer
    25
    10
    May 2, 2017
    United States
    @Maschell I haven't used browserhax since I first installed haxchi, but there's no downside to having it as a backup right?
    I'm just wondering if it's possible to restore it on a 5.5.2 console that is already exploited
     
    Last edited by DonnieV, Jul 21, 2017
  5. Marko76

    Marko76 GBAtemp Psycho!

    Member
    3,465
    1,942
    Aug 19, 2015
    United Kingdom
    Clydebank
    It would be useful for people on 5.5.2 incase they accidentally delete their haxchi game (Yes i am aware if they have cold boot they are fucked lol)
     
  6. Felek666

    Felek666 Archdemon | #AMDForever

    Member
    3,228
    3,330
    Jan 3, 2017
    Poland
    reddit.com/r/satania/
    You can try to overwrite previous browser version if you know what you're doing with SysConfigTool.
     
  7. OrGoN3

    OrGoN3 GBAtemp Advanced Maniac

    Member
    1,754
    368
    Apr 23, 2007
    United States
    And you will have to either disable updates or DNS block them or hope that you never click check for a system update by accident.
     
    Felek666 likes this.
  8. monkeyman4412

    monkeyman4412 GBAtemp Advanced Fan

    Member
    542
    108
    Jun 16, 2016
    United States
    wait.... I thought that tool could only be used on emunand.
     
  9. Marko76

    Marko76 GBAtemp Psycho!

    Member
    3,465
    1,942
    Aug 19, 2015
    United Kingdom
    Clydebank
    No there has been a version of sysconfigtool that works on nand since the start of the year.
     
  10. C0mm4nd_

    C0mm4nd_ Aspirant Wii U homebrew dev :P

    Member
    675
    330
    Oct 9, 2016
    Italy
    Actually it always worked, If it bricks sysNAND, it bricks redNAND too and vice versa
     
  11. 3DSPoet

    3DSPoet GBAtemp Fan

    Member
    367
    206
    Dec 9, 2015
    United States
    I haven't a clue about how Wii U works, but on the Old 3DS, you could update your firmware, then reinstall an older version of the browser for using things like Spider. The New 3DS used an entirely different browser, so it doesn't work on there...
    Not sure if that's the case with the Wii U, but just a thought...
     
  12. Felek666

    Felek666 Archdemon | #AMDForever

    Member
    3,228
    3,330
    Jan 3, 2017
    Poland
    reddit.com/r/satania/
    tbh, 3DS has more homebrew to install system apps easily, all we have is Nintendo's old leaked version of SysConfigTool which is capable of doing it. (It errors out if there's a problem with app if there's a problem with it)
     
  13. aplumafreak500

    aplumafreak500 Member

    Newcomer
    22
    15
    Dec 20, 2014
    United States
    East Smethport, PA
    I was wondering the same thing, and I don't see why it wouldn't work, especially since the IOSU wasn't updated. The only things I would really look out for are update blocking, but apart from that, with the legit ticket and TMD, it's an easy install with WUP Installer, and some quick testing.
     
  14. Ryccardo

    Ryccardo WiiUaboo

    Member
    2,894
    1,353
    Feb 13, 2015
    Italy
    Imola
    Couldn't be bothered to rebuild wupinstaller without """safety""", so I just updated 5.5.1 to 5.5.2 via ftpiiu-everywhere and everything is just fine (but I'm on CBHC), going to redowngrade the browser now
     
  15. KiiWii

    KiiWii GBAtemp Psycho!

    Member
    3,667
    1,219
    Nov 17, 2008
    United Kingdom
    And how do you run wupinstaller on the 5.5.2 system to get the browser downgraded?
     
  16. gudenau

    gudenau Never a unique idea

    Member
    3,237
    1,216
    Jul 7, 2010
    United States
    /dev/random
    I would just copy the old browser over the new one with FTP.
     
    KiiWii likes this.
  17. KiiWii

    KiiWii GBAtemp Psycho!

    Member
    3,667
    1,219
    Nov 17, 2008
    United Kingdom
    How do you achieve FTP without homebrew or CFW?
     
  18. gudenau

    gudenau Never a unique idea

    Member
    3,237
    1,216
    Jul 7, 2010
    United States
    /dev/random
    "console that already has haxchi?"
     
    KiiWii and Ryccardo like this.
  19. KiiWii

    KiiWii GBAtemp Psycho!

    Member
    3,667
    1,219
    Nov 17, 2008
    United Kingdom
    Fair play, I completely missed that :(
     
  20. Ryccardo

    Ryccardo WiiUaboo

    Member
    2,894
    1,353
    Feb 13, 2015
    Italy
    Imola
    Yes, browser-only downgrade appears to be fine


     
    Last edited by Ryccardo, Jul 26, 2017
    Pepois likes this.