Question/Idea? 4.5 Emunand on N3ds to allow for MT-card/DStwo+?

Discussion in '3DS - Flashcards & Custom Firmwares' started by Timburpton, Jun 18, 2016.

  1. Timburpton
    OP

    Timburpton GBAtemp Advanced Fan

    Member
    591
    133
    Nov 18, 2014
    NOTE: I'm referring to 3DS mode not the DS cart mode

    The MT-Card and DSTWO plus does not work on the N3ds because it default comes on firmware>9.2.

    However, if the sysnand of N3ds were to be downgraded to 4.5, I'm fairly certain it will work.

    Given this, would it be possible to boot straight into emunand 4.5 (via a9lh) in order to facilitate the usage of emunand with MT-card/DSTwo+?

    Premise
    1. Gateway A9LH.bin serves to launch the launcher.dat (this means we have a way to start launcher.dat)
    2. MT-card and DStwo+ launcher.dat is launched but fails to work. I have tested this with 2.3 MT-card launcher.dat and it black screens. This situation is the same as when emunand version is too high and not supported
    3. Hypothesis is that in the link below

    For instance
    https://gbatemp.net/threads/how-to-...latest-10-1-emunand-with-eshop-access.398117/

    This allows the usage of latest emunand on MT-card via hex editing. It stands to reason that some of the titles are not working on >9.2 hence resulting in MT-card/dstwo+ not booting.

    Solution?
    1. Either create a emunand with 4.5 and use the above link to install the 4 system titles after hex editing
    2. Or install the 4 system titles after hex editing directly onto sysnand allow for MT-card/DStwo+ support.
    What I need from you guys in terms of advice and help
    1. With N3DS A9LH, can I swap SD card to prepare for emunand etc etc and when its all done can I just swap back to my original SD card and have my 3ds back to its original state before this experiment?
    2. Solved
      Warning: Spoilers inside!

     
    Last edited by Timburpton, Jun 18, 2016
  2. ShadowOne333

    ShadowOne333 GBAtemp Guru

    Member
    7,070
    4,477
    Jan 17, 2013
    Mexico
    Why not simply install the DS Flashcart Whitelist CIA?
    I did that for both my N3DS w/Blue GW cart and my O3DS w/R4itt cart, both systems with 11.0 A9LH sysnand and both flashcarts work wonderfully.
     
    Last edited by ShadowOne333, Jun 18, 2016
  3. satan89

    satan89 GBAtemp Fan

    Member
    374
    119
    Jan 30, 2014
    India
    Bangalore
    I can help you with this at least.
    Find the 4.5 fw on that iso site and use sysupdater in emuNAND to downgrade it to that version.
    Remember that N3DS doesnt officially support 4.x, And 4.x doesn't have a softkey to toggle WiFi
     
  4. Timburpton
    OP

    Timburpton GBAtemp Advanced Fan

    Member
    591
    133
    Nov 18, 2014
    My bad, I wasn't clear. Was referring to the 3ds cart.

    Yeah but would 4.5 work natively? I remember while installing a9lh, 2.1 needed to be unbricked to work. Would 4.5 need to be unbricked to work or does it work straight away?
     
  5. ShadowOne333

    ShadowOne333 GBAtemp Guru

    Member
    7,070
    4,477
    Jan 17, 2013
    Mexico
    You need to unbrick it too since 4.5 is only available for O3DS, N3DS needs unbricking for that FW to load.
     
  6. Timburpton
    OP

    Timburpton GBAtemp Advanced Fan

    Member
    591
    133
    Nov 18, 2014
    How can I unbrick it though?
     
  7. satan89

    satan89 GBAtemp Fan

    Member
    374
    119
    Jan 30, 2014
    India
    Bangalore
    I Don't know that.
    Why exactly are you trying to use MT/DSTWO?
     
  8. Timburpton
    OP

    Timburpton GBAtemp Advanced Fan

    Member
    591
    133
    Nov 18, 2014
    Because I own a MT and am considering getting a DSTWO+ for my DS+3DS needs. I mainly use CIAs now but would like to tinker around. That's why the homebrew/cfw scene exists. People work to do shit that can't be done before.
     
    Ryccardo and satan89 like this.
  9. Ryccardo

    Ryccardo WiiUaboo

    Member
    3,208
    1,544
    Feb 13, 2015
    Italy
    Imola
    With otphelper!
    Not one click setup, of course, but the "unbrick" only option... assuming it doesn't verify that your titles are the 2.1 ones...
     
  10. Timburpton
    OP

    Timburpton GBAtemp Advanced Fan

    Member
    591
    133
    Nov 18, 2014
    Interesting. Now all that is left is to confirm if I can perform such things by using a new SD card and then getting my 3ds back to the way it was by replacing my original sd card.
     
  11. Ryccardo

    Ryccardo WiiUaboo

    Member
    3,208
    1,544
    Feb 13, 2015
    Italy
    Imola
    Yes, it's perfectly possible to have multiple emunands by putting each on a different card (and in fact has much better compatibility than the various multi-emunand solutions).
    I don't know though if the MT cfw will like a n3ds partition table...
     
  12. Timburpton
    OP

    Timburpton GBAtemp Advanced Fan

    Member
    591
    133
    Nov 18, 2014
    Interesting. I guess I'll be extra careful about this then. I'll perform a NAND backup first etc etc.

    Since A9LH means I'm brick proof so long as I don't mess with A9LH itself.