Question before updating my o3DS to 11.1.0-34 U

Discussion in '3DS - Homebrew Development and Emulators' started by Rion45, Oct 8, 2016.

  1. Rion45
    OP

    Rion45 Member

    Newcomer
    40
    2
    Sep 12, 2016
    United States
    I've held back on updating for a while now. My main entry point to homebrew was SmileBASIC, but he loved a short life :c

    Now that basehaxx seems to work on the new firmware, I'm thinking of installing the 11.1 ver and then updating.

    But I heard earlier that save manager isn't working? That's the main reason I use Homebrew and in wondering what happened with it. Is it only for ORAS or is it for every game?
     
  2. Xiphiidae

    Xiphiidae

    Member
    2,085
    1,021
    Sep 13, 2009
    Australia
    In regard to save managers not working on 11.1, that's pretty much only for ORAS (and a small handful of other games), but there's a workaround by downloading Pokémon Bank and using JKSV. Reading through the recent pages in the JKSV thread will point you in the right direction for that.

    To be honest, I would recommend not updating to 11.1 and instead using ctr-httpwn to access online features.

    What system version are you on at the moment?
     
    Last edited by Xiphiidae, Oct 8, 2016
  3. Rion45
    OP

    Rion45 Member

    Newcomer
    40
    2
    Sep 12, 2016
    United States
    Thanks for the links! Thd bypass is definitely helpful. I'll be sure to install it later so I can continue using pkHex. Although it isn't my priority. I mainly use the ACNL Sve Editor and HANS

    I'm on 11.0.0-33U right now.
     
    Last edited by Rion45, Oct 8, 2016
  4. Xiphiidae

    Xiphiidae

    Member
    2,085
    1,021
    Sep 13, 2009
    Australia
    No problem.

    I would definitely recommend staying on 11.0 and reading a bit on httpwn. There's no reason to upgrade to 11.1.
     
  5. Rion45
    OP

    Rion45 Member

    Newcomer
    40
    2
    Sep 12, 2016
    United States
    True. Hopefully I'll be able to get httpwn to work, I need to get that Sun and Moon demo!
     
  6. Returnofganon

    Returnofganon I pretend like I know what I'm talking about

    Member
    533
    198
    Jul 1, 2015
    United States
    Its always good to stay on a downgrade able firmware. Well with some work downgrade able
     
  7. Omer

    Omer GBAtemp Regular

    Member
    214
    20
    May 13, 2014
    what if I'm on 11.0 and using arm9loader and luma cfw , should I update ?
     
  8. Returnofganon

    Returnofganon I pretend like I know what I'm talking about

    Member
    533
    198
    Jul 1, 2015
    United States
    You are good to go. I updated last week an everything is fine. Typically you are good to update if you have a9lh and luma, just make sure you have a backup if you are unsure if you will brick ;)
     
  9. Rion45
    OP

    Rion45 Member

    Newcomer
    40
    2
    Sep 12, 2016
    United States
    Apparently I can't install .CIA files with 11.0? How should I get httpwn to work then?
     
  10. KunoichiZ

    KunoichiZ GBAtemp Guru

    Member
    8,426
    3,535
    Mar 16, 2012
    United States
    ctr-httpwn is a Homebrew application, not a .cia. You launch ctr-httpwn via the Homebrew Launcher, then press Start then X to exit back into the Home Menu to keep ctr-httpwn. And yes, you can't install CIAs on 11.0+ without CFW.
     
  11. Rion45
    OP

    Rion45 Member

    Newcomer
    40
    2
    Sep 12, 2016
    United States
    You know what, I'm dumb! Thanks for telling me. I forgot it was already installed. I tested it and can access the eshop perfectly.

    Thanks for all the help guys! Looks like this 3DS will stay in 11.0 for a long time.