Question About the CycloDSi (and other DSi Flashcarts)

Discussion in 'CycloDS' started by Bowser-jr, Dec 25, 2010.

  1. Bowser-jr
    OP

    Member Bowser-jr GBAtemp Fan

    Joined:
    Nov 27, 2008
    Messages:
    342
    Country:
    United States
    I just got a new DSi and wondering, should I update the system? I would like to get a DSi flashcart; preferably the CycloDSi since CycloDS was my first flashcart. Is it best for me not to update my DSi system or is there a flashcart out there that is able to work with the latest Nintendo DSi firmware?
     
  2. Red_Gh0st

    Member Red_Gh0st GBAtemp Regular

    Joined:
    Oct 24, 2010
    Messages:
    238
    Location:
    Puerto Rico
    Country:
    United States
    Almost all flashcards work with the latest firmware
     
  3. Bowser-jr
    OP

    Member Bowser-jr GBAtemp Fan

    Joined:
    Nov 27, 2008
    Messages:
    342
    Country:
    United States
    cool, thanks

    Does anyone know if the CycloDSi will work with the latest firmware.
     
  4. AP Hacker

    Newcomer AP Hacker Advanced Member

    Joined:
    Oct 2, 2010
    Messages:
    85
    Country:
    Canada
    I believe it was stated in one of the numerous posts on GBATemp that the CycloDSi will work on arrival, meaning yes, it will work.
     
  5. DeMoN

    Member DeMoN GBAtemp Guru

    Joined:
    May 12, 2004
    Messages:
    7,647
    Country:
    United States
    It has a USB connector like the m3i0, so you can rest assured it will always work with the latest DSi firmware (as long as Team Cyclops keeps it updated!)
     
  6. Rydian

    Member Rydian Resident Furvertâ„¢

    Joined:
    Feb 4, 2010
    Messages:
    27,883
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    Games do not need firmware updates, don't bother updating unless you want to use the store.
     

Share This Page