[Q] GBA cia on emunand not rendering screen correctly

Discussion in '3DS - Flashcards & Custom Firmwares' started by Hepklep, Sep 11, 2015.

  1. Hepklep
    OP

    Hepklep Member

    Newcomer
    19
    3
    Aug 16, 2015
    So recently I've been dabbling in gba games converted to 3ds format in the form of a cia file. So they all install correctly and run, but the problem is that they don't display correctly. The top of the screen is cropped off and then displays on the bottom of the screen, so it makes it a bit difficult to play. This happens in some games more then others, and I was just wondering if anyone had come across it at all or knows of a fix for it?
    [​IMG]
    --------------------------------------
    emunand 9.9 on a sysnand 3ds XL 9.2
     


  2. ubergeek77

    ubergeek77 Post editing world champ.

    Member
    556
    255
    Dec 6, 2014
    United States
    Is this using AGB_FIRM or the experimental GBA emulator found inside the other VC titles? I've been running a lot of custom AGB_FIRM GBA games and I've never had this problem. How does the ROM you used run in something like VBA?
     
  3. Hepklep
    OP

    Hepklep Member

    Newcomer
    19
    3
    Aug 16, 2015
    Bringing up an old thread I know, but it's just this game. Doesn't matter what source it comes from, as soon as it's put as a CIA on the 3ds it has the screen off so the top pans back around to the bottom. These are all installed as CIA's and I've tried on multiple emunand versions all the way from 9.6 through to 10.3 and every time the exact same thing. As I said, I have not seen this with any game except DBZ Legacy of Goku II. Does anyone experience this? And if so has anyone found a fix?
     
  4. deinonychus71

    deinonychus71 GBAtemp Fan

    Member
    315
    206
    Sep 12, 2008
    United States
    Chicago
    Last edited by deinonychus71, Feb 28, 2016
  5. LeSpaz

    LeSpaz Advanced Member

    Newcomer
    57
    18
    Jan 5, 2016
    United States
    Sorry to bump an old thread (probably better than starting a new one)...
    but I am getting the same problem above when I try loading Pokemon Emerald/Fire Red/Leaf Green.

    Specs:
    New 3DS
    Reinand 10.7
    128gb MicroSD

    I'm hoping the only fix isn't switching sd cards because there's really isn't a chance for me to just swap out a 128gb card...

    So if any one knows a possible fix?
     
  6. stl25

    stl25 GBAtemp Advanced Fan

    Member
    963
    535
    Feb 3, 2008
    United States
    Here, there and everywhere
    I have had this problem recently and it only happens on GBA VC roms 16MB and larger. I had the problem on Zelda Minish Cap, Mega Man Zero 4, Donkey Kong Country 3 and all Pokemon Games. Not really sure why it is happening. I am formatting my mSD with 64 kb clusters and installing the AGB_FIRM with no splash screen to try and fix. Are you using the AGB_FIRM with Gameboy splash screen?
     
  7. LeSpaz

    LeSpaz Advanced Member

    Newcomer
    57
    18
    Jan 5, 2016
    United States
    Hmm that's pretty good speculation for >16MB games.

    And yes I'm using the patched agb_firm with the splash screen (because nostalgia lol).
    I guess i might as well try the patched agb_firm without the splash screen i guess.
     
  8. stl25

    stl25 GBAtemp Advanced Fan

    Member
    963
    535
    Feb 3, 2008
    United States
    Here, there and everywhere

    That is what I am going to test once I restore my SD contents. Good luck.
     
  9. ANU815

    ANU815 Newbie

    Newcomer
    5
    1
    Aug 25, 2014
    United States
    Any update on this? I'm also using a 128gb FAT32 formatted microSD on my N3DS on aureinand a9lhax. I have the exact same screen issue except for <16mb games (I think). I've not done anything with agb_firm other than what was in the aureinand a9lhax install pages. I only have sysnand. No red or emunand.
     
  10. LeSpaz

    LeSpaz Advanced Member

    Newcomer
    57
    18
    Jan 5, 2016
    United States
    Unfortunately still happening with mine, with the screen display being off like shown above.
    Guess we'd just have to cut down the >16MB files I guess??
     
  11. OrGoN3

    OrGoN3 GBAtemp Advanced Maniac

    Member
    1,754
    368
    Apr 23, 2007
    United States
    Assuming you're using a custom Minish Cap ROM and not, for example, the eshop one?
     
  12. jonnytron

    jonnytron Advanced Member

    Newcomer
    85
    8
    Dec 4, 2015
    Hi, same problem here. I posted on the homebrew boards but realised that it's probably not the ideal place for this issue.

    So has anyone quietly found a method to fix this? Aside from downsizing the SD card?

    Edit: Also, pressing the home button in game makes the screen scroll further up... after doing this a good 20 times the screen levels itself out. So i suppose thats sort of a fix.
     
    Last edited by jonnytron, May 27, 2016
  13. shadoom

    shadoom GBAtemp Regular

    Member
    150
    42
    Sep 14, 2009
    Taiwan
    I have noticed the same but for me its totally random.
    Sometimes the game doesn't get cut-off, and sometimes (feels like 30%?) it does.
    Also the home button only moves the screen up by some pixel every 10th time i push it.

    I asked some people in IRC but they think I'm crazy as they've never heard of it.


    btw. 128gb sd + n3dsxl + luma3ds
     
    Hepklep likes this.
  14. jonnytron

    jonnytron Advanced Member

    Newcomer
    85
    8
    Dec 4, 2015
    Yeah ive just given up hope at this stage. I just hammer the home button until the screen fixes if i ever want to play those titles :lol: its just a very odd side effect of big sd cards i think.
     
  15. CheatFreak47

    CheatFreak47 Complex Donut

    Member
    1,335
    888
    Oct 11, 2011
    United States
    Michigan, USA
    I can confirm this as well, but I've always been able to fix it by powering off from the home menu, and powering back on to start the game I wanted to play.
     
  16. shadoom

    shadoom GBAtemp Regular

    Member
    150
    42
    Sep 14, 2009
    Taiwan
    the aurora dev said this:
    "I recall this being an AGB FIRM issue with cluster size on the SD FAT FS (too small or too large, can't remember). It surely is not a Luma issue."
    What are your cluster sizes on the SD?
     
  17. CheatFreak47

    CheatFreak47 Complex Donut

    Member
    1,335
    888
    Oct 11, 2011
    United States
    Michigan, USA
    So to put this issue to rest once and for all, I did 10 tests of 3 SD, 3 times each with different formats, here are the results.
    All performed on a New 3DS XL, with the official copy of WarioWare, Inc. Mega Microgame$!. Cards formatted with Minitool Partition Wizard each time.
    ---
    4GB Toshiba SDHC @ FAT32 16KB Cluster Size
    0/10 times the issue was present.

    4GB Toshiba SDHC @ FAT32 32KB Cluster Size
    0/10 times the issue was present.

    4GB Toshiba SDHC @ FAT32 64KB Cluster Size
    1/10 times the issue was present.

    32GB SanDisk SDHC @ FAT32 16KB Cluster Size
    0/10 times the issue was present.

    32GB SanDisk SDHC @ FAT32 32KB Cluster Size
    0/10 times the issue was present.

    32GB SanDisk SDHC @ FAT32 64KB Cluster Size
    1/10 times the issue was present.

    64GB Samsung EVO SDXC @ FAT32 16KB Cluster Size
    0/10 times the issue was present.

    64GB Samsung EVO SDXC @ FAT32 32KB Cluster Size
    0/10 times the issue was present.

    64GB Samsung EVO SDXC @ FAT32 64KB Cluster Size
    2/10 times the issue was present.

    ---
    Seems clusters above 32KB cause the issue. So riding the line by being on 32 seems to be the best option, since it seems going lower makes the console significantly slower, especially on the largest card sizes.

    In addition, it seems it may be more common on larger card sizes, possibly related to larger cards being slower?

    Edit: fixed a couple typos I made.
     
    Last edited by CheatFreak47, Aug 16, 2016 - Reason: fixed typos.
    astronautlevel and zezzo like this.
  18. contingences

    contingences Member

    Newcomer
    40
    12
    Sep 5, 2016
    Belgium
    Hello, it seems getting a 128gb micro sd card could be an issue alone:
    mine is :

    128GB sandisc SDXC @ FAT32 32KB Cluster size
    6/10 times the issue was present (with certain games only, like FFVIadv) - and 10/10 on first boot.

    So, revert back to 64 (humpf, I dumped all my collection on my 128) will do the trick ?

    Regards


    (nb : when you are playing GBA in original resolution (Start+Select when loading the game) it’s not the upper screen which is cropped to the bottom, but the bottom which is double. The upper section is missing, though.
     
    Last edited by contingences, Sep 17, 2016
  19. Classicgamer

    Classicgamer GBAtemp Fan

    Member
    497
    135
    Aug 20, 2012
    United States
    Has this issue been resolved yet? it's been quite some time and I'm having the same issue myself.
     
  20. Xyphoseos

    Xyphoseos Hack or no games

    Member
    755
    66
    Jun 29, 2016
    France
    same issue, I don't understand why (128gb new3ds for me)