Hacking Purple screen Switch and failed to init emmc.

Grimm

Well-Known Member
OP
Newcomer
Joined
Nov 22, 2008
Messages
79
Trophies
0
XP
172
Country
United States
Hi guys,

A few years ago my brother hit me up saying his Switch had taken a crap on him. I know a little about a lot so I told him to bring it over. It was giving him this purple screen when turned on and wouldnt do anything. Hard reset wasnt helping so I tried to load cfw on it. RCM was working so I followed the guide and ran Tegrasmash on it and loaded Hekate. Now anything I try to do with emmc results in 'failed to init emmc.'

I tried all kinds of guides and read a bunch of threads with people trying various fixes but nothing seems to help. Memloader/hacdiskmount, gptrestore, tried to pull nand stuff from hekate... Nothing. I tried taking it apart and cleaning the connector where the emmc board connects to the switch. Everything looked fine inside.

He wasnt doing anything weird with it at the time when it first bricked. Official Nintendo dock, plenty of battery, no mods or hacks and so on. He played it, went to bed and when he got up it was purple screened. So needless to say we have no nand backup or anything like that.

He has since replaced it with a working unit but since I have this hackable Switch laying around it would be great to be able to get it to do SOMETHING. I dont care about getting banned, going online, etc. I have plenty of physical Switch games I can play from my Lite but it would be awesome to have this running so I could play on the TV or use emulators.

Is there any way to get this thing working with few or something?
 

Draxzelex

Well-Known Member
Member
Joined
Aug 6, 2017
Messages
16,692
Trophies
1
Age
27
Location
New York City
XP
11,239
Country
United States
Hi guys,

A few years ago my brother hit me up saying his Switch had taken a crap on him. I know a little about a lot so I told him to bring it over. It was giving him this purple screen when turned on and wouldnt do anything. Hard reset wasnt helping so I tried to load cfw on it. RCM was working so I followed the guide and ran Tegrasmash on it and loaded Hekate. Now anything I try to do with emmc results in 'failed to init emmc.'

I tried all kinds of guides and read a bunch of threads with people trying various fixes but nothing seems to help. Memloader/hacdiskmount, gptrestore, tried to pull nand stuff from hekate... Nothing. I tried taking it apart and cleaning the connector where the emmc board connects to the switch. Everything looked fine inside.

He wasnt doing anything weird with it at the time when it first bricked. Official Nintendo dock, plenty of battery, no mods or hacks and so on. He played it, went to bed and when he got up it was purple screened. So needless to say we have no nand backup or anything like that.

He has since replaced it with a working unit but since I have this hackable Switch laying around it would be great to be able to get it to do SOMETHING. I dont care about getting banned, going online, etc. I have plenty of physical Switch games I can play from my Lite but it would be awesome to have this running so I could play on the TV or use emulators.

Is there any way to get this thing working with few or something?
Have you tried using ChoiDujour?
 
General chit-chat
Help Users
    Julie_Pilgrim @ Julie_Pilgrim: i fuckin love this post...