PSP shuts down after a few minutes

Discussion in 'PSP - Console, Accessories and Hardware' started by He4TS3eKeR, Dec 16, 2012.

  1. He4TS3eKeR

    He4TS3eKeR Newbie

    Sep 26, 2012
    Alright, so I've got this problem with my PSP, it always shuts down after a few minutes of being on. I doubt its a system problem, it's not a memory card problem, not a battery problem (tried 2) which work on my friends psp. I've tried a lot of things and tests and I've concluded that this thing that started happening recently, my UMD drive is going all crazy, there's nothing in it i've turned all the system settings concerning UMD's to off or none.

    It started doing this thing where every time i turn on my psp the UMD drive starts doing something. I can hear moving noises, like when you actually put a UMD in. Something is moving inside the drive left and right stopping for a second and spinning or something. I've never had that happen before, but now it happens every time i turn it on. The psp also stopped working when that started.

    It's kinda like that action which the UMD drive preforms, tells the PSP to shut down in 5 minutes, and it always shuts down in the same timeframe too.

    Does anyone have any insight on this? I'd really appreciate help.
  2. Kouen Hasuki

    Kouen Hasuki Kouen the Cyber Husky

    Jan 9, 2013
    Gaming Bunker
    This sounds to me like a possible motherboard fault.

    What PSP Model is it? also are you running custom firmware?

    If your on a recent custom firmware taking the battery out, and putting it in power it on while holding R there is an option in there that you can reset your settings.

    Go to Advanced then to "Format flash1 and reset settings" and press X. Please note that it will reset your PSP internal memory like you have never used it before so any wifi settings and your PSN ID will be erased from the Unit, While it should not affect any data on your memory stick it never hurts to remove it before doing this.

    If you have Custom Firmware I have a few idea's if your on official firmware you could try factory resetting your psp (again remove memory stick 1st) from the PSP.

    Also does this occur only when you have a UMD / Memory stick in the unit or both?