psp not powering on

Discussion in 'PSP - Games & Content' started by SugaDaddy, May 14, 2008.

  1. SugaDaddy
    OP

    SugaDaddy Advanced Member

    Newcomer
    1
    Oct 16, 2007
    United States
    ur moms vagine
    ok heres mi problema. while taking off my LCD on my phat, i popped the plug(or fuse?) on the motherboard. when i press it and my charger is plugged in, i get an orange LED, but no green LED when i try turn it on. no booting whatsoever either. i tried following the instructions in this youtube video, http://www.youtube.com/watch?v=mYRnaImG28E, and when i press the little tab i get the green LED, still no booting.

    here are some pics

    [​IMG]


    [​IMG]


    [​IMG]


    should i bridge the plug?
     
  2. SavageWaffle

    SavageWaffle GBAtemp Maniac

    Member
    1
    Jan 13, 2008
    United States
    New York
  3. lookout

    lookout GBAtemp Board Room

    Member
    1
    Aug 16, 2006
    United Kingdom
    SugaDaddy, I notice you also brick your Wii and then PSP what else have brick... lol
     
  4. superrob

    superrob H4X H4X H4X!

    Member
    2
    Apr 4, 2007
    GBATemp factory.
    Himself [​IMG]?
     
  5. SugaDaddy
    OP

    SugaDaddy Advanced Member

    Newcomer
    1
    Oct 16, 2007
    United States
    ur moms vagine
    i already tried that, idk for some reason it didnt work lol [​IMG]
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice