PSP 3000 on 5.03 - Which way to go now?

Discussion in 'PSP - Hacking & Homebrew' started by kiafazool, Feb 13, 2011.

Feb 13, 2011
  1. kiafazool
    OP

    Member kiafazool GBAtemp Maniac

    Joined:
    Apr 21, 2010
    Messages:
    1,221
    Location:
    Canada
    Country:
    Canada
    hey guys
    kiafazool here
    with someones psp that i applied 5.03 gen-c on
    and they cannot get any new games to work
    so instead of taking 30 mins of my life to explain them how to patch games - i decided to just take their psp to upgrade it

    so im pretty much dead on the psp after the psp died around 2 years ago
    i know theres 6.20 tn-d (soon d) and 6.35 pro-a and others including hbl

    so what is the best one to upgrade to?

    im preferring something that doesn't require any "iso loader" but if it has to go to that, i guess i can spare 10 mins

    ty

    EDIT: btw its a psp 2000 with the v3 motherboard that cannot get 100% cfw - that one that only softmods

    also i know there is a sticky - theres a reason i made this thread (no offence rydian[​IMG])
     
  2. Rydian

    Member Rydian Resident Furvert™

    Joined:
    Feb 4, 2010
    Messages:
    27,883
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    The 6.x hacks are worse.
    The 5.x hacks are better.
     
  3. yeop

    Member yeop GBAtemp Regular

    Joined:
    Jun 2, 2010
    Messages:
    138
    Location:
    Spain
    Country:
    Spain
    If yu dont want a CFW that requires ISO Loader you can install Prometheus patch.
    I have my PSP3000 with 5.03 GEN-C + Prome 4(the one which was leaked when Monster Hunter came out) and I haven´t got any problem with it.
    However I didn´t try new games. The last I tried was european version Lord of Arcana and it worked fine.

    If you already have Prometheus and new games don´t work you´ll have to update to 6.20 TN or 6.35 PRO
     
  4. kiafazool
    OP

    Member kiafazool GBAtemp Maniac

    Joined:
    Apr 21, 2010
    Messages:
    1,221
    Location:
    Canada
    Country:
    Canada
    i dont have prometheus on it yet
    EDIT: which prometheus for 5.03 is the newest? is it v4? or is there a v5?
     
  5. yeop

    Member yeop GBAtemp Regular

    Joined:
    Jun 2, 2010
    Messages:
    138
    Location:
    Spain
    Country:
    Spain
    Try it then. It's easy to install.
    And after you installed it first time, the next time you have to load it you can load the Prometheus directly from ChickHEN r2.
    So you won´t need to install GEN-C and then Prome.

    I think the last is the Promtheus-4
     
  6. Rydian

    Member Rydian Resident Furvert™

    Joined:
    Feb 4, 2010
    Messages:
    27,883
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    The 5.03, 5.00, and 5.50 hacks have almost the exact same compatibilty with homebrew and ISOs and such. That is, almost everything.

    The 6.20, 6.31, and 6.35 hacks all have major flaws, including a majority of plugins not working, much homebrew not working, and even older PSP games not work, in addition to the complete lack of custom POPS/PSX loading.

    When these things change 6.x will become the new standard, but as of right now I suggest the 5.x hacks.
     
  7. kiafazool
    OP

    Member kiafazool GBAtemp Maniac

    Joined:
    Apr 21, 2010
    Messages:
    1,221
    Location:
    Canada
    Country:
    Canada
    which one is the newest version?
    i found a prometheus v6 for 5.03 gen-c
     
  8. kiafazool
    OP

    Member kiafazool GBAtemp Maniac

    Joined:
    Apr 21, 2010
    Messages:
    1,221
    Location:
    Canada
    Country:
    Canada
    the owner of the psp
    doesnt need plugins
    doesnt need homebrew
    doesnt need pops/psx

    only need isos and most like only new isos only because hes almost done playing all the old ones

    EDIT:darn flabbit
    double posted
     
  9. yeop

    Member yeop GBAtemp Regular

    Joined:
    Jun 2, 2010
    Messages:
    138
    Location:
    Spain
    Country:
    Spain

    v6 I think is version 6 of the first prometheus released.
    After it there are prome-2,3 and 4(whitouth te "v")

    look for the 5.03 prometheus-4, it was releases it december 2010
     
  10. kiafazool
    OP

    Member kiafazool GBAtemp Maniac

    Joined:
    Apr 21, 2010
    Messages:
    1,221
    Location:
    Canada
    Country:
    Canada
    im getting confused
    there is prometheus v6 then prome-4 and then prometheus-4

    just give me a link to the lastest version
     
  11. yeop

    Member yeop GBAtemp Regular

    Joined:
    Jun 2, 2010
    Messages:
    138
    Location:
    Spain
    Country:
    Spain
    Sorry for confusing you, prometheus and prome are the same, it´s just a shorter name.

    Try this download link
     
  12. Rydian

    Member Rydian Resident Furvert™

    Joined:
    Feb 4, 2010
    Messages:
    27,883
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    The v6 is Prome-1 v6.
    Prome-4 is the latest.

    You want the Prome-4 addon (that yeop linked)for 5.03 to play recent games.
     
  13. kiafazool
    OP

    Member kiafazool GBAtemp Maniac

    Joined:
    Apr 21, 2010
    Messages:
    1,221
    Location:
    Canada
    Country:
    Canada
    oh k i got it
    and thanks yeop for the link

    ill see how this works and report back

    EDIT

    i started it up and it says 5.03 prometheus-3

    i guess its an old version

    ill look for -4
     
  14. yeop

    Member yeop GBAtemp Regular

    Joined:
    Jun 2, 2010
    Messages:
    138
    Location:
    Spain
    Country:
    Spain

    It says prometheus-3 but it is -4

    Liquidzigong(the author) didn´t want to release it but it was leaked.
    So maybe the name wasn´t changed for this reason.
    But I´m sure that it is prometheus-4, when I installed it I thought it was wrong but I tried loading Monster Hunter Freedom 3rd and it loaded so it was prometheus-4
     
  15. kiafazool
    OP

    Member kiafazool GBAtemp Maniac

    Joined:
    Apr 21, 2010
    Messages:
    1,221
    Location:
    Canada
    Country:
    Canada
    i download -4 from another place and it had the exact same files

    ill just install this
     
  16. Rydian

    Member Rydian Resident Furvert™

    Joined:
    Feb 4, 2010
    Messages:
    27,883
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    Yeah he didn't officially finish version 4, so the version string is changed on some (like the 5.50 version) and not on others.
     
  17. kiafazool
    OP

    Member kiafazool GBAtemp Maniac

    Joined:
    Apr 21, 2010
    Messages:
    1,221
    Location:
    Canada
    Country:
    Canada
    is there any difference on 5.50 prome-4 vs 5.03 prome-3
     
  18. yeop

    Member yeop GBAtemp Regular

    Joined:
    Jun 2, 2010
    Messages:
    138
    Location:
    Spain
    Country:
    Spain
    5.50 is only for 5.50 GEN which PSP 2000 v3 and 3000 can´t load
    The patch is exactly the same, just for different GEN firmwares
     

Share This Page