Hardware PSP-3000: Battery not detected

SaddQ

Well-Known Member
OP
Member
Joined
Aug 11, 2010
Messages
157
Trophies
0
XP
485
Country
Netherlands
Hi folks.
Here's the problem: I got two PSP's, both model 3000. One of them charges and plays fine. The other one, however, will only play when powered by the power cable. Under "settings>battery information", it doesn't even display any battery (see the picture), nor is any battery icon present on the home screen.

I know the batteries I use aren't problematic as they work fine on the other console.

What might be the problem and how to easily fix it?
 

Attachments

  • IMG_20201112_104810.jpg
    IMG_20201112_104810.jpg
    1.2 MB · Views: 152

Corrupted-innocence

Member
Newcomer
Joined
May 2, 2021
Messages
8
Trophies
0
Age
23
XP
40
Country
United Kingdom
It may be a problem with the PSP battery contacts not sensing the battery, this can be caused by water damage or just general wear and tear of older consoles. A fix could be to first try wiping the internal contacts on the inside of the PSP with a clean cotton swab with nothing on it and if that doesn't work, it may be an internal problem, so idk what do in that situation, sorry.
 
Last edited by Corrupted-innocence,

Jayumi

Well-Known Member
Newcomer
Joined
Jun 14, 2020
Messages
89
Trophies
0
Age
20
XP
162
Country
United States
Hi folks.
Here's the problem: I got two PSP's, both model 3000. One of them charges and plays fine. The other one, however, will only play when powered by the power cable. Under "settings>battery information", it doesn't even display any battery (see the picture), nor is any battery icon present on the home screen.

I know the batteries I use aren't problematic as they work fine on the other console.

What might be the problem and how to easily fix it?
Is one PSP older than the other, because it may just come down to general wear and tear on the console.
Also do you have a device that measure electrical currents (I can't remember what they are called) if you test the battery contacts with it, it could be possible that the contacts may need replacing.
 
General chit-chat
Help Users
    Veho @ Veho: Psi is this you? https://i.imgur.com/Y7CG9A1.jpg