Hacking PSP-2010 won't charge, won't turn on without a battery, but charges through USB.


New Member
Jan 12, 2021
Hello everyone,

I need some input into a unique problem I ran into with my PSP. It's a bit of a headscratcher for me so I was hoping someone could help me out.

This is a bit of a long story.

About a year back I dug out my old PSP-2010 to install CFW on it, only the battery was swollen, so I borrowed a PSP-1000 and tried using that battery. This worked fine, so I got a new AC adapter, but my old PSP wouldn't charge it. It showed the green light during use but no orange light, and it would not turn on with just the AC like they normally can. This meant I had to use the 1000 to charge the battery which would then go into the 2000 for play.

Needless to say, this was a terrible system. But then I discovered I could charge with the USB, so that problem was solved. Recently I gave back the borrowed 1000 along with it's battery, and got myself a cheap chinese knock-off in order to do a battery mod. First problem was that the casing for the chinese battery didn't properly fit, so I had to hold it at a weird angle for it to turn on my PSP, which it did, but still no charging or playing without a battery.

This all led me to believe that my power jack was the issue, so I got a replacement and got to installing it and removing the UMD drive to fit the battery mod. I tried testing the new jack by plugging it in and trying to turn on the console without the battery, which should work, but no joy.

Being absolutely stumped, I ripped a little light bulb from a Christmas light strip and got to testing, and as it turns out, both my old and new power jacks work perfecly and pass current. I tried plugging everything in and testing the actual battery pins to see if the current made its way all the way over there, and sure enough it didn't. Additionally, during all this, I accidentally broke the battery circuit of the chinese knockoff, since the battery has charge but it the current doesn't make it all the way up to the pins. I also checked the little metal ends where the power jack cable connects to the motherboard and got current there as well.

So the situation is this:

  • I have no way of turning on the system to see if I broke something accidentaly, which I am pretty sure I didn't since I have experience repairing phones and such. I already asked for another battery online in order to sanity check but still.

  • Both the original and the new AC power jacks work perfectly fine, and so does my AC adapter.

  • The system is capable of charging via USB, so at least some part of the circuit works just fine.

  • The power switch works fine, but the console won't work without a battery installed, and cannot charge through the AC port.
I thought I went through every possible issue here, even changing out the jack, but I seriously have no idea what is wrong with this. The only things I can think off is that the motherboard is shot in an incredibly specific way, or that maybe some power fuse is dead. A ways back I used a weird cable with interchangeable bits to charge the PSP, which had different voltages. I was little when I did this, but I made sure to use the right voltage. Could it be possible that maybe changing the voltage at some point could have blown a fuse or something inside the PSP?

I am perplexed by this. Any help is appreciated.


Active Member
Jan 29, 2022
Replace the capacitor that leaks on the board, it can be with a 1.5v or 3.3v battery, ideally 3.3v, for me it worked with 1.5v.


Site & Scene News

Popular threads in this forum

General chit-chat
Help Users
    radicaleinward @ radicaleinward: I'm thinking of making a thread of a very hard-to-find movie short, that I'm uploading to the...