Tutorial [PSA][Tutorial] HWFLY chips will brick your OLED. Here is how to avoid it

  • Thread starter Mena
  • Start date
  • Views 55,938
  • Replies 341
  • Likes 17

Stryd

Well-Known Member
Newcomer
Joined
Dec 23, 2021
Messages
66
Trophies
0
XP
115
Country
Italy
Thank you very much! Yeah the only reason I mentioned the plugged in part is because I was uncertain if the system shutdown after the removal and maybe leaving it plugged it would trigger the system to start back up automatically.
No problem, glad it helped! :yay:
 

boston909

Member
Newcomer
Joined
Jan 10, 2022
Messages
11
Trophies
0
Age
33
XP
27
Country
United Kingdom
Does anybody know if the payload checker will be updated to work with sthetix's updated hwfly firmware
That would be great to know - my OLED chip is being installed soon by my local modder, so I'm in two minds to either stick with stock 0.2.0 for now and be mindful of which SD card to use, or go with either sthetix's r021 or Mena's firmwares... I'll be keeping an eye on this thread.
 

Lumince

Well-Known Member
Member
Joined
Aug 15, 2015
Messages
2,216
Trophies
1
XP
2,885
Country
United States
That would be great to know - my OLED chip is being installed soon by my local modder, so I'm in two minds to either stick with stock 0.2.0 for now and be mindful of which SD card to use, or go with either sthetix's r021 or Mena's firmwares... I'll be keeping an eye on this thread.
I have an OLED switch with a TX lite running menas FW and it works GREAT. No issues so far and it glitches quite fast. No complaints
 

Bonovox40

Well-Known Member
Member
Joined
Apr 2, 2003
Messages
539
Trophies
0
XP
1,030
Country
United States
The whole SD card dying thing is what has me worried since I paid an installer to install the hwfly lite modchips I bought with spacecraft v1.0 on 2 different OLEDs. I know the risks of turning it on without an SD card or payload.bin not being present, it's the SD card randomly failing that has me worried.

If someone wanted to test the following scenario, would be greatly appreciated.

A hacked switch (doesn't necessarily have to be with a modchip, just hacked in general) running atmosphere in emunand, plugged in official nintendo usb charger. Then remove the sd card without waking up the switch. I assume removing the sd card would be similar to it actually failing (at least I hope).

Does the switch automatically power off and back on due to it being plugged into a power source? Does it stay running with an error message until the user pressing a button?

The point of this test is to see if by the small chance of the sd card failing while sleeping docked or while using it will give the user a chance to swap the SD card before the modchip has to glitch again. The worst case scenario would be if the sd card fails, the switch automatically restarts and then 5v gets sent from the modchip failing to find the sd card.

This is my fear because my guy is only doing the SX lite install, but will NOT messing w the SD card. (will not prep or load any kind of payload/cfw stuff on it, for legal reasons)

So I basically asked that he only make sure after the chip is connected correctly and goes green, to not turn it on anymore to lessen the 5v risk/damage, and I will prep everything at home and try to flash spacecraft V2 to it as well. :-/ What else can I do?
 

Bonovox40

Well-Known Member
Member
Joined
Apr 2, 2003
Messages
539
Trophies
0
XP
1,030
Country
United States
I have an OLED switch with a TX lite running menas FW and it works GREAT. No issues so far and it glitches quite fast. No complaints

Was going to flash spacecraft V2 on the SX lite, but can you or someone explain the difference between spacecraft V2/r021/Mena's version?
Is one better than the other or depends on chip used?
 

lufeig

Well-Known Member
Member
Joined
Oct 22, 2009
Messages
282
Trophies
0
Age
43
Location
São Paulo, Brazil
XP
767
Country
Brazil
Was going to flash spacecraft V2 on the SX lite, but can you or someone explain the difference between spacecraft V2/r021/Mena's version?
Is one better than the other or depends on chip used?
For original SX Lite or Core use vanilla Spacecraft

R021 and Mena’s are intended to be used on clone modchips
 
  • Like
Reactions: Bonovox40

boston909

Member
Newcomer
Joined
Jan 10, 2022
Messages
11
Trophies
0
Age
33
XP
27
Country
United Kingdom
Can anyone offer their thoughts on my predicament?:

Having received my OLED switch back today with the OLED-specific chip in there - which has been left on stock Spacecraft 0.2.0 - I find it can pulse purple a few times when powering on then go green, but the screen remains black as if Hekate hasn't loaded (or I'm briefly getting the Hekate logo screen then just black screen after that). I'm having to hold down the power button for ~15 seconds to ensure it turns off again, before turning on to try again.

Other times it can take up to 40 pulses for the chip's LED to go green and Hekate will then load correctly, although it still seems to go to a black screen almost every other time I try powering back on again.

I get the same issue with both a Samsung Evo Plus 512GB card and a SanDisk Extreme 1TB card.

I'm hoping that sthetix's better optimised r021 firmware might resolve this issue if I send it back to my modder guy to sort this out for me. What do you all think would be the best course of action?
 

juanvlc

Member
Newcomer
Joined
Jan 7, 2022
Messages
12
Trophies
0
Age
43
XP
133
Country
Spain
I'm using r021 on same chip (6wired one) and works amazing, booting in 2 seconds and no microsd issues at all.
1st Training time 2min 30secs
Hope it helps you
 

boston909

Member
Newcomer
Joined
Jan 10, 2022
Messages
11
Trophies
0
Age
33
XP
27
Country
United Kingdom
I'm using r021 on same chip (6wired one) and works amazing, booting in 2 seconds and no microsd issues at all.
1st Training time 2min 30secs
Hope it helps you
Thanks juanvlc - mine is indeed the 6-wired chip, so I'll send it back to my local modder to have that done. :)
 

lufeig

Well-Known Member
Member
Joined
Oct 22, 2009
Messages
282
Trophies
0
Age
43
Location
São Paulo, Brazil
XP
767
Country
Brazil
The USB adapter is part of the modchip kit, your mod guy should have sent it with your modded console, after all you paid for all that stuff. Just my 0.02
 

passle

New Member
Newbie
Joined
Jan 7, 2022
Messages
1
Trophies
0
Age
33
XP
32
Country
Germany
what are the failure codes of the led ?
the v3 chip flashes in purple and then blue?
The sreen shows only purple...
what can be the problem ?
 

Toadsty!

Member
Newcomer
Joined
May 3, 2016
Messages
6
Trophies
0
Age
24
XP
75
Country
003F0010 29 46 96 BA 25 64 8E A8 C1 0B E4 C1 1F 11 07 56
003F0020 79 52 79 D9 99 0C 7F 71 C5 9F 1F 9F 82 5B 52 C4
003F0030 E5 A3 13 54 57 A3 B0 26 75 55 B7 9F 92 54 EC 9A
003F0040 14 9D B0 C0 12 5E 8A B1 85 9F 65 62 C5 B3 38 30
003F0050 71 8A 17 AD 6C 07 7C 72 78 7D 05 A5 A1 35 27 6E
003F0060 E2 D5 23 FA DE 74 E3 13 80 0E AA 23 9C DC 27 0D
003F0070 66 66 76 8B AA 96 58 43 4C 7C 5B 71 DE 28 6D A8
003F0080 85 6E DB DB 9C 1B 2C 80 C8 8B D7 38 37 C8 71 D0
003F0090 C1 3E 0C F0 B6 51 D9 14 F4 6E C0 17 85 49 2B 74

The app says: Unknown Payload/ SX Payload?



so its not an v0.2? My chip is an oled hwfly, the person who did the mod said its the latest and its upgradeable...
 
General chit-chat
Help Users
  • No one is chatting at the moment.
    KenniesNewName @ KenniesNewName: Need a psu and Wii mote those still run $20