Ps4/Ps5 webkit exploit reports and tests.

Newhouse-Estates

Well-Known Member
OP
Newcomer
Joined
Dec 15, 2020
Messages
78
Trophies
0
Age
32
XP
530
Country
Canada
Looks like a good start for future homebrew for the PS5, Were still a long way before kernel excess but with only a year or so in to the console's life it's not looking too bad.
Just wanted to post my personal results and would like to get others results with firmware version.
On 4.02 but only get 3 out of 9 pop up's. Can any one else confirm?
All credits go to @sleirsgoevy


Source: https://www.psxhax.com/threads/ps4-...by-sleirsgoevy-kernel-exploit-required.10317/
 

Attachments

  • Inked20211104093433_LI.jpg
    Inked20211104093433_LI.jpg
    765.5 KB · Views: 51
  • 20211104092114.jpg
    20211104092114.jpg
    191.3 KB · Views: 48
  • 20211104092112.jpg
    20211104092112.jpg
    186.6 KB · Views: 57
  • 20211104092110.jpg
    20211104092110.jpg
    186.2 KB · Views: 46

stranno

Well-Known Member
Member
Joined
Feb 17, 2013
Messages
802
Trophies
1
XP
2,333
Country
Spain
I would stay on the lowest firmware possible until something official is released. Do not update past 4.03.
4.50 is supposedly compatible with the exFAT OOB exploit, according to PS5 dev wiki. One Twitter user also reported that the latest WebKit exploit also works on 4.50. So, in the end, who knows.
 

Newhouse-Estates

Well-Known Member
OP
Newcomer
Joined
Dec 15, 2020
Messages
78
Trophies
0
Age
32
XP
530
Country
Canada
4.50 is supposedly compatible with the exFAT OOB exploit, according to PS5 dev wiki. One Twitter user also reported that the latest WebKit exploit also works on 4.50. So, in the end, who knows.
The exfat bug was patched past 4.03 but yes was just about to post my results on the newest exploit working on 4.50.
 

johnnyblackout

Active Member
Newcomer
Joined
May 24, 2010
Messages
25
Trophies
0
XP
319
Country
United States
Good luck with your testng. I just wanted to make it clear to anyone seeing this thread and who might misinterpret it. Hate to see someone miss out. Smartest move is to stay on lowest firmware possible until something concrete is released.
 

Attachments

  • Screenshot_20220128-073007_Firefox.jpg
    Screenshot_20220128-073007_Firefox.jpg
    519.4 KB · Views: 23
  • Like
Reactions: Newhouse-Estates

Newhouse-Estates

Well-Known Member
OP
Newcomer
Joined
Dec 15, 2020
Messages
78
Trophies
0
Age
32
XP
530
Country
Canada
Good luck with your testng. I just wanted to make it clear to anyone seeing this thread and who might misinterpret it. Hate to see someone miss out. Smartest move is to stay on lowest firmware possible until something concrete is released.
Hey thanks! Your way ahead of me today lol.
 

seany1990

Well-Known Member
Member
Joined
Aug 3, 2015
Messages
309
Trophies
0
XP
1,466
Country
United Kingdom
4.50 is supposedly compatible with the exFAT OOB exploit, according to PS5 dev wiki. One Twitter user also reported that the latest WebKit exploit also works on 4.50. So, in the end, who knows.
cturts findings have been patched on firmwares later than 4.03. Kernel will only be possible on 4.03 and maybe before
 
General chit-chat
Help Users
    Psionic Roshambo @ Psionic Roshambo: Hmm not a lot to be honest lol too busy working +1