PS4 Fightstick through USB on switch? Also Best current arcade emulator for switch?

DrippyB

Member
OP
Newcomer
Joined
May 23, 2022
Messages
16
Trophies
0
Age
22
Location
Florida
XP
36
Country
United States
Anybody know if theres a way to use a PS4 fightstick on the switch? Ive looked into syscon and mission control, but syscon doesnt support 3rd party controllers and missioncontrol appears to be bluetooth only.

Also a semi related side question:

Anyone know whats the the current best way to play arcade romsets on switch? I know of pFBA and Mame but a lot of the threads are rather old on this subject and I just want to know the current consensus on whats the best emulator for arcade roms or if theres been a new one made besides the two mentioned.
 

hippy dave

BBMB
Member
Joined
Apr 30, 2012
Messages
8,196
Trophies
1
XP
13,202
Country
United Kingdom
If those two don't support it, the only other option is a hardware adapter. I know there's a few available but I haven't used them, they've been discussed elsewhere on here tho.
 

Elodain

Well-Known Member
Member
Joined
Feb 3, 2022
Messages
210
Trophies
0
Age
28
Location
Mi
XP
315
Country
United States
Yeah you're going to want a USB controller adapter, like Dave said.

Probably cant go wrong with 8bitdo, since their like the kings of controllers recently, but I've heard good things about MAYFLASH as well.
 

Purple_Shyguy

Well-Known Member
Member
Joined
Nov 8, 2008
Messages
1,876
Trophies
1
Age
32
Location
Republic of Ireland
XP
3,161
Country
I remember I plugged my old fightstick into my switch like back in 2018 to see if it actually worked.

Get yourself a Mayflash Bluetooth adapter dongle or one of the similar highly rated products. They're like $15-20 and I can't recommend them enough.

IMG_20180707_172940.jpg
 

DrippyB

Member
OP
Newcomer
Joined
May 23, 2022
Messages
16
Trophies
0
Age
22
Location
Florida
XP
36
Country
United States

DrippyB

Member
OP
Newcomer
Joined
May 23, 2022
Messages
16
Trophies
0
Age
22
Location
Florida
XP
36
Country
United States
I remember I plugged my old fightstick into my switch like back in 2018 to see if it actually worked.

Get yourself a Mayflash Bluetooth adapter dongle or one of the similar highly rated products. They're like $15-20 and I can't recommend them enough.

View attachment 311928
Thanks for all the replies yall I was going to get an adapter but it seems i found a solution.
 

DrippyB

Member
OP
Newcomer
Joined
May 23, 2022
Messages
16
Trophies
0
Age
22
Location
Florida
XP
36
Country
United States
I made a fork of sys-con for a user who contacted me to improve support for USB PS4/PS3 controllers and fightsticks. I think he has since modified it to recognise even more controllers. You can find his version here https://github.com/pseiler/sys-con/tree/sony-controllers. Note that it will need to be compiled from source.
Hey man Ive finally had time to sit down and look into this more but Im pretty special when it comes to this kind of stuff. Ive never compiled code before, so i know this is noob stuff here, but how would i go about compiling this? Really would love to try it out.
 

ndeadly

Well-Known Member
Member
Joined
Nov 5, 2018
Messages
371
Trophies
0
Age
35
XP
1,724
Country
Australia
Hey man Ive finally had time to sit down and look into this more but Im pretty special when it comes to this kind of stuff. Ive never compiled code before, so i know this is noob stuff here, but how would i go about compiling this? Really would love to try it out.
Follow the project build instructions.

Basically, something like this
  • Set up the devkitpro build environment
  • Open a devkitpro terminal and clone the project with
    Code:
    git clone --recurse-submodules https://github.com/pseiler/sys-con.git
    (can't remember if git is installed by default. If not, ths should install it)
    Code:
    pacman -S git
  • Enter the cloned project directory and checkout the modified branch with
    Code:
    git checkout sony-controllers
  • Run make to build the project
 

DrippyB

Member
OP
Newcomer
Joined
May 23, 2022
Messages
16
Trophies
0
Age
22
Location
Florida
XP
36
Country
United States
Follow the project build instructions.

Basically, something like this
  • Set up the devkitpro build environment
  • Open a devkitpro terminal and clone the project with
    Code:
    git clone --recurse-submodules https://github.com/pseiler/sys-con.git
    (can't remember if git is installed by default. If not, ths should install it)
    Code:
    pacman -S git
  • Enter the cloned project directory and checkout the modified branch with
    Code:
    git checkout sony-controllers
  • Run make to build the project
Follow the project build instructions.

Basically, something like this
  • Set up the devkitpro build environment
  • Open a devkitpro terminal and clone the project with
    Code:
    git clone --recurse-submodules https://github.com/pseiler/sys-con.git
    (can't remember if git is installed by default. If not, ths should install it)
    Code:
    pacman -S git
  • Enter the cloned project directory and checkout the modified branch with
    Code:
    git checkout sony-controllers
  • Run make to build the project
Hell yea man thank you so much for the guide. Ive never compiled code before let alone coded anything before, but your steps seem easy to follow and Im looking forward to trying it later on today. Ill be sure to let you know how it goes.
 

DrippyB

Member
OP
Newcomer
Joined
May 23, 2022
Messages
16
Trophies
0
Age
22
Location
Florida
XP
36
Country
United States
Follow the project build instructions.

Basically, something like this
  • Set up the devkitpro build environment
  • Open a devkitpro terminal and clone the project with
    Code:
    git clone --recurse-submodules https://github.com/pseiler/sys-con.git
    (can't remember if git is installed by default. If not, ths should install it)
    Code:
    pacman -S git
  • Enter the cloned project directory and checkout the modified branch with
    Code:
    git checkout sony-controllers
  • Run make to build the project
Hey so I downloaded devkit pro and am trying to figure this out. I opened MSYS2 and tried the code but I just get an error when trying to install git
Code:
# pacman -S git
resolving dependencies...
looking for conflicting packages...

Packages (33) heimdal-7.7.0-3  libcbor-0.9.0-1  libfido2-1.10.0-1
              openssh-8.9p1-3  perl-Authen-SASL-2.16-2  perl-Clone-0.45-2
              perl-Convert-BinHex-1.125-1  perl-Encode-Locale-1.05-1
              perl-Error-0.17029-1  perl-File-Listing-6.14-1
              perl-HTML-Parser-3.76-1  perl-HTML-Tagset-3.20-2
              perl-HTTP-Cookies-6.10-1  perl-HTTP-Daemon-6.12-1
              perl-HTTP-Date-6.05-1  perl-HTTP-Message-6.36-1
              perl-HTTP-Negotiate-6.01-2  perl-IO-HTML-1.004-1
              perl-IO-Socket-SSL-2.074-1  perl-IO-Stringy-2.113-1
              perl-LWP-MediaTypes-6.04-1  perl-MIME-tools-5.509-1
              perl-MailTools-2.21-1  perl-Net-HTTP-6.22-1
              perl-Net-SMTP-SSL-1.04-1  perl-Net-SSLeay-1.90-1
              perl-TermReadKey-2.38-2  perl-TimeDate-2.33-1
              perl-Try-Tiny-0.31-1  perl-URI-5.10-1  perl-WWW-RobotRules-6.02-2
              perl-libwww-6.57-1  git-2.36.1-1

Total Installed Size:  42.80 MiB

:: Proceed with installation? [Y/n] y
(33/33) checking keys in keyring                   [#####################] 100%
(33/33) checking package integrity                 [#####################] 100%
error: perl-File-Listing: signature from "David Macek <[email protected]>" is unknown trust
 
Last edited by DrippyB,

ndeadly

Well-Known Member
Member
Joined
Nov 5, 2018
Messages
371
Trophies
0
Age
35
XP
1,724
Country
Australia
Hey so I downloaded devkit pro and am trying to figure this out. I opened MSYS2 and tried the code but I just get an error when trying to install git
Haven't seen an error like that before. It might be trying to install old versions of the files that are no longer supported. Try updating everything with the following command and try again.

Code:
pacman -Syy && pacman -Syu
 

DrippyB

Member
OP
Newcomer
Joined
May 23, 2022
Messages
16
Trophies
0
Age
22
Location
Florida
XP
36
Country
United States
Haven't seen an error like that before. It might be trying to install old versions of the files that are no longer supported. Try updating everything with the following command and try again.

Code:
pacman -Syy && pacman -Syu
That seemed to have done it. I installed git and used the command for cloning the project and it was successful, but now Im a little lost when it comes to the next step. Where/how exactly do i go in the cloned project directory to checkout the modified branch?
EDIT: Okay I figured that part out but when I enter git checkout sony-controllers I just get told that 'sony-controllers' did not match any files known to git.
Code:
[email protected] MSYS ~
# cd /home/User/sys-con/source/libstratosphere

[email protected] MSYS ~/sys-con/source/libstratosphere
# git checkout sony-controllers
error: pathspec 'sony-controllers' did not match any file(s) known to git

[email protected] MSYS ~/sys-con/source/libstratosphere
# git checkout sony-controllers
error: pathspec 'sony-controllers' did not match any file(s) known to git



EDIT2***
Okay so I found out I was going to the wrong directory and found out its just home/User/sys-con/ and not home/User/sys-con/source/libstratosphere but now im getting a whole new error
Code:
ig/common.mk:146: /home/Kendall/sys-con/source/libstratosphere/libmesosphere/include/mesosphere.hpp.gch/nintendo_nx_arm64_release] Error 1
make[3]: *** [Makefile:95: lib_nintendo_nx_arm64/libmesosphere.a] Error 2
make[3]: Leaving directory '/home/Kendall/sys-con/source/libstratosphere/libmesosphere'
make[2]: *** [Makefile:8: libmesosphere] Error 2
make[2]: Leaving directory '/home/Kendall/sys-con/source/libstratosphere'
make[1]: *** [Makefile:9: libstratosphere] Error 2
make[1]: Leaving directory '/home/Kendall/sys-con/source'
make: *** [Makefile:24: build] Error 2


Am I doing something wrong?
 
Last edited by DrippyB,

ndeadly

Well-Known Member
Member
Joined
Nov 5, 2018
Messages
371
Trophies
0
Age
35
XP
1,724
Country
Australia
That seemed to have done it. I installed git and used the command for cloning the project and it was successful, but now Im a little lost when it comes to the next step. Where/how exactly do i go in the cloned project directory to checkout the modified branch?
EDIT: Okay I figured that part out but when I enter git checkout sony-controllers I just get told that 'sony-controllers' did not match any files known to git.
Code:
[email protected] MSYS ~
# cd /home/User/sys-con/source/libstratosphere

[email protected] MSYS ~/sys-con/source/libstratosphere
# git checkout sony-controllers
error: pathspec 'sony-controllers' did not match any file(s) known to git

[email protected] MSYS ~/sys-con/source/libstratosphere
# git checkout sony-controllers
error: pathspec 'sony-controllers' did not match any file(s) known to git



EDIT2***
Okay so I found out I was going to the wrong directory and found out its just home/User/sys-con/ and not home/User/sys-con/source/libstratosphere but now im getting a whole new error
Code:
ig/common.mk:146: /home/Kendall/sys-con/source/libstratosphere/libmesosphere/include/mesosphere.hpp.gch/nintendo_nx_arm64_release] Error 1
make[3]: *** [Makefile:95: lib_nintendo_nx_arm64/libmesosphere.a] Error 2
make[3]: Leaving directory '/home/Kendall/sys-con/source/libstratosphere/libmesosphere'
make[2]: *** [Makefile:8: libmesosphere] Error 2
make[2]: Leaving directory '/home/Kendall/sys-con/source/libstratosphere'
make[1]: *** [Makefile:9: libstratosphere] Error 2
make[1]: Leaving directory '/home/Kendall/sys-con/source'
make: *** [Makefile:24: build] Error 2


Am I doing something wrong?
By the looks of things I think you're attempting to build the most recent libstratosphere from master. Sys-con hasn't been updated to use the latest version and there is a note in the build instructions about switching to a specific older commit.
 

DrippyB

Member
OP
Newcomer
Joined
May 23, 2022
Messages
16
Trophies
0
Age
22
Location
Florida
XP
36
Country
United States
By the looks of things I think you're attempting to build the most recent libstratosphere from master. Sys-con hasn't been updated to use the latest version and there is a note in the build instructions about switching to a specific older commit.
You were right but for some reason when I try to run make install or make after i checkout the commit for libstratosphere i get a similar error still. Im really at my wits end with this error, I cant find anything on it that I understand and Im not too sure what it is im doing wrong, Im trialing and erroring with it a lot too to no avail.
Code:
[email protected] MSYS ~/libnx
#  git checkout b35d42faaa60b02662aaaf0702614f6e4afcbbbc
HEAD is now at b35d42fa hiddbg: fix IsHdlsVirtualDeviceAttached for 13.0.0

[email protected] MSYS ~/libnx
# make install
make -C nx/ install
make[1]: Entering directory '/home/Kendall/libnx/nx'
parcel.c
C:/Users/Kendall/libnx/nx/source/display/parcel.c: In function 'parcelTransact':
C:/Users/Kendall/libnx/nx/source/display/parcel.c:41:28: error: the comparison will always evaluate as 'true' for the address of 'payload' will never be NULL [-Werror=address]
   41 |     if (in_parcel->payload != NULL)
      |                            ^~
In file included from C:/Users/Kendall/libnx/nx/source/display/parcel.c:3:
C:/Users/Kendall/libnx/nx/include/switch/display/parcel.h:15:9: note: 'payload' declared here
   15 |     u8  payload[PARCEL_MAX_PAYLOAD];
      |         ^~~~~~~
cc1.exe: all warnings being treated as errors
make[2]: *** [/home/Kendall/devkitpro/devkitA64/base_rules:19: parcel.o] Error 1
make[1]: *** [Makefile:124: lib/libnx.a] Error 2
make[1]: Leaving directory '/home/Kendall/libnx/nx'
make: *** [Makefile:5: install] Error 2
 
Last edited by DrippyB,
General chit-chat
Help Users
    NeoGaming @ NeoGaming: mmmmmmmmmmmmmmmmmmmooooooooooooooooooooooooonnnnnnnnnnnnnnnnnnnnniiiiiiiiiiiiiiiiiiiiiiiiiiiiiiii...