PS Vita Left Analog Stick - diagonal movements issue in certain games

Bluesilver238

Member
OP
Newcomer
Joined
Apr 9, 2018
Messages
13
Trophies
0
Age
21
XP
246
Country
Gabon
I've been having an issue for quite some time now, where trying to move in diagonal directions (especially up-right and down-right) with the left analog stick in PSP games in Adrenaline just makes the character walk instead of run.

The games I've tested this for were 7th Dragon 2020 (most likely also occurs in 2020 II) and Fate/Extra. I also tested analog movements with the right analog stick by setting it as the left one in the official settings, and the diagonal issue was still happening. This is actually something I was able to reproduce with the Vita version of Ys Origin, but it's mostly occurring in the PSP games I've tried that allow analog movements. On top of that my analog movements worked fine with other PSVita games like Digimon Cyber Sleuth and Ys Memories of Celceta so I don't think the issue is related to the left analog stick itself.

Still, just in case I decided to perform the usual troubleshooting steps; I replaced the left analog stick with a new one, rebuilt the vita database and tried using the AnalogsEnhancer plugin. Nothing seems to work. At this point I'm fairly confident this is not just an hardware issue. I tried to look for a way to somehow increase the left analog stick's "range", but found nothing so far.

Has anyone else experienced a similar problem? If so, were you able to figure out a solution?
 

JoAoMGuedes

Member
Newcomer
Joined
Sep 27, 2019
Messages
20
Trophies
0
XP
107
Country
Brazil
The problem with drift on analog sticks only in some games is a common issue in ps vita. I'm having this problem right now, and using the hardware test homebrew, I undertando the problem now. The analog sticks has coordinates x and y. Every game has a deadzone, where if the value for x and for y is under a defined number the character doesn't move, other cordinates the character walks and another the character run.

So, probably ir your problem is your analog stick has a drift that surpass the value for x or y (or both) deadzone specific to this game, and the drift of your analog doesnt surpass the deadzone values for other games.

Even replacing the analog, the drift remains, cause some replacement analogs come with drift, but we can't even notice since it doesn't surpass the values of deadzone for most games.

Another problem source could be the analog board. I recommend you to use the homebrew app to test the coordinates in standby firts, and you will probably see there's a drift (the analog do not remain on the center as supposed to).

One tip: when buying analogs to replacement ever test it using the software, and you can see if it has drift, and if its the case you should request a return and refund.

App name: Vita Tester
 

Bluesilver238

Member
OP
Newcomer
Joined
Apr 9, 2018
Messages
13
Trophies
0
Age
21
XP
246
Country
Gabon
Thank you for your input. Unfortunately, as I mentioned this specific issue is unlikely to be related to my left joystick itself.
I actually used Vita Tester back when it happened first and didn't see any drifting issue for either of my analog sticks; both were reading "127,127" at rest. I reinstalled it again just now and tested it for the current left analog I have installed and get about "125,127" for it. The right analog is still read as having no drift.

I assume this means the issue couldn't possibly be related to the analog sticks themselves, otherwise assigning the right analog to work as the left one in the PSVita's PSP official settings wouldn't cause the weak diagonal movements in the PSP games I've tested for it. I also doubt the slight drift of 2 on the current left analog I have is significant enough to cause this, especially since it already happened with the old one without drift.

Btw, these weak diagonal readings were most noticeable in Fate/Extra in my case; I encourage anyone who's confident they have good joysticks to test it out.
 

JoAoMGuedes

Member
Newcomer
Joined
Sep 27, 2019
Messages
20
Trophies
0
XP
107
Country
Brazil
Have you tried opening VitaTester right when the problem appears in the games in question, without touching the analog sticks? I think it would be worth a try. Another point perhaps would be to think about disconnecting the battery and pressing the power button for about 30 seconds, to eliminate excess energy that could interfere with the functioning of the analogs.

I will install the game in question and report here if the problem also happens to me.
 

Bluesilver238

Member
OP
Newcomer
Joined
Apr 9, 2018
Messages
13
Trophies
0
Age
21
XP
246
Country
Gabon
That's an interesting development. In my case the character actually runs in some diagonal directions, the issue of them walking instead of running occurs when the left joystick is pretty much at an exact 45 degrees angle up-left, down left, up-right or down-right. It's only really noticeable when rotating slowly.

When you slowly rotate your left joystick pushing to the max in a circle in-game, does the walking occur at any point? If no then that's pretty strange. The issue happens without fail in all PSP games I've mentioned (and Ys Origin), and switching to Vita Tester after closing them just shows my analogs' regular values. I also had the impression these PSP games in Adrenaline use a different driver for analog movement. Are you using a slim or an OLED Vita?

I'll still try to unplug the battery and press the power button, maybe that'll actually do something. In any case, I appreciate your assistance.
 

JoAoMGuedes

Member
Newcomer
Joined
Sep 27, 2019
Messages
20
Trophies
0
XP
107
Country
Brazil
That's an interesting development. In my case the character actually runs in some diagonal directions, the issue of them walking instead of running occurs when the left joystick is pretty much at an exact 45 degrees angle up-left, down left, up-right or down-right. It's only really noticeable when rotating slowly.

When you slowly rotate your left joystick pushing to the max in a circle in-game, does the walking occur at any point? If no then that's pretty strange. The issue happens without fail in all PSP games I've mentioned (and Ys Origin), and switching to Vita Tester after closing them just shows my analogs' regular values. I also had the impression these PSP games in Adrenaline use a different driver for analog movement. Are you using a slim or an OLED Vita?

I'll still try to unplug the battery and press the power button, maybe that'll actually do something. In any case, I appreciate your assistance.
I tried slowly in all directions, and here the char always runs and never walks on the max input (used the USA version of the game). It's really strange in fact. I'm using the slim model. I hope you can find a solution.
 

Bluesilver238

Member
OP
Newcomer
Joined
Apr 9, 2018
Messages
13
Trophies
0
Age
21
XP
246
Country
Gabon
Alright, thanks for confirming. I tried removing the battery and pressing the power button for 30 seconds, but even now the diagonal movements are still as weak as before. Although I'm using an OLED instead of the slim model like you do, so maybe that has something to do with this.

This issue is something I've seen several people experience between Gamefaqs, Reddit and here, but in most cases the discussion drops off without anyone reaching a solution beyond replacing the analog stick, which itself is never reported as solving the problem by the person experiencing the issue. In most cases I've seen it happen for Ys Origin. The only workaround I found that supposedly solves this was setting the left analog stick to a negative value in AnalogEnhancer, but the plugin didn't seem to work for me. I hope I'll be able to figure something out eventually, but in the meantime I'll just try to setup the left analog as digital with reVita or use the D-pad.
 
  • Like
Reactions: JoAoMGuedes

RKT9

Member
Newcomer
Joined
Dec 16, 2021
Messages
6
Trophies
0
Age
36
XP
34
Country
Philippines
Are you using reVita? Mine has the same diagonal issues when that plugin is installed, but just on certain games only (ToCS 1 & 2). Removing the plugin fixes that issue.
 
  • Like
Reactions: Bluesilver238

Bluesilver238

Member
OP
Newcomer
Joined
Apr 9, 2018
Messages
13
Trophies
0
Age
21
XP
246
Country
Gabon
Are you using reVita? Mine has the same diagonal issues when that plugin is installed, but just on certain games only (ToCS 1 & 2). Removing the plugin fixes that issue.
Impressive. I've indeed been using reVita for a while now, and as you said removing the plugin instantly solved the issue! I'm honestly surprised by how simple the solution was.
I checked the issue section for reVita on Github and apparently this problem has already been reported, even though no new release has been made since the report. This plugin is pretty useful so I'll look forward to them eventually fixing it. I'll see if I can go back to remaPSV2 in the meantime.

Regardless, thank you for your continued assistance JoAoMGuedes, and thank you very much for the recommendation RKT9. This could very well be the explanation for anyone else dealing with this.

EDIT: I tried to switch from reVita to remaPSV/2, and apparently the weaker diagonal movements also occur in the 2.0.2 version of remaPSV but not in the 1.1 version. So remaPSV should be more suitable to use than remaPSV2/reVita for now.
 
Last edited by Bluesilver238,
  • Like
Reactions: JoAoMGuedes

Randy Steele

Well-Known Member
Newcomer
Joined
Apr 19, 2014
Messages
71
Trophies
0
Age
29
XP
950
Country
United States
Are you using reVita? Mine has the same diagonal issues when that plugin is installed, but just on certain games only (ToCS 1 & 2). Removing the plugin fixes that issue.
Dude, thank you so much! I came across this thread on complete accident and wasn't expecting a fix. I've been having this same issue in a few specific games that made them basically impossible to enjoy (Ratchet and Clank collection, Simpsons PSP, Oddworld stranger's wraith and maybe some others). My left stick would always walk instead of running when pressing it up and slightly diagonal to the right in those specific games but vita tester showed no issues. I was so close to replacing the sticks. Removing remaPSV2 fixed the issue.
 
General chit-chat
Help Users
  • No one is chatting at the moment.
    Dark_Phoras @ Dark_Phoras: Good evening