PS TV is on 3.20. Upgrade or stay?

Discussion in 'PS Vita - Hacking & Homebrew' started by bache, Nov 18, 2015.

  1. bache
    OP

    bache GBAtemp Advanced Fan

    Member
    694
    292
    Sep 28, 2009
    I received my PS TV today, and the firmware is on 3.20. For someone who'd like to play PSP/PS1 backups, as well as use the whitelist to play unsuppported Vita games, should I stick to this firmware, or is there a better one to update to?
     
  2. oxenh

    oxenh The most unknown member of GBAtemp

    Member
    273
    39
    Sep 1, 2008
    Cote d'Ivoire
    Stay in fw 3.20.
    The only problem you may encounter is that some psvita games still not gonna work after using the whitelist.
     
  3. RazorX2014

    RazorX2014 GBAtemp Fan

    Member
    488
    99
    Mar 18, 2014
    the whitelist doesnt allow games to play on lower firmware it only removes some games that where blacklisted, for example because they use the touch pads on the back of the vita or touchscreen which the pstv doesnt have
     
  4. bache
    OP

    bache GBAtemp Advanced Fan

    Member
    694
    292
    Sep 28, 2009
    So would I be better to manually update to 3.51 to maintain the email exploit and Rejuvenate, while also increasing the compatibility of games that require FW updates?
     
  5. dekuleon

    dekuleon GBAtemp Advanced Fan

    Member
    GBAtemp Patron
    dekuleon is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    511
    158
    Oct 1, 2010
    Brazil
    where the wind makes the curve
    3.20 is like 3.18 for the Ps vita, its the most hackable firmware.

    STAY on 3.20!!! You can use TN-V and TN-X for 100% perfect ps1 emulation!
     
    zfreeman likes this.
  6. bache
    OP

    bache GBAtemp Advanced Fan

    Member
    694
    292
    Sep 28, 2009
    Alrighty then 3.20 it is. I'm trying to set up Rejuvenate using this tutorial, however when it comes to resuming the update, it does change to 5mb, but at the end, it just says "waiting to install".
    Does anybody know what I might be doing wrong? I'm definitely using Unity 1.05.