Problems migrating from SX os to atmosphere 4 minutes to boot

Ing17

Well-Known Member
OP
Newcomer
Joined
Apr 8, 2018
Messages
45
Trophies
0
Age
29
XP
379
Country
Laos
My switch is a Mariko hardware modded Sx core and it was 11.0.0 on emunand and was on the latest SX os fw. Long story short I tried to update the sysnand which was 10. 2 to 11.0.0 as my emunand via chourdojourn but somehow failed and the Switch failed to boot. So I went ahead and proceed with the migration anyways from Sx os To Atmosphere and sort of succeeded and screwed up. After one whole day of fiddling Atmosphere is installed but now it takes at least 4 mins to boot and the battery life is still persisting. Besides formating anything I can do?
 

binkinator

Garfield’s Fitness Coach
Member
GBAtemp Patron
Joined
Mar 29, 2021
Messages
2,622
Trophies
2
XP
1,841
Country
United States
My switch is a Mariko hardware modded Sx core and it was 11.0.0 on emunand and was on the latest SX os fw. Long story short I tried to update the sysnand which was 10. 2 to 11.0.0 as my emunand via chourdojourn but somehow failed and the Switch failed to boot. So I went ahead and proceed with the migration anyways from Sx os To Atmosphere and sort of succeeded and screwed up. After one whole day of fiddling Atmosphere is installed but now it takes at least 4 mins to boot and the battery life is still persisting. Besides formating anything I can do?

Slow boot isn’t typically a software issue but let’s explore that for a bit anyway. Which guide did you follow?

(I would suspect a hardware issue with your SD card being corrupt or your SD card reader being in 1 bit mode.)
 

Ing17

Well-Known Member
OP
Newcomer
Joined
Apr 8, 2018
Messages
45
Trophies
0
Age
29
XP
379
Country
Laos
Slow boot isn’t typically a software issue but let’s explore that for a bit anyway. Which guide did you follow?

(I would suspect a hardware issue with your SD card being corrupt or your SD card reader being in 1 bit mode.)
Thing is after the update via chour, the Switch was unbootable with only black screen no matter how long I press the power button then I gave it to my friend who followed the Chinese guide of installing atmosphere. Prior to that I followed this guide https://rentry.org/mys8q. The SD card being screwed is what I suspected as well so I decided to order a new micro SD card which will arrive Monday. So in this case all I have to do is simply copy and paste?
 

binkinator

Garfield’s Fitness Coach
Member
GBAtemp Patron
Joined
Mar 29, 2021
Messages
2,622
Trophies
2
XP
1,841
Country
United States
Thing is after the update via chour, the Switch was unbootable with only black screen no matter how long I press the power button then I gave it to my friend who followed the Chinese guide of installing atmosphere. Prior to that I followed this guide https://rentry.org/mys8q. The SD card being screwed is what I suspected as well so I decided to order a new micro SD card which will arrive Monday. So in this case all I have to do is simply copy and paste?

That’s a decent guide. I used too.

You will want to try to do a bit-for-bit copy of the sd card if you were using an emunand on a hidden partition. Everything else can just use windows copy but the bit copy will have already taken care of that. Let’s hope it’s not corrupted though as it will copy corruption as well Which would be bad.
 

Ing17

Well-Known Member
OP
Newcomer
Joined
Apr 8, 2018
Messages
45
Trophies
0
Age
29
XP
379
Country
Laos
That’s a decent guide. I used too.

You will want to try to do a bit-for-bit copy of the sd card if you were using an emunand on a hidden partition. Everything else can just use windows copy but the bit copy will have already taken care of that. Let’s hope it’s not corrupted though as it will copy corruption as well Which would be bad.
If the boot time is still slow, there’s nothing I can do about it? Would a fresh install of atmosphere not fix it?
 

binkinator

Garfield’s Fitness Coach
Member
GBAtemp Patron
Joined
Mar 29, 2021
Messages
2,622
Trophies
2
XP
1,841
Country
United States
If the boot time is still slow, there’s nothing I can do about it? Would a fresh install of atmosphere not fix it?

You’re welcome to try anything you’d like. It’s just that Atmosphere is merely a CFW…it injects itself into the main FW as it boots…it doesn’t replace it. What I’m getting at is the slow boot speeds are not likely due to shimming the OS with CFW. But again…you’re more than welcome to retrace your steps, upgrade, what have you. You really can’t hurt anything.
 

Purple_Shyguy

Well-Known Member
Member
Joined
Nov 8, 2008
Messages
1,877
Trophies
1
Age
32
Location
Republic of Ireland
XP
3,171
Country
Boot up Hekate cfw and it will tell you instantly if your SD card is in 1-bit mode.

1 bit mode has severely limited read speeds on the SD card which might be why it takes 4 minutes to boot.

I had this issue. I had to repair the SD card connector and replace the SD card reader.
 
  • Like
Reactions: binkinator

Ing17

Well-Known Member
OP
Newcomer
Joined
Apr 8, 2018
Messages
45
Trophies
0
Age
29
XP
379
Country
Laos
Boot up Hekate cfw and it will tell you instantly if your SD card is in 1-bit mode.

1 bit mode has severely limited read speeds on the SD card which might be why it takes 4 minutes to boot.

I had this issue. I had to repair the SD card connector and replace the SD card reader.
This requires soldering right? And buying replacements as well. I don’t know if this info is any useful but on the Sxos never had problems with loadtime
 

Ing17

Well-Known Member
OP
Newcomer
Joined
Apr 8, 2018
Messages
45
Trophies
0
Age
29
XP
379
Country
Laos
Boot up Hekate cfw and it will tell you instantly if your SD card is in 1-bit mode.

1 bit mode has severely limited read speeds on the SD card which might be why it takes 4 minutes to boot.

I had this issue. I had to repair the SD card connector and replace the SD card reader.
Luckily theres no notification or indication that my Sd card is running at 1 bit mode. However the issue of slow booting still persist might so I dont really know what to do here
 

The Real Jdbye

*is birb*
Member
Joined
Mar 17, 2010
Messages
21,996
Trophies
3
Location
Space
XP
11,215
Country
Norway
Boot up Hekate cfw and it will tell you instantly if your SD card is in 1-bit mode.

1 bit mode has severely limited read speeds on the SD card which might be why it takes 4 minutes to boot.

I had this issue. I had to repair the SD card connector and replace the SD card reader.
HOS itself doesn't support 1-bit mode. So CFW would not boot if the SD card was stuck in 1-bit mode.
 

Ing17

Well-Known Member
OP
Newcomer
Joined
Apr 8, 2018
Messages
45
Trophies
0
Age
29
XP
379
Country
Laos
You’re welcome to try anything you’d like. It’s just that Atmosphere is merely a CFW…it injects itself into the main FW as it boots…it doesn’t replace it. What I’m getting at is the slow boot speeds are not likely due to shimming the OS with CFW. But again…you’re more than welcome to retrace your steps, upgrade, what have you. You really can’t hurt anything.
Upgraded my SD card to 512GB sandisk. Formatted it to fat32 prior the copy paste. Everything works fine except the load time issue still persist sadly
 

binkinator

Garfield’s Fitness Coach
Member
GBAtemp Patron
Joined
Mar 29, 2021
Messages
2,622
Trophies
2
XP
1,841
Country
United States
Upgraded my SD card to 512GB sandisk. Formatted it to fat32 prior the copy paste. Everything works fine except the load time issue still persist sadly

Since you have a new card to work with now, I would take everything off and build it up from nothing…start with just Hekate, Atmosphere and Sigpatches and see if the issue goes away.

Heres a straightforward guide to step through to make sure nothing is missed: https://rentry.org/SwitchHackingIsEasy

Once you get past that start adding things back (any mods, homebrew and finally games.) Whatever it is should pop up in that process.
 
General chit-chat
Help Users
    KenniesNewName @ KenniesNewName: Apparently someone was knocking on windows and trying to open them last night