1. cwstjdenobs

    OP cwstjdenobs Sodomy non sapiens
    Member

    Joined:
    Mar 10, 2009
    Messages:
    1,756
    Country:
    Ok, I'm starting playing with SDL on the wii, and everything is fine until I grab the source from svn. SDL itself compiles fine but whenever I try to run make in the other library folders I get this

    Code:
    Compiling src/SDL_framerate.c
    /bin/sh: powerpc-gekko-gcc: command not found
    Compiling src/SDL_gfxBlitFunc.c
    /bin/sh: powerpc-gekko-gcc: command not found
    Compiling src/SDL_gfxPrimitives.c
    /bin/sh: powerpc-gekko-gcc: command not found
    Compiling src/SDL_imageFilter.c
    /bin/sh: powerpc-gekko-gcc: command not found
    Compiling src/SDL_rotozoom.c
    /bin/sh: powerpc-gekko-gcc: command not found
    Archiving lib/libSDL_gfx.a
    make: powerpc-gekko-ar: Command not found
    make: *** [lib/libSDL_gfx.a] Error 127
    I'm using devkit on Vista at the moment, I haven't tried on a *NIX yet, and I'm guessing there's no problem on Linux or the BSD's and that's what the devs are using

    I think it's a problem with the makefiles, but I'm not sure (I'm not really up to speed on make syntax) and I'd like to make sure I'm not being stupid before I add an issue on the google code page
     
  2. Jacobeian

    Jacobeian GBAtemp Advanced Maniac
    Member

    Joined:
    May 15, 2008
    Messages:
    1,891
    Country:
    Cuba
    I'm on Vista and devkitpro works perfectly fine
    check your installation (most important things are the DEVKITPPC and DEVKITPRO environment variables, they should be correctly set and point to your installed directories.

    powerpc-gekko-gcc (compiler) and powerpc-gekko-ar (linker) should be automatically installed in c:/devkitpro/devkitppc/bin

    If you are using msys to compile, you need to add the following lines in /msys/etc/profile:

    Code:
    export PATH=$PATH:/ppc/bin
    export DEVKITPPC=/ppc
    It might also be a buggy Makefile that only works under specific environment


    In all case, this is not an issue with SDL but with your compilation environment
     
  3. cwstjdenobs

    OP cwstjdenobs Sodomy non sapiens
    Member

    Joined:
    Mar 10, 2009
    Messages:
    1,756
    Country:

    I tried that and no luck, from both MSYS and the "Command Prompt". And two different PCs.

    Well that's strange. It must be the make files because everything else compiles fine on my systems and so does SDL itself, just not SDL_gfx, sdl_image etc.
     
  4. Jacobeian

    Jacobeian GBAtemp Advanced Maniac
    Member

    Joined:
    May 15, 2008
    Messages:
    1,891
    Country:
    Cuba
    post the Makefile, maybe someone could help
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - compiling, Problem, SDL_gfx