preloader and scrambled HBC

Discussion in 'Wii - Hacking' started by krezy, Sep 17, 2011.

Sep 17, 2011

preloader and scrambled HBC by krezy at 3:03 PM (2,335 Views / 0 Likes) 41 replies

  1. krezy
    OP

    Newcomer krezy Member

    Joined:
    Nov 25, 2009
    Messages:
    17
    Country:
    United States
    I tried softmodding a Wii, everything went fine (HBC, bootmii as ios, did make a NAND backup, patched ios36) then I installed preloader 0.29. The message from the Wii when booting is the black screen "The system files are corrupted..."

    I can get into preloader, but when I load HBC I get a scrambled screen.

    The Wii is on 4.2. Preloader says: IOS v70, Systemmenu v482. Don't know if that's helpful. How can I solve this?
     


  2. obcd

    Member obcd GBAtemp Advanced Maniac

    Joined:
    Apr 5, 2011
    Messages:
    1,594
    Country:
    Belgium
    if your preloader installer is having an option to uninstall preloader, you might use that.
    You can try to run the installer from within preloader.

    I have no idea what softmod tutorial you are following, but installing preloader was a bad move.
    Nowadays, people use priiloader instead of preloader (which is based upon preloader and has the same purpose).

    Most people will advice to use modmii as your guidance for your softmod.
     
  3. The_Dragons_Mast

    Member The_Dragons_Mast GBAtemp Advanced Fan

    Joined:
    Apr 20, 2007
    Messages:
    613
    Country:
    Egypt
    What??? Sure preloader needs to be replaced with priiloader but you are suggesting for him to delete the last thing that is standing between him having a fully bricked wii.

    @OP try booting MMM using preloader . If you succeed then use ModMii to reinstall 4.2 & re hack your wii.
     
  4. krezy
    OP

    Newcomer krezy Member

    Joined:
    Nov 25, 2009
    Messages:
    17
    Country:
    United States
    I used http://gbatemp.net/index.php?showtopic=168890 and softmodded many wii's with this, however most of them were on 4.1 or lower. Only difference with this guide is for 4.2 a modified TBR and bannerbomb (and anytitledelete to delete a few IOS but I couldn't complete these steps as I can't load HBC anymore)

    Anyway, I do remember me having issues in the past with system 4.2 / IOS70 / preloader but I don't remember the exact guide I followed to fix this. But at that time I could load the HBC.


    There is no uninstall preloader (0.29) in the menu's. I've read that you can reinstall the system menu, but you need a wad manager, so still need HBC.

    edit: @dragons_master, just read your post, will try to find more info about your tip now... thanks
     
  5. The_Dragons_Mast

    Member The_Dragons_Mast GBAtemp Advanced Fan

    Joined:
    Apr 20, 2007
    Messages:
    613
    Country:
    Egypt
    Well you used a nearly 2 years old guide so this are the consequences . First of all DON'T UNINSTALL PRELOADER FOR NOW . Second there is an option to install a .dol file in preloader just install this http://www.mediafire.com/?zb9lg8d88d04h9b and see if it boots . If it boots then use it to do the WAD installing & use ModMii from here http://gbatemp.net/t207126-modmii-for-windows to get the WADs .

    I can't fully remember but I believe to install it you need to put the boot.dol in the memory card root.
     
  6. krezy
    OP

    Newcomer krezy Member

    Joined:
    Nov 25, 2009
    Messages:
    17
    Country:
    United States
    I am able to load MMM but the wii remote doesn't work, probably need gamecube controllers? I don't have these [​IMG]
     
  7. The_Dragons_Mast

    Member The_Dragons_Mast GBAtemp Advanced Fan

    Joined:
    Apr 20, 2007
    Messages:
    613
    Country:
    Egypt
    Well you can try re-syncing or rapidly pressing 1 & 2 but if it fails then yes you need to get a gamecube controller . Just go out & grab the cheapest gamecube controller & use it to reinstall your system menu.
     
  8. krezy
    OP

    Newcomer krezy Member

    Joined:
    Nov 25, 2009
    Messages:
    17
    Country:
    United States
    bummer all shops closed until monday

    any other wad managers that can load from preloader?
     
  9. The_Dragons_Mast

    Member The_Dragons_Mast GBAtemp Advanced Fan

    Joined:
    Apr 20, 2007
    Messages:
    613
    Country:
    Egypt
    Well I don't know about any other current wad managers but you can try dop-mii here . It isn't really a wad manager but it can be used to re install the system menu & support all controllers.

    If it loaded but you cant control it with the wiimote then preloader might be the cause as its really outdated now & you have to wait till you get a gc controller.
     
  10. krezy
    OP

    Newcomer krezy Member

    Joined:
    Nov 25, 2009
    Messages:
    17
    Country:
    United States
    ok thanks, launched dopmii + wii remote ok. Is it possible for you to guide me step by step, I don't want to do anything wrong now.
     
  11. The_Dragons_Mast

    Member The_Dragons_Mast GBAtemp Advanced Fan

    Joined:
    Apr 20, 2007
    Messages:
    613
    Country:
    Egypt
    Here : http://sites.google.com/site/completesg/how-to-use/dop-ios . If you are connected to a wi-fi connection then it should be really simple but if you aren't you will need modmii to download the WADs required for you & put then in the WAD folder.

    You mainly need to reinstall the system menu & ios 70 but you might also use it to remove stubs & update all your ios if you want . Just keep in mind that the re installing will remove preloader so you will need to make sure as much as possible that nothing goes wrong.

    EDIT: Before doing anything you might want to try to reinstall hbc with the latest hackmii installer from here http://bootmii.org/download as it is alot safer doing this from hbc.
     
  12. Coto

    Member Coto GBAtemp Addict

    Joined:
    Jun 4, 2010
    Messages:
    2,276
    Country:
    Chile
    1. A scrambled/messed up HBC means the IOS HBC uses was patched (IOS36?), you'll need to reinstall IOS 61, 58, 36 without patches for now, oh and they must NOT be STUB IOS. Use Dop-mii to reinstall those IOS.

    2. Later you'll need to reinstall HBC (1.0.8) along the new bootmii (as ios too) using the hackmii installer you can grab from hackmii site.

    3. Also, it would be a good idea to reinstall the whole System Menu, which can be done through dop-mii too. If you install 4.3U you must install IOS80 NON-STUB(yes, it means NO STUB IOS).


    4. Don't uninstall preloader for now, it should be erased once dop-mii re-installs the 4.3U System Menu (If dop-mii asks you to preserve preloader, choose NO).

    5. And finally install priiloader (0.7).

    6. Do a NAND backup.
     
  13. krezy
    OP

    Newcomer krezy Member

    Joined:
    Nov 25, 2009
    Messages:
    17
    Country:
    United States
    thanx both, still reading and trying to understand all, since I probably only have 1 shot to fix this (as preloader will be removed with dopmii)

    I also found this (dopmii restoring 4.1):
    http://gbatemp.net/t225437-wii-bricked-pre...t&p=2813648

    1) Do you guys think this guide is safe
    2) @Coto if I reinstall IOS 61, 58, 36 without patches, how would I be able to restore the System Menu? Won't dopmii give an error like: "ERROR! Choose an IOS that accepts fake signing!" . I currently have IOS36 that accepts fake signing. Sorry if I'm misunderstanding.
     
  14. Coto

    Member Coto GBAtemp Addict

    Joined:
    Jun 4, 2010
    Messages:
    2,276
    Country:
    Chile
    IIRC dop-mii should see if you have the IOS required by the system menu update (if you choose 4.3U it should check IOS 80). And no, just grab the latest dop-mii from the wiibrew site, and since it uses AHBPROT (a low level hardware access 'exploit') it won't need any ios patched! (make sure you get the latest one, because earlier revs of dop-mii didn't have this feature).

    Just make sure you update all the IOS described above (non-stub IOS, remember), then proceed with the Hackmii 1.0.8 installer (HBC 1.0.8 and bootmii as ios too!) , then the system menu update, then priiloader.

    I usually prefer to install priiloader before anything, but since you already have preloader installed, you'll need to wipe it from NAND first.

    edit: If ahbprot can't be enabled in dop-mii, you'll need to grab also the IOS236 installer. This app installs a patched IOS236 which you can later use for most homebrew to install stuff to NAND (it has all the patches/NAND permission bundled)
     
  15. JoostinOnline

    Member JoostinOnline Certified Crash Test Dummy

    Joined:
    Apr 2, 2011
    Messages:
    10,834
    Location:
    The Twilight Zone
    Country:
    United States
    It would be safer if the OP was to re-install the System Menu he already has. No point in updating to 4.3. I would also suggest either using MMM or Wii Mod instead, as the newer versions of Dop-Mii have numerous reports of crashing. There is also no reason to install a clean IOS36, because that will just limit what the OP can do.
     
  16. terminal_illness

    Member terminal_illness Dark Hadou Master

    Joined:
    Aug 29, 2008
    Messages:
    746
    Location:
    Canada! Mah Fukas!
    Country:
    Canada

    [​IMG]
     
  17. krezy
    OP

    Newcomer krezy Member

    Joined:
    Nov 25, 2009
    Messages:
    17
    Country:
    United States
    Update: I just went for this ^^^ solution (using dopmii). I found IOS70-64-v6687 [Patched][FreeTheBug] on my hdd from a previous softmod (don't remember why, something with preloader), I held my breath and used that one (along with System Menu 4.2 from NUS).

    And all is back. Happy me.

    Thank you all for your input, I have read all your suggestions carefully (it's a few hours later now and the solution was like 5 mins work...). Thank you The_Dragons_Master_F for pointing me to dopmii, that really saved this wii.


    I still would like some sort of protection like preloader. So the latest priiloader is the way to go? For what it's worth:
    1) I can now use my remote with MMM
    2) system was and still is 4.2.
    3) HBC is still installed, version 1.0.6 IOS61 v21.29 .
    4) The softmod is yet not complete, I haven't deleted the stub ios's yet, nor installed a cios/backuploader.
     
  18. JoostinOnline

    Member JoostinOnline Certified Crash Test Dummy

    Joined:
    Apr 2, 2011
    Messages:
    10,834
    Location:
    The Twilight Zone
    Country:
    United States
    Use ModMii and tell it your Wii is a virgin. You no doubt have some very out of date stuff.
     
  19. The_Dragons_Mast

    Member The_Dragons_Mast GBAtemp Advanced Fan

    Joined:
    Apr 20, 2007
    Messages:
    613
    Country:
    Egypt
    Nice to know that your wii is fully functional again . Now first thing to do is install priiloader from here http://code.google.com/p/priiloader/downloads/list . Second check if you have any stubs & remove them with dopmii . After that you can update your hbc , install cios or anything else you want as long as you stay away from ios 70 & the system menu you will be safe.
     
  20. JoostinOnline

    Member JoostinOnline Certified Crash Test Dummy

    Joined:
    Apr 2, 2011
    Messages:
    10,834
    Location:
    The Twilight Zone
    Country:
    United States
    There is no need to mess with stubs. They won't hurt anything if you leave them there.
     

Share This Page