Homebrew RELEASE pPlay: switch video player

docgold

Member
Newcomer
Joined
Feb 4, 2021
Messages
22
Trophies
0
Age
41
XP
29
Country
Bosnia and Herzegovina
@docgold
i should have fixed the regex for your decoder, now it will print the channels list.

can you send me the result of /web/epgnow?bRef=1:7:1:0:0:0:0:0:0:0 (for epg integration)
so i can make a more consistent build.
thanks
GB800 SE and openLD works but sadly Dreambox One doesn't. Bouquets are not shown.
 

Attachments

  • epgnow.xhtml.zip
    363 KB · Views: 14
Last edited by docgold,

proconsule54

Well-Known Member
Member
Joined
Nov 5, 2019
Messages
508
Trophies
0
Age
41
XP
1,213
Country
Italy
@docgold
try on Dreambox One with:

/web/getservices?sRef=1:15:fffffffe:12:ffffffff:0:0:0:0:0:

and

/web/getservices

and post the results

probably an empy sRef give error on that decoder (not on others).
 

tataniko

Well-Known Member
Member
Joined
Jul 20, 2016
Messages
164
Trophies
0
Location
- Planet Earth -
Website
www.facebook.com
XP
1,081
Country
Antarctica
@proconsule54

Did you find anything about performance issue?
Also, our kids request to add battery percentage (%) to the status bar of Pplay.
Keep up the good work & thank you. :)

battery.png
 

proconsule54

Well-Known Member
Member
Joined
Nov 5, 2019
Messages
508
Trophies
0
Age
41
XP
1,213
Country
Italy
Did you find anything about performance issue?
Also, our kids request to add battery percentage (%) to the status bar of Pplay.
Keep up the good work & thank you. :)
Yes i am working on performance, i have some ideas.
the battery % is simple to add so it will be in the next release for sure!
 
  • Like
Reactions: tataniko

docgold

Member
Newcomer
Joined
Feb 4, 2021
Messages
22
Trophies
0
Age
41
XP
29
Country
Bosnia and Herzegovina
@docgold
try on Dreambox One with:

/web/getservices?sRef=1:15:fffffffe:12:ffffffff:0:0:0:0:0:

and

/web/getservices

and post the results

probably an empy sRef give error on that decoder (not on others).

GB800: Enigma2-TV works but after a some time picture is freezing and SXOS crashes.

On the E2 screenshot you can see that the currently watched ts stream makes it impossible to zap within the receiver. Exit on pPlay doesn't open the zapping functionalty on receiver. Only E2 restart solves the problem.
Maybe (webif-) zapping via pPlay is an further option?

After selecting Enigma2 only the current available EPG is listed. There is no interactive updating.

Extended latin alphabets like Ü,Ä, ... are not displayed correctly. See picture.

DM One: ftp streaming from /media/hdd works till suddenly the picture gets blurred. Audio still working while picture freezing.
Stoping the movie and restart from this point solves problem. If I do not stop it within a short time window, SXOS is crashing.
Error messages.

After all of this crashes I have problems to get SXOS bootet with my NS Atmopshere payload injector.
 

Attachments

  • screenshot.jpg
    screenshot.jpg
    67.4 KB · Views: 9
  • IMG_20211015_123842.jpg
    IMG_20211015_123842.jpg
    455.3 KB · Views: 10
  • IMG_20211015_120927.jpg
    IMG_20211015_120927.jpg
    654.7 KB · Views: 12
  • IMG_20211015_120448.jpg
    IMG_20211015_120448.jpg
    623.6 KB · Views: 12
  • getservices?sRef=1:15:fffffffe:12:ffffffff:0:0:0:0:0:.xhtml.zip
    178 KB · Views: 18
  • getservices.xhtml.zip
    2.2 KB · Views: 10

proconsule54

Well-Known Member
Member
Joined
Nov 5, 2019
Messages
508
Trophies
0
Age
41
XP
1,213
Country
Italy
Ok @docgold thanks for your debugging.
Extended chars will be fixed as soon as i get UTF8 working.
The crash on live tv will probably be fixed when i resolve the performace issue (i suspect it has a cpu peak).
Dreambox One will be fixed also with the log you provided.
Thanks!
 

proconsule54

Well-Known Member
Member
Joined
Nov 5, 2019
Messages
508
Trophies
0
Age
41
XP
1,213
Country
Italy
Sorry for the delay but i want to deliver code that is as good as i can.
But expect a release in the next days with many fix and new features

Also if someone skilled in icon design can provide a better icon? Thanks
 

tataniko

Well-Known Member
Member
Joined
Jul 20, 2016
Messages
164
Trophies
0
Location
- Planet Earth -
Website
www.facebook.com
XP
1,081
Country
Antarctica
@proconsule54
The video decoder performance will be the same or better in your fork than Pplay 3.5?
I have seen your question on libnx about Video HW decoder, but there is no answer yet.
How is possible that, Pplay3.5 is much better in performance than your fork 4?
If you solve the performance issue, then your fork will be the best media player on Switch.
Thanks & keep up the good work. :)
 
Last edited by tataniko,
  • Like
Reactions: proconsule54

proconsule54

Well-Known Member
Member
Joined
Nov 5, 2019
Messages
508
Trophies
0
Age
41
XP
1,213
Country
Italy
Performance diff may be in the ffmpeg complied in. i suspect that the ones bundled in 3.5 was a custom build one. but anyway i am working on making it the fastest possible.
HW decoder inst possible at the moment but i am sure it will be there in a not so long time.
 
  • Like
Reactions: tataniko

proconsule54

Well-Known Member
Member
Joined
Nov 5, 2019
Messages
508
Trophies
0
Age
41
XP
1,213
Country
Italy
Release

https://github.com/proconsule/pplay/releases/tag/v3.5-fork-v5

Changelog:
  • Added CPU/GPU/MEM Meter
  • Changed Font
  • Fix for Dreambox One decoder (hope so)
  • Added Battery %
  • Small fixes
Hope you all enjoy this release!

I really need a new icon (@Storm21 thanks for your icon but i need an original one made by known author) so help me on that!
 

proconsule54

Well-Known Member
Member
Joined
Nov 5, 2019
Messages
508
Trophies
0
Age
41
XP
1,213
Country
Italy
@proconsule54
Pplay 3.5 fork 5 is not running on AMS 1.1.1 FW 13.0.0
It crashes immediately, error occurred, software closed.
Fork 4 is running & stable on AMS 1.1.1 FW 13.0.0.
Very Very Strange!!!
I know it has issue with some tesla overlay.
I only used the sys-clk for setting power saving freqs.
Can you test on lower fw and let me know!
Sorry for this issue

I tested it on FW 12.10 and AMS 1.0.0
 
  • Like
Reactions: tataniko
General chit-chat
Help Users
  • No one is chatting at the moment.
    Veho @ Veho: Getting reamed.