Power Outtage in my area killed my Wii

Discussion in 'Wii - Console and Game Discussions' started by Dharmaboy, Sep 25, 2009.

Sep 25, 2009
  1. Dharmaboy
    OP

    Newcomer Dharmaboy Advanced Member

    Joined:
    Jul 6, 2009
    Messages:
    81
    Country:
    Canada
    So I was playing Grand Slam Tennis just tonight and suddenly the power came on and off , and on and off again. My USB Drive (using Loader GX) flashed back on and powered. But my Wii will not turn on anymore. I tried a few different power plug ins and nothing.

    I don't want to remod a new Wii (old one is under warranty with Best Buy) and end up with a dreaded LU64 or LU65.

    What the hell. When I finally started using this Wii over the past few months and This had to happen. Grrr

    Am I screwed or what?
     
  2. jesterscourt

    Member jesterscourt Not Brad.

    Joined:
    Jan 3, 2007
    Messages:
    2,153
    Country:
    United States
    Well you may not be completely hosed. The first thing I would check is the power adapter itself. Do you have a friend/family member/coworker that also has a Wii? Ask them if you can borrow the power supply. I'd check that first. If it's just the power supply that's hosed, you may be able to work things out from there. Update us! [​IMG]
     
  3. Dharmaboy
    OP

    Newcomer Dharmaboy Advanced Member

    Joined:
    Jul 6, 2009
    Messages:
    81
    Country:
    Canada
    Phew okay Update.

    Looks like I had to let the PSU sit for a bit (cooldown or reset?). She powered back up again.

    So Looks like the Power Adapter has some sort of failsafe in these events.

    Good to know for later.

    thanks
     
  4. zuron7

    Member zuron7 RBYG

    Joined:
    Apr 6, 2009
    Messages:
    1,369
    Location:
    GPS not available in this area
    Country:
    India
    It has a fuse in it.
    That's all.
     
  5. nico445

    Member nico445 GBAtemp Advanced Fan

    Joined:
    Apr 27, 2008
    Messages:
    579
    Location:
    my house.
    Country:
    Netherlands
    had almost the same once the wii froze and i plugged it very quikly out and in again..
    then it didn't light op until i let it rest for a bout 2/3 mins
     

Share This Page