Pokemon Soul Silver: White Screen at Startup

Discussion in 'DSTT' started by Rokku, Nov 28, 2010.

Nov 28, 2010
  1. Rokku
    OP

    Member Rokku GBAtemp Fan

    Joined:
    Oct 4, 2010
    Messages:
    358
    Country:
    United States
    So I have Pokemon Soul Silver on my DSTT, and even with the Anti-Piracy patcher AND a trimmed ROM, it gives me nothing but a white screen.

    Could the Neo Soul Silver ROM hack be the problem?
     
  2. SlimShady

    Newcomer SlimShady Member

    Joined:
    Aug 24, 2010
    Messages:
    28
    Location:
    Canada
    Country:
    Canada
  3. Rokku
    OP

    Member Rokku GBAtemp Fan

    Joined:
    Oct 4, 2010
    Messages:
    358
    Country:
    United States
  4. jurassicplayer

    Member jurassicplayer Completionist Themer

    Joined:
    Mar 7, 2009
    Messages:
    4,280
    Location:
    Pantsuland
    Country:
    United States
    It could possibly be the patch that you applied. Check the Game ID to see if it matches the clean one (probably won't) and if it doesn't, I would suggest taking a look at the section for DSTT help in the B/W translation patch in order to fix up your infolib.dat and extinfo.dat.
     
  5. Rokku
    OP

    Member Rokku GBAtemp Fan

    Joined:
    Oct 4, 2010
    Messages:
    358
    Country:
    United States
    I'm seeing two different IDs with the same code (IPGE), which TTMenu tells me is the game code.

    So which one do I change?
     
  6. Rokku
    OP

    Member Rokku GBAtemp Fan

    Joined:
    Oct 4, 2010
    Messages:
    358
    Country:
    United States
    Did what the instructions said, white screen all the same.

    Should I have kept both IPGE codes?
     
  7. Rokku
    OP

    Member Rokku GBAtemp Fan

    Joined:
    Oct 4, 2010
    Messages:
    358
    Country:
    United States
    Gave this another crack tonight with a fresh ROM, nope! Still just a white screen.

    There's two IPGE game IDs, and I changed both because changing the first one didn't fix it, so...what? Why does it still not work?
     
  8. Rokku
    OP

    Member Rokku GBAtemp Fan

    Joined:
    Oct 4, 2010
    Messages:
    358
    Country:
    United States
  9. Ammako

    Member Ammako GBAtemp Guru

    Joined:
    Dec 22, 2009
    Messages:
    6,372
    Country:
    Canada
    One of my friends has a TTDS, I just updated savlib.dat, extinfo.dat and infolib.dat and everything worked perfectly, including B/W.
    Before updating, he was running HG with the regular AP patch and it worked perfectly.
     
  10. Rokku
    OP

    Member Rokku GBAtemp Fan

    Joined:
    Oct 4, 2010
    Messages:
    358
    Country:
    United States
    This isn't regular HG/SS though, this a ROM hack of SS.
     

Share This Page