1. Alex4U

    OP Alex4U i like pancakes
    Member

    Joined:
    Jan 6, 2016
    Messages:
    1,209
    Country:
    Mexico
    No, I already changed the battery for a new one and still doesn't work. Saving works perfectly, but time doesn't run. It keeps in the same time. (Tuesday 18:32)
    I already investigated something about it, I just found two things: Broken oscillator from cartridge or broken cartridge. The cartridge isn't damaged in anyway, and I the oscillator is fine, I already tried to resolder it, and still doesn't work. The same thing happend to my gold cartridge, wasn't working but i'm not sure what I did, I just cleaned the oscillator and it got working. Weird. I did that on my Silver cartridge, and I had no luck. Still froze. Lucky I have an oscillator, but I want to make sure if the oscillator from the cartridge is damaged somehow and how can I fix it before soldering the new one. (Also I bought them used of course, I just changed the batteries of both) I don't know if soldering the oscillator from the cheap clock I have would work, yeah it has the same form like the gameboy cartridge.
    Changing battery doesn't work, tried with three new batteries and didn't work. Even if I have my gameboy on, the clock is still freeze, never changes.
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - oscillator, cartridge, Pokémon