Pokemon Shiny Gold with EZ3in1

Discussion in 'GBA - Game Development, ROM Hacks and Translations' started by TheWingless, Feb 28, 2008.

Feb 28, 2008
  1. TheWingless
    OP

    Member TheWingless Wafuu~

    Joined:
    Jan 29, 2008
    Messages:
    1,034
    Country:
    United States
    Pokemon SG works, but the saving will not work with or without the SRAM patch. It actually starts saying the save is corrupted when I use the SRAM patch, which means if I save, I'll just end up in the last place I saved before it. I also tried the EZ4 Client, but that didn't work either. The patching tool I used was GBATA.

    Patching Order:
    Patch with Save Patch(Came with Fire Red. Don't even think I need it) > Patch Shiny Gold > Fix Header (Won't start without this) > SRAM(Either Before or after Fix Header and will not work)

    Atleast I got the game to work on my EZ 3in1 but it still won't save. [​IMG]
    Has anyone gotten it to work or has a solution?
     
  2. Volsfan91

    Member Volsfan91 GBAtemp Regular

    Joined:
    Sep 3, 2006
    Messages:
    203
    Country:
    United States
    Worked fine for me- I just dumped my own Fire Red ROM, patched with Lunar IPS, patched with the EZ4 Client on default settings, and then burnt to cart with whatever was popular at the time a few months ago.
     
  3. myuusmeow

    Member myuusmeow GBAtemp Advanced Maniac

    Joined:
    Jun 24, 2007
    Messages:
    1,643
    Country:
    United States
    I've gotten it to work:
    1. IPS patch
    2. SRAM patch
    3. Put on 3-in-1

    Worked fine for me. I still got the error message "save corrupted" but I could still save just fine. Try a ROM from a different source.
     
  4. TheWingless
    OP

    Member TheWingless Wafuu~

    Joined:
    Jan 29, 2008
    Messages:
    1,034
    Country:
    United States
    I can't even get past the GBA Bios Boot thing without using the header fix in GBATA, because it says it's "BAD" after I patch it with the Shiny Gold hack.

    [​IMG]

    And I forgot to say this but I'm using the Version 5 Shiny Gold patch which ends at Fuchsia City. It seems I can't get it to even load my save as it just deletes it now. [​IMG] I also tried using another ROM of the same game, but it doesn't seem to make a difference.

    Edit: I found out a way to get saving to work even though it's corrupted! (Yeah, I got the patches and ROM to work) All you have to do is save the game twice, because it reverts to the save before your last. [​IMG]
     
  5. Trolly

    Member Trolly GBAtemp Advanced Maniac

    Joined:
    Sep 14, 2007
    Messages:
    1,720
    Location:
    Behind you! I know you looked!
    Country:
    United Kingdom
    Thanks, I was just about to ask how you do this. I'll have to go find a different ROM, seeing as I'm having the problem you had originally.
     
  6. TheWingless
    OP

    Member TheWingless Wafuu~

    Joined:
    Jan 29, 2008
    Messages:
    1,034
    Country:
    United States
  7. Trolly

    Member Trolly GBAtemp Advanced Maniac

    Joined:
    Sep 14, 2007
    Messages:
    1,720
    Location:
    Behind you! I know you looked!
    Country:
    United Kingdom
    Okay, any chance you could tell me how you fixed the saves and everything?
    So far, I've patched Fire Red with Shiny Gold V5 and fixed the header with GBATA.

    Do I need the newest GBA ExPloader for saves to work?

    EDIT:
    Sorry, I've got it working now. Just followed what the other guys did.

    Out of interest, where did you get the Beta 5 from? The latest I've seen is Beta 4!
     

Share This Page