Pokemon migration issue (Ez flash 2 to DS)!

Discussion in 'NDS - Flashcarts and Accessories' started by Slipstream, May 2, 2007.

May 2, 2007
  1. Slipstream
    OP

    Newcomer Slipstream Newbie

    Joined:
    May 1, 2007
    Messages:
    9
    Country:
    United States
    HELP!!!

    I have a 512mb EZ-Flash 2 powerstar and it works great. However I recently acuired a Nintendo DS and Pokemon Version Pearl. It is possible with Version Pearl to "migrate" pokemon from the GBA games to the DS for use in Pearl. However the Pearl does not recoginize the Flash cart. The DS will play GBA games from the Flash cart though. I tried removing the EZ-Loader and removing the Intro, my idea was that the DS would read straight to the ROM, but to no avail. Does anyone know how to make the migration function work? Please Help!!!
     
  2. Dirtie

    Former Staff Dirtie :'D

    Joined:
    Sep 9, 2003
    Messages:
    3,705
    Location:
    Zealer
    Country:
    New Zealand
    That's usually what you would do. Make sure it's the only rom on the cart, make sure it is written without a loader, and possibly without any patching either (I remember there were IPS patches for some of the GBA Pokemon games) - make sure your one has a good CRC (let me know exactly what GBA game it is and I'll give you the right CRC). Also, I heard that it must be the same region as your copy of D/P - if you originally had a Japanese save and transferred it over to the USA version, you could try using the Japanese GBA rom, though I don't know if this will make a difference (anything's worth a shot).

    Edit: Topic moved to the appropriate forum.
     
  3. Slipstream
    OP

    Newcomer Slipstream Newbie

    Joined:
    May 1, 2007
    Messages:
    9
    Country:
    United States
    Yeah, it was the only rom on the cart. I disabled the EZ-Loader as well. The game I tried it on is Pokemon Emerald Version. As far as I can tell it is the U.S. version...it's in English any ways. What exactly is a CRC? How do I apply it to the rom cart? Thank you very much for your help, it is greatly appreciated. I posted on some other forums but nobady had a clue what I was talking about.
     
  4. larvi

    Member larvi GBAtemp Regular

    Joined:
    Jun 24, 2006
    Messages:
    233
    Country:
    United States
    I tried and couldn't get it to work with my EZ2 either, or my EZ4. To the best of my knowledge no one has been able to migrate pokemon to a retail copy of diamond/pearl from any flash cart, if they have I would like to know how.
     
  5. Dirtie

    Former Staff Dirtie :'D

    Joined:
    Sep 9, 2003
    Messages:
    3,705
    Location:
    Zealer
    Country:
    New Zealand
    Did you try copying it into the NOR memory on the EZ4?

    Emerald has a patch and will not run on a lot of carts without it applied. 1F1C08FB is the correct unpatched CRC32.
     
  6. Destructobot

    Member Destructobot Crave the Hammer

    Joined:
    Oct 15, 2006
    Messages:
    5,005
    Location:
    Portland, OR
    Country:
    United States
    The problem isn't the rom, it's the save memory. Diamond & Pearl can't read the save from the SRAM on a flashcart, they can only read the type of save that the retail GBA carts use.

    Currently, the only way to migrate pokemans to Diamond or Pearl from a flashcart is with the EZ-V with kernel 1.40 or higher and the 3-in-1 expansion cart. The EZ-V will patch the DS rom so that it can read the save from the 3-in-1. (incidentally, when they fixed migrating from the 3-in-1, they broke migrating from genuine GBA pokemon carts.)
     
  7. Slipstream
    OP

    Newcomer Slipstream Newbie

    Joined:
    May 1, 2007
    Messages:
    9
    Country:
    United States
    So then presently there is no way to migrate to the store bought game from a cart or from a store bought game to a cart? The only way is to use the EZ-Flash V + 3 in 1 combo? Does the WiFi work when running off the EZ flash V?
     
  8. Destructobot

    Member Destructobot Crave the Hammer

    Joined:
    Oct 15, 2006
    Messages:
    5,005
    Location:
    Portland, OR
    Country:
    United States
    It should.
     
  9. Slipstream
    OP

    Newcomer Slipstream Newbie

    Joined:
    May 1, 2007
    Messages:
    9
    Country:
    United States
    Thanks for all the info. What exactly is the 1.40 kernal? Is that just the code that the EZ-V is using? Also what software do you use to manage the EZ-V? It isn't Ez-Client is it?
     
  10. Destructobot

    Member Destructobot Crave the Hammer

    Joined:
    Oct 15, 2006
    Messages:
    5,005
    Location:
    Portland, OR
    Country:
    United States
    I'm not 100% sure, as I don't have an EZ-V, but I don't think you really need any extra software with the newest kernels (at least not for DS games). There is a hybrid tool that was used to patch roms to add various capabilities, but I think that's been integrated into the kernel now.

    You do need to patch GBA roms with the EZ4 Client to get them to work on the 3-in-1.
     
  11. Slipstream
    OP

    Newcomer Slipstream Newbie

    Joined:
    May 1, 2007
    Messages:
    9
    Country:
    United States
    When you say that you don't need any extra software for EZ-V does that mean I can just drag and drop roms onto it?
     
  12. Destructobot

    Member Destructobot Crave the Hammer

    Joined:
    Oct 15, 2006
    Messages:
    5,005
    Location:
    Portland, OR
    Country:
    United States
    As far as I know, yes.
     

Share This Page