Homebrew Pokemon Emerald Corrupted Save After Elite Four


Jan 2, 2017
United States
As the title suggests I've been playing through Pokemon Emerald on my 3DS from a CIA I built/injected myself. However, after beating the elite four I was greeted with the fantastic message: "The save file has been erased due to corruption or damage." So, I dumped the save with GodMode9 and started troubleshooting.

PKHeX gave me an error implying the save was corrupted. I tried using an emulator and that just didn't work. So I did some research and found that one of the biggest problems I had was when I made the CIA, I made it to save in 64Kb which I guess causes problems later (even though I followed a guide for making the CIA, maybe I did something wrong).
I read somewhere that I could pad the save file with 00's in HxD and that should fix it. While this does let me see my Pokemon in PKHeX, that is the full extent of what I can do with the now 128Kb save.
I also read that I can try using an emulator to convert the save. So I booted up the version of the rom that saves in 64Kb and tried importing my save (battery file), but that still gave me the corruption message. And loading a rom that saves in 128Kb with the 128Kb save also gives me the corruption message.

At this point, I have no idea what else to do to recover. While it's nice that I still have access to the Pokemon themselves, I would like to continue playing with this save. I do have an even earlier backup that I exported from PKSM that does work (I was using a different CIA at the time) but it's so far back that I would rather not restart. Maybe, though, that might help recover?

EDIT: I just found another backup from the latest CIA I used that's 20 hours in, 64KB, and working just fine. Still though, I would much rather not have to make up 17 hours lost.

Thank you in advance for the help!
Last edited by Momaster12,
General chit-chat
Help Users
    Psionic Roshambo @ Psionic Roshambo: Looks like fun