Please, Please, Please tell me someone can help me here.

Discussion in '3DS - ROM Hacking, Translations and Utilities' started by handheldvet, Feb 29, 2016.

  1. handheldvet
    OP

    handheldvet Advanced Member

    Newcomer
    68
    4
    Feb 29, 2016
    Hiya guys, I've currently got back into handheld gaming, and I've been using the Drastic emulator for Android. However, I'd like to be able to play Nintendo 3DS games on an emulator, but after hours of searching, there isn't a stable emulator around that can do that, which leads me to just getting a console, and an R4 Card. I've not used an R4 card since 2011, when I had a NDS Lite, long time ago, so a lot's changed in the time I've been away.

    What I'd like to know is if R4 cards work on N2DS, and if so, which ones are they, and if possible, could someone link me to a trusty website to get one of these, as I say, I want the card to be totally able to work on a 2DS, and also be able to play 3DS games, I'd like to take a punt myself, but unfortunately, it's been a long time since I've done anything like this that I may end up going about it the wrong way.

    Note: I've seen the SKY3DS & Gateway Flash cards, those aren't what I'm interested in
     
  2. SomeGamer

    SomeGamer GBAtemp Guru

    Member
    5,796
    2,760
    Dec 19, 2014
    Hungary
    Only Sky and Gateway can play 3DS games. But on or below 10.3 firmware version, you don't even need a flashcart to play roms!
     
  3. GalladeGuy

    GalladeGuy Freeze Kirby :3

    Member
    2,588
    2,652
    Oct 28, 2015
    United States
    Sorry, but I don't think there are any R4s that can play 3DS games, and most of them don't even work on 3DS anyways. If you want to pirate on a 3DS, you're either going to need a 3DS with firmware 10.3 or lower and a lot of technical knowledge, or a Sky3DS+/DSTWO. Gateway DOES NOT work on the latest versions.

    EDIT: :ninja:
     
    Games&Stuff likes this.
  4. handheldvet
    OP

    handheldvet Advanced Member

    Newcomer
    68
    4
    Feb 29, 2016
    I've seen gateway doesn't run, surprises me, as they're still quite expensive. It annoys me, as I would play them outright on a proper game bought from a shop, but given that Pokemon Y is still £25-30.

    SKY3DS cards are a little risky, those prices make me unnerved about the fact that one day they could just stop working.

    Exactly what sort of knowledge would I need with a firmware lower than 10.3, and can the 2DS be downgraded?

    — Posts automatically merged - Please don't double post! —


    What exactly do you mean? don't need a flashcart?
     
  5. Magical Sheep

    Magical Sheep The Super Stylish Black Cat

    Member
    277
    130
    Jan 22, 2016
    United States
    The Metaverse
    If the console was on firmware version 10.3 (or below), you could use a custom firmware to install the games and skip the flashcart. (10.3 would let you backdate the console's firmware version, so it made that possible.)
     
  6. GalladeGuy

    GalladeGuy Freeze Kirby :3

    Member
    2,588
    2,652
    Oct 28, 2015
    United States
    If you are on 9.3-10.3, you are able to downgrade to 9.2 and use a kernel exploit that allows piracy. The problem is, downgrading is pretty difficult if you don't know what you're doing, and it doesn't work 50% of the time anyways, which could force you to update to an undowngradable version, or just outright break your console. Once you're on 9.2 or below, installing emuNAND for piracy isn't exactly a piece of cake either, even with a good guide.
     
  7. handheldvet
    OP

    handheldvet Advanced Member

    Newcomer
    68
    4
    Feb 29, 2016
    That sounds easy enough to do, is it still possible to do? and would there be a chance that eventually, that would stop working?. Sorry for the completely OTT questions, it's just I've not done this for a long time, so I've lost knowledge lol
     
  8. Magical Sheep

    Magical Sheep The Super Stylish Black Cat

    Member
    277
    130
    Jan 22, 2016
    United States
    The Metaverse
    This sums it up well. The exploit was fixed in the versions after 10.3, but you would stay on whatever version you downgraded to unless you update for some reason.
     
    Games&Stuff, Seriel and GalladeGuy like this.
  9. handheldvet
    OP

    handheldvet Advanced Member

    Newcomer
    68
    4
    Feb 29, 2016
    Seeing as you know what you're talking about, would you do this yourself if you needed to? I'm pretty much gonna take what you say, I wouldn't wanna go out and buy a console, then balls it up for myself with my own wrong doing
     
    GalladeGuy likes this.
  10. deishido

    deishido Texture Modder

    Member
    241
    115
    Jul 8, 2009
    United States
    Indiana
    https://gbatemp.net/threads/simple-guide-to-downgrading-your-3ds.407888/

    Heres the guide I followed. Find the firmware files on that iso site. (We can't link you, but its easy to find) you want the firmware files for the O3DS system version 9.2.0-20 (e/u/j) whatever region you're in. That is the one that will work on your 2ds. Notice the O at the beginning. Do not use anything labeled N3DS with an N. That will brick your system.

    After you're downgraded, drop the cfw of your choice and you're ready to go. Reinand is pretty smooth, rxtools works well for the 2ds as well. From there, you can install games in the cia format directly to your sd card. Make sure your card is big enough. Mine is a 32 gig and I have about a dozen big games on it with space for more.

    If you set up cfw and also set up menuhax to boot you directly into emunand, there will be almost no chance of bricking. Just don't update your system. Good luck.
     
  11. GalladeGuy

    GalladeGuy Freeze Kirby :3

    Member
    2,588
    2,652
    Oct 28, 2015
    United States
    Believe it or not, I just did exactly that with my dad's N3DS on 9.9. I'd be happy to help you. :)
     
  12. Magical Sheep

    Magical Sheep The Super Stylish Black Cat

    Member
    277
    130
    Jan 22, 2016
    United States
    The Metaverse
    I did it to my New 3DS XL twice, but I couldn't get online working on the custom firmware, so I updated since a friend wanted to play online with me.
     
  13. handheldvet
    OP

    handheldvet Advanced Member

    Newcomer
    68
    4
    Feb 29, 2016
    Thanks for everyone's help, really do appreciate it, I didn't even have this help when I first started doing this in 2011 xD.

    What happened if I bought a Nintendo 2DS on say 10.2, could I do the whole thing without the need to downgrade? or would I downgrade for peace of mind.
    Secondly, seeing as I've never had a 3D Nintendo, do the updates happen forced? or can you choose to accept/reject them?
     
    Magical Sheep likes this.
  14. GalladeGuy

    GalladeGuy Freeze Kirby :3

    Member
    2,588
    2,652
    Oct 28, 2015
    United States
    Actually, as long as you don't buy the Yokai Watch or Pokemon RBY bundle, it will come with a firmware WELL under 9.2, meaning you don't have to downgrade and you can use go.gateway-3ds.com to install emuNAND with some SD Card fiddling. Don't worry, it doesn't auto-update like the Wii U. Every time you go to the home menu, it will ask if you want to update, and you can just tap no. Just keep in mind that online play, the eshop and the friends list won't work unless you are on the latest update, and certain games require a certain update or higher to work.
     
    Last edited by GalladeGuy, Feb 29, 2016
  15. handheldvet
    OP

    handheldvet Advanced Member

    Newcomer
    68
    4
    Feb 29, 2016
    So basically, the only things I'd need, is a Nintendo 2DS, and a SD Card, and that's it? No R4 Card, no Flashcard or anything?

    And that's fine about the eshop thing, and friends thing, I'm 24, I don't have friends who still play Nintendo xD
     
  16. Magical Sheep

    Magical Sheep The Super Stylish Black Cat

    Member
    277
    130
    Jan 22, 2016
    United States
    The Metaverse
    *jumping back in* No flashcart is needed. If you do go to downgrade, you need to be absolutely sure that you don't accidentally install the wrong firmware. (N3DS FW on an Old 3DS)
     
  17. GalladeGuy

    GalladeGuy Freeze Kirby :3

    Member
    2,588
    2,652
    Oct 28, 2015
    United States
    Yep. All you need is a 2DS, an internet connection, and an SD Card adapter. (Although I recommend getting a bigger SD Card, as the one the 2DS comes with probably won't be enough!)

    — Posts automatically merged - Please don't double post! —

    @handheldvet I'll PM you some instructions in a minute.
     
    Last edited by GalladeGuy, Feb 29, 2016
    Magical Sheep likes this.
  18. handheldvet
    OP

    handheldvet Advanced Member

    Newcomer
    68
    4
    Feb 29, 2016
    Sounds wonderful, so I can 100% play 3DS games with this method?
     
  19. TheNerdWIzard

    TheNerdWIzard GBAtemp Regular

    Member
    233
    104
    Jun 7, 2015
    United States
    Yes. I have hack both of my 3DSes. I can also answer questions you may have. If you can successfully use broswerhax to boot up the homebrew loader, it will make the whole process easier. http://yls8.mtheall.com/3dsbrowserhax.php Please go to the homebrew section to find out more about homebrew. There is homebrew that can setup emunand. I need to go now so I can't provide more information atm.
     
  20. handheldvet
    OP

    handheldvet Advanced Member

    Newcomer
    68
    4
    Feb 29, 2016
    Well I've not yet got a console. I'm guessing though I should end up with one before the end of today :)