Please help me find software to run my card on my DSi!

Discussion in 'NDS - Flashcarts and Accessories' started by sum1quiet, Sep 9, 2012.

  1. sum1quiet
    OP

    sum1quiet Newbie

    Newcomer
    3
    0
    Sep 9, 2012
    A fairly long time ago, I bought a flashcart for my DSi and it worked just fine. Tried a load of games, all worked.

    I've since tried to play Pokémon White, but it wouldn't run. So I looked around a bit, thought maybe I needed to try a different firmware. I'm not very knowledgeable in this area so I don't know all the different cards and permutations of software that will run on them, but I tried loads (Wood, AKAIO, RetroGameFan, YSMenu, TTMenu) and I could not get the thing to work. I even tried updating my DSi in the hope that it would work on a newer firmware, which in hindsight may have screwed me over...

    I've uploaded a picture of the card and the PCB here. The software that I got from the site listed on the card won't even boot, I just get a screen saying an error has occurred and to read the Nintendo operation manual. The card is identified by the DSi as 'Danny Phantom Urban Jungle THQ'.

    Appreciate if anyone can help me get this thing working again :)

    Thanks
     
  2. TheDreamLord

    TheDreamLord GBAtemp Advanced Fan

    Member
    926
    103
    Jun 8, 2011
    Ireland
    Do you have another DS? Also, it seems to be a crappy clone. Not entirely sure..
     
  3. DragorianSword

    DragorianSword GBAtemp's #1 Gunter

    Member
    614
    158
    Oct 31, 2008
    Belgium
    Try this one: http://www.r4i.ndsi.in/download/V3.0/R4GOLDv3.0_EN.zip
    Also it's best you format the card before doing this (backup your games and saves before you do!)
     
  4. assassin98

    assassin98 GBAtemp Regular

    Member
    157
    0
    Apr 30, 2011
    Pakistan
    If u R4 is really a clone like mine (r4i-dshc) ,u can run some r4 clone firmware.like i did i could run some r4 clone firmwares. get this kernal and try it:http://r4i-dshc.com/downloade.asp
    they didnt release a new kernal from a long time so to play new games u might need to use RGF
    HOPE THIS WORKS!!!
     
  5. EyeZ

    EyeZ GBAtemp Addict

    Member
    2,496
    523
    Dec 4, 2009
    The error message you are receiving indicates you have updated your DSi which means your R4i will no longer work on your DSi.

    You will need to go to the website of your R4i to see if they have released an update patch (that's if your R4i is upgradable)
     
  6. sum1quiet
    OP

    sum1quiet Newbie

    Newcomer
    3
    0
    Sep 9, 2012
    I had a look on their site (www.r4ids.com) and there seems to be nothing that relates to the card that I have. Isn't it possible to patch it using another clone's update? As you can see in the picture of the PCB, the IC is the same one that's used in other clones so I don't understand why I can't just update it using another software patch.

    Has anyone else done this?
     
  7. 0reo

    0reo Member

    Newcomer
    14
    1
    Jul 30, 2012
    United States
    Montana
    I would be careful doing this as I had a clone with a very similar PCB and it would brick when trying to use any other firmware or kernel. I went through 3 of them just playing with different kernels and loaders and rarely would another clone's kernel/firmware work. Your best bet is to upgrade your flash cart, but you might be able to find a suitable update with some diligence.
    -edit (By firmware I was meaning the update patch. Sorry for the confusion)
     
  8. Rydian

    Rydian Resident Furvert™

    Member
    27,883
    8,111
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters
    It's not just about the main chip model, bootloader/firmware updates are cart-specific for various technical reasons, and the updates often have clone checks built into them and will refuse to run on anything other than the cart type it was meant for, to prevent competitors from leeching the updates.

    Updates for a cart will come from the site printed on the cart. If the site/team no longer supports that card, than you should get a new one with support.
    http://gbatemp.net/t290097-which-flash-cart-should-i-get

    What Oreo is talking about (kernels/loaders) is a separate issue from what you have.
     
  9. 2DBOY

    2DBOY Banned

    Banned
    24
    0
    Sep 16, 2012
    United States
    Yeah what he is talking about is separate. Try it again.
     
  10. eggsample

    eggsample punahussy

    Member
    529
    56
    Mar 29, 2010
    Poland
    This flashcard works with dsi 1.4 and older OS versions and it's not upgradable for future system. It has HW limitations, sorry. Get some another card, AK2i, R4i-SDHC, DSTwo, or one of the officialy supported by YWG Wood firmwares. Check shoptem.
     
  11. warior

    warior Member

    Newcomer
    14
    0
    Mar 14, 2009
    got the same card recently. Found that my card is equal with R4i Gold Non-3DS from www.r4ids.cn and can run WOOD R4i kernel from there.
    Then patched mine to work with my DSi v1.4.4, more you can read here - Upgrading the firmware of old R4i Gold r4ids.com card
    (btw, before patching it has danny phantom urban jungle icon, after patch for 1.44dsi icon changed to deep labyrinth)
     
  12. sum1quiet
    OP

    sum1quiet Newbie

    Newcomer
    3
    0
    Sep 9, 2012
    Thanks for the advice :) I don't have access to another DSi / 3DS so for the time being I can't downgrade it but hopefully I can borrow one at some point so I can try your suggestion. Thanks to all who've given advice.