Please help! Going Mad trying to get SD card set up for Homebrew

Discussion in 'Wii U - Homebrew' started by Flevans, May 25, 2017.

  1. Flevans
    OP

    Flevans Newbie

    Newcomer
    9
    0
    May 25, 2017
    Hey all

    First post here....

    I'm fairly tech savvy, so no noob, but only now just got around to trying to get loadiine up and running on my Wii U.

    I've tried 6 different SD cards - from older 2gig to new sans disk c10 64gb SDXC card. All formatted FAT32. I've tried each with 32 / 64 cluster size, different formatting techniques (MACOS - disk utility and terminal, Panasonic SDformatter and Windows Fat32 formatter as well as combinations of the two!) and NOTHING works.

    I always get the FS Mountsource failed error.

    None of the cards will save Mii's (it just says no SD card inserted). When I go to the Wii Menu and look at the SD page, when I insert the SD card it says 'reading' (so it recognises that there is a card being inserted) but every time says this card cannot be used.

    I've cleaned the SD slot, compressed air then next time around with isopropyl alcohol and pipe cleaners....

    ALL cards recognised on my laptops etc.

    SO - can I safely assume that, despite NEVER being used before, that the SD slot is f*cked, or am I still missing something?!?

    Any help hugely appreciated thanks.
     
  2. Lglaplante

    Lglaplante GBAtemp Fan

    Member
    312
    27
    Feb 12, 2017
    Canada
    Do you have the files for hbl? If no, download them, put them on your sd card and everything should work
     
  3. Flevans
    OP

    Flevans Newbie

    Newcomer
    9
    0
    May 25, 2017
    Thanks for reply.
    Yep, have hbl files, on card (or all cards) in correct place etc
     
  4. Lglaplante

    Lglaplante GBAtemp Fan

    Member
    312
    27
    Feb 12, 2017
    Canada
    Latest Firmware? If yes, try again to see, otherwise go check on the wii u homebrew launcher on gbatemp, there is a few error codes and how to fix them
     
  5. Flevans
    OP

    Flevans Newbie

    Newcomer
    9
    0
    May 25, 2017
    firmware is 5.5.1
    I'll give that thread a look, thanks.
    However every other thread I've looked at I've tried every suggestion!!
     
  6. Flevans
    OP

    Flevans Newbie

    Newcomer
    9
    0
    May 25, 2017
    Hi again
    There is nothing on the homebrew thread that I can see that I haven't tried.
    It's really frustrating because I can't believe the SD slot would be broken!!
    If anyone else has had similar experiences and solved them somehow, I'd be hugely grateful if you could get in touch.
     
  7. killmister2

    killmister2 Advanced Member

    Newcomer
    87
    23
    Jan 24, 2017
    Canada
    Since you formatted the SD card on a Mac, maybe it switched your SD card to GUID instead of MBR.
     
  8. Flevans
    OP

    Flevans Newbie

    Newcomer
    9
    0
    May 25, 2017
    Again thanks for the response. I run windows inside my mac so (using EaseUS this time!) I can confirm that it's formatted as Fat32 / Primary / MBR
     
  9. Reecey

    Reecey Mario 64 (favorite game of all time)

    Member
    4,358
    1,129
    Mar 7, 2010
    At Home :)
    It sounds like your using cheap sd cards and that can be a real problem! this fsmountsource error is due to using sub-standard sd cards. Have you got your sd card set up properly> wiiu/apps/..... also download the free mini tool partition app to format your cards, you want too select your sd card then click on format partition, and you want fat32, primary, 64kb cluster and apply. Just a quick pointer, I presume you have not got the lock on your sd card when you have pushed it in the sd slot?

    If I ever get this issue I wipe the sd card with a soft cloth and give the sd slot on the wiiu a good blow and maybe push it in and out a few times and on your last go push it in hard and keep your finger pressed on it in the slot for a few seconds and then let go of the card again with it in the slot. Try this and load your homebrew again?
     
    Last edited by Reecey, May 25, 2017
  10. killmister2

    killmister2 Advanced Member

    Newcomer
    87
    23
    Jan 24, 2017
    Canada
    Well, if you are FAT32 MBR, and your SD card is working properly on your PC, but can't be used on your Wii U even for standard Mii saves... Only thing left I might think about, before saying your Wii U SD Slot is defective, is maybe hidden system files polluting (I got that issue before with hidden OSX files).

    Maybe also try to redownload all the homwbrew apps (HBL, etc.). I got once an issue with TCP Gecko (HBL freezing when my TCP Gecko files were on my SD, and still don't know what gone wrong with it... I just redownloaded TCP Gecko and start over then it worked).

    Maybe try to run a CRC check on your SD Card, maybe it's corrupted/not really working properly).
     
    Last edited by killmister2, May 25, 2017
  11. Flevans
    OP

    Flevans Newbie

    Newcomer
    9
    0
    May 25, 2017
    Thanks for all your responses!
    I will check again for hidden files, but have fully formatted away from MacOS!
    I'm also using genuine high quality SD cards and have cleaned the contacts on the card and the Wii U! (This error has replicated across 6 different SD cards, all either Sansdisk or Panasonic)
    I'll have a look at all the points you guys have raised, will reformat and re-download HBL etc and will report back...
    Thanks!
     
  12. Flevans
    OP

    Flevans Newbie

    Newcomer
    9
    0
    May 25, 2017
    Well I've tried all of these things. Another full format, re-downloaded HBL file and still the FSsourcemount failed error. I really don't know what else to try, but I'm not sure it's worth the hassle of trying to get the SD slot repaired, but I'm really gutted - I've been trying everything for the last 3/4 days and made no progress! If anyone has any other ideas or can think of any other way I can test the SD card slot, please let me know.
     
  13. killmister2

    killmister2 Advanced Member

    Newcomer
    87
    23
    Jan 24, 2017
    Canada
    It really starts to smell like your SD card reader is toasted :(

    Do you have a friend nearby with a Wii U? You might then try your SD card on his console, and check if it's the same behavior.
     
  14. Flevans
    OP

    Flevans Newbie

    Newcomer
    9
    0
    May 25, 2017
    I know!! It is looking that way eh?
    Annoyingly I don't know anyone else with a Wii U nearby so I can't test it out that way either.
    I'm having one final go at everything from scratch again and then I think I'll need to admit defeat...otherwise I'm going to go mad!!
    Thanks all for your help, if by some miracle I find a solution I'll let you know...
     
  15. Heran Bago

    Heran Bago Where do puyo come from?

    Member
    3,018
    441
    Nov 6, 2005
    United States
    Foggy California
    Do the SD cards work on the Wii U for non-homebrew purposes?

    Like ummm... uhh.... what even uses that... Like screenshots in smash bros. ?
     
  16. Flevans
    OP

    Flevans Newbie

    Newcomer
    9
    0
    May 25, 2017
    I've tried using them (and several of them) to save Mii QR codes and it asks me to insert SD card when it's already in there...
     
  17. Heran Bago

    Heran Bago Where do puyo come from?

    Member
    3,018
    441
    Nov 6, 2005
    United States
    Foggy California
    This more than anything makes the SD reader sound busted. Sorry there.
     
  18. fatsquirrel

    fatsquirrel GBAtemp Advanced Maniac

    Member
    1,954
    1,461
    Nov 11, 2013
    SD reader is such a shit in WiiU really.
    Sorry mate :(
     
  19. Lglaplante

    Lglaplante GBAtemp Fan

    Member
    312
    27
    Feb 12, 2017
    Canada
    Getting errors too... SD carddetected, but when I launch it, it say like FS(don't remember), and there nothing about this