1. loopout

    OP loopout Newbie
    Newcomer

    Joined:
    May 26, 2017
    Messages:
    9
    Country:
    Good day mates,

    I plan to update my friend's Switch so he can play online again but I'm nervous because I had problems updating my switch, my SD got corrupted and now I have an unhacked Switch until I get time to rehack it.

    My plan is:

    (in this order)
    Update Atmosphere and Hekate to latest versions.
    Update fss0 sigpatches to latest version (because I use Deepsea).
    Check if emuMMC CFW (in 11.0 yet) launches correctly and boots games.
    UPDATE sysMMC clean to 12.0 with nintendo update service.
    Check if Hekate can now launch emuMMC and sysMMC without problems from the "launch" option (not reboot).

    Is this all correct? I just want to get sysMMC to latest, and stay on 11.0 on emuMMC so my friend can swap between them without using the jig (just using autoRCM).

    Does Atmosphere latest version and Hekate latest version have problems launching emuMMCs with 11.0? I'm just nervous because I read a lot of changes were made so Maybe new Atmosphere version can't boot that older fw on emuMMC.

    Thanks a lot buddies.
     
  2. thesjaakspoiler

    thesjaakspoiler GBAtemp Regular
    Member

    Joined:
    Nov 20, 2018
    Messages:
    298
    Country:
    Afghanistan
    Also note that the game cart reader was updated in 12.0
    So you also have to choose if you want to use it on either 12.0 or 11.0.
    You can block the update in the 12.0 update so you can keep on using it on the 11.0 but
    you cannot use it with the 12.0 fw then.

    Are there any games out there that actually do need the 12.0 fw?
     
  3. petspeed

    petspeed GBAtemp Advanced Fan
    Member

    Joined:
    Nov 13, 2009
    Messages:
    692
    Country:
    Denmark
    I am not using the stock function in Hekate because I boot SysMMC normally but does stock mode use AMS at all? If not then there is no need to update AMS in your case. Just update Hekate to the latest version and then update SysMMC. As mentioned I am not using this so I am not sure this will work, just an idea. It would make the upgrade a lot easier.
     
  4. loopout

    OP loopout Newbie
    Newcomer

    Joined:
    May 26, 2017
    Messages:
    9
    Country:
    Absolutely, would be a lot easier, but I thought the new version of hekate could have problems booting older atmosphere versions because of the big changes in this update. Will try that if no one gives more advice, thanks!
     
  5. Draxzelex

    Draxzelex GBAtemp Legend
    Member

    Joined:
    Aug 6, 2017
    Messages:
    14,895
    Country:
    United States
    If newer versions of Atmosphere and Hekate have problems launching older firmware versions, that should be brought up immediately because they are supposed to support ALL firmware versions not just the latest. The whole point of an update for CFW is to add support, not replace it just because there is a newer firmware version. They simply cannot assume everyone is on the same firmware let alone the latest.
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - Planning, letting, update