TEMPORARY MODE ENABLED
New posts, edits, and any changes will not be saved during the transition period.
Registrations are temporarily disabled until the migration is complete.

  1. pavachan

    OP pavachan Member
    Newcomer

    Joined:
    May 28, 2010
    Messages:
    17
    Country:
    Iceland
    Hello all.

    I am having a strange issue.
    On a n3DS 9.0, I installed the gateway emunand, and updated it to 9.5. All works well, CIA's, etc.

    Using Ninjahax, I used rxTools and later PastaCFW to get into sig-patched sysNand 9.0 and installed both GBA cia files and 1 DSiWare cia file using BigBlueMenu
    .
    Now, all of that works great on my o3DS, but for some reason, on this n3DS, the icon of Zelda 4 Swords DSiWare disappears from the home menu after installing the cia, and while the gba icons don't disappear, I can't launch any of them (An error has occurred, please hold the power button bla bla bla).

    The icon disappears and the gba's wont launch both in rxTools / Pasta sysnand, and in rxTools emunand.
    The CIA files are of course installed both in sysnand and emunand separately as I unlinked it.

    If I boot into regular Gateway emunand, the Zelda DSiWare shows up, but I of course cant launch it.

    Everything else works in both rxTools and PastaCFW. I can run normal unsigned installed CIAs, like BigBlueMenu, but it seems like AGB_Firm and TWL_Firm are not getting patched no matter which CFW I use.

    Any help or tips would be appreciated.

    Thanks :)
     
  2. Ronhero

    Ronhero Too Weird to Live, Too Rare to Die
    Member

    Joined:
    Jun 28, 2014
    Messages:
    3,470
    Country:
    United States
    You need the agb patch on sysnand. That will make gba work and dsi works if you install it to the nand not the sd; use fbi for the nand direction
     
  3. Tony_93

    Tony_93 GBAtemp Addict
    Member

    Joined:
    Jun 13, 2015
    Messages:
    2,453
    Country:
    United States
    GBA games have to installed in SD.
    DSiware games have to be installed to NAND.
     
    wormdood and Ronhero like this.
  4. Ronhero

    Ronhero Too Weird to Live, Too Rare to Die
    Member

    Joined:
    Jun 28, 2014
    Messages:
    3,470
    Country:
    United States
    You also need agb patch installed with dev menu
     
  5. Tony_93

    Tony_93 GBAtemp Addict
    Member

    Joined:
    Jun 13, 2015
    Messages:
    2,453
    Country:
    United States
    Not anymore, that was a thing on the past now rxTools plays GBA & DSiware without having to install patched firms.

    His problem is that DSiware can't be played in emunand no matter what CFW you use, only in sysnand while installed to NAND.

    Also DSiware neither GBA can't be played in Gateway, only CFW.
     
    Last edited by Tony_93, Nov 28, 2015
  6. Ronhero

    Ronhero Too Weird to Live, Too Rare to Die
    Member

    Joined:
    Jun 28, 2014
    Messages:
    3,470
    Country:
    United States
    Really? I tried it on pasta and rx 3.0 sys and always needed it. Maybe I'm doing it wrong
     
  7. capito27

    capito27 GBAtemp Advanced Fan
    Member

    Joined:
    Jan 19, 2015
    Messages:
    874
    Country:
    Swaziland
    both of you are right, for now, RxTools patches on the fly the AGB and TWL firms on O3DS, but it doesn't work yet for N3DS,but we are working on it, so it should be supported on N3DS...sometime (can't really tell precisely, because we are working on multiple projects at the same time, some exciting stuff.)
     
    noctis90210, Ronhero and peteruk like this.
  8. Ronhero

    Ronhero Too Weird to Live, Too Rare to Die
    Member

    Joined:
    Jun 28, 2014
    Messages:
    3,470
    Country:
    United States
    Thanks for the update and for all the hard work. Nice to know I'm not crazy or doing it wrong
     
    peteruk likes this.
  9. pavachan

    OP pavachan Member
    Newcomer

    Joined:
    May 28, 2010
    Messages:
    17
    Country:
    Iceland
    Oh I had no idea this wasn't supported yet.

    No prob, I will wait :)
    Thanks a lot ^_^
     
  10. Ronhero

    Ronhero Too Weird to Live, Too Rare to Die
    Member

    Joined:
    Jun 28, 2014
    Messages:
    3,470
    Country:
    United States
    It works? You just need to do what I said above
     
  11. pavachan

    OP pavachan Member
    Newcomer

    Joined:
    May 28, 2010
    Messages:
    17
    Country:
    Iceland
    Thanks ronhero, I will give it a go.

    For the record, I wasn't trying to use gba or dsi games in gateway emunand. only in rx/pasta sysnand and rx emunand- basically all that worked for me on Old 3DS.

    Thanks all :)
     
  12. Mr_Q

    Mr_Q Member
    Newcomer

    Joined:
    Jun 30, 2006
    Messages:
    27
    Country:
    I had exactly the same issue as you had; the icon disappeared. Eventually I found out it had to do with the region of the DSiWare.. I had the US version of this game, while I should have had the European version, the same as my New 3DS XL.

    I installed the game using FBI (select NAND as target) in emunand and sysnand. My emunand and sysnand are unlinked but I can still boot Four Swords from emunand. When I would like to start it from sysnand, I first need to launch CFW like minipasta.

    NOTE: I do have the patched AGB firmware installed (on both sysnand and emunand) for playing GBA games. I read this is also required for DSI-games but I'm not sure.
     
    Last edited by Mr_Q, Jan 31, 2016
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - PastaCFW, rxTools, DSiWare