Homebrew RELEASE ovl-sysmodules - A Tesla Overlay to toggle Sysmodules

kylum

Well-Known Member
Member
Joined
Dec 8, 2008
Messages
325
Trophies
0
XP
1,104
Country
United States
Sys-ftpd-light and sys-con both are activated on startup while others are not(sys-clk) . Since I really don’t use sysmodules often enough it would be nice for those to be off by default. Is there a way to change this behavior for those two sysmodules?
 
Last edited by kylum,

bad361

Well-Known Member
Member
Joined
Jun 18, 2018
Messages
1,044
Trophies
0
Location
Moscow
XP
1,658
Country
Russia
Sys-ftpd-light and sys-con both are activated on startup while others are not(sys-clk) . Since I really don’t use sysmodules often enough it would be nice for those to be off by default. Is there a way to change this behavior for those two sysmodules?
Why would you even care? They are literally background system services that don't drain almost any battery. You can just delete them if you don't use them i guess, otherwise just leave them on.
 

kylum

Well-Known Member
Member
Joined
Dec 8, 2008
Messages
325
Trophies
0
XP
1,104
Country
United States
Why would you even care? They are literally background system services that don't drain almost any battery. You can just delete them if you don't use them i guess, otherwise just leave them on.
I never said I don’t use them. Why would I even take the time to setup the overlay for them if I didn’t use them? Since these are services that can be toggled on/off on the fly without a reboot. It makes sense to me that they would be set to off by default. It’s just my personal preference if it is deed an option, if not than that’s ok too.
 
  • Like
Reactions: crazy_p

LightBeam

Well-Known Member
Member
Joined
Oct 1, 2018
Messages
501
Trophies
0
XP
1,372
Country
France
I believe he said that you would need to ask the devs to update their modules to appear in Kosmos Toolbox, because the overlay is basically the same than Kosmos Toolbox
 

octopus

Custom Title
Member
Joined
Sep 6, 2013
Messages
412
Trophies
0
Location
/
XP
1,183
Country
Somalia
Only the modules that do not require reboot will appear in the overlay. You don't need to wait for anyone, you can create related toolbox.json yourself. The only thing that you need to figure out is whether it requires reboot or not. If it does, it won't toggle with the overlay.
 
Last edited by octopus,

kylum

Well-Known Member
Member
Joined
Dec 8, 2008
Messages
325
Trophies
0
XP
1,104
Country
United States
They appear just fine in the overlay and I can turn them off and on at will. My question is how to make the sysmodules that don’t require a reboot to be toggled off during startup/boot. In other word, turning them on when needed not just constantly running in the background. Example: sys-ftp is on and running on boot/startup. I then turn it off, when I perform reboot sys-ftp is on again. This isn’t a big deal it’s just that I might only use ftp once a month so why have it on by default.
 

octopus

Custom Title
Member
Joined
Sep 6, 2013
Messages
412
Trophies
0
Location
/
XP
1,183
Country
Somalia
They appear just fine in the overlay and I can turn them off and on at will. My question is how to make the sysmodules that don’t require a reboot to be toggled off during startup/boot. In other word, turning them on when needed not just constantly running in the background. Example: sys-ftp is on and running on boot/startup. I then turn it off, when I perform reboot sys-ftp is on again. This isn’t a big deal it’s just that I might only use ftp once a month so why have it on by default.
It's because this overlay launches / terminates processes. The boot2.flag is kept intact. Either turn them off with Kosmos Toolbox or manually delete corresponding boot2.flags.
 
D

Deleted User

Guest
Yeah this is definitely something kudos. I am scared to use this atm but am definitely monitoring your progress.
 
  • Like
Reactions: WerWolv

kylum

Well-Known Member
Member
Joined
Dec 8, 2008
Messages
325
Trophies
0
XP
1,104
Country
United States
It's because this overlay launches / terminates processes. The boot2.flag is kept intact. Either turn them off with Kosmos Toolbox or manually delete corresponding boot2.flags.
Deleted the boot2.flags to the ones I wanted to be off on startup and it’s working great.

Thank you!

Thank you @WerWolv for this and everything else that goes with it!
 

caUnknown

Active Member
Newcomer
Joined
Sep 29, 2019
Messages
44
Trophies
0
Age
39
XP
294
Country
Canada
'emuiibo was not accessed' showing in tesla overlay. It appears under 'static' in sysmodules but cannot be changed from the 'off' position. can anyone help me figure this out? thanks
 
General chit-chat
Help Users
    Psionic Roshambo @ Psionic Roshambo: lol